aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tiffgt
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-06-11 00:15:24 +0800
committerdinoex <dinoex@FreeBSD.org>2014-06-11 00:15:24 +0800
commit61b200d7c9202cda49170a39a9fe831a8341ea3c (patch)
tree4f691f5882e87cdf09cb4801599d9bafdce86fb2 /graphics/tiffgt
parent9045f4d1bd490eff11c0b56b9dd1c89380574056 (diff)
downloadfreebsd-ports-gnome-61b200d7c9202cda49170a39a9fe831a8341ea3c.tar.gz
freebsd-ports-gnome-61b200d7c9202cda49170a39a9fe831a8341ea3c.tar.zst
freebsd-ports-gnome-61b200d7c9202cda49170a39a9fe831a8341ea3c.zip
This software provides support for the Tag Image File Format (TIFF),
a widely used format for storing image data. Included in this software distribution is a small collection of tools for doing simple manipulations of TIFF images on UNIX systems. LICENSE: Permission to use, copy, modify, distribute, and sell for any purpose WWW: http://www.remotesensing.org/libtiff/ PR: 190816
Diffstat (limited to 'graphics/tiffgt')
-rw-r--r--graphics/tiffgt/Makefile42
-rw-r--r--graphics/tiffgt/distinfo2
-rw-r--r--graphics/tiffgt/files/patch-Makefile.in31
-rw-r--r--graphics/tiffgt/pkg-descr9
4 files changed, 84 insertions, 0 deletions
diff --git a/graphics/tiffgt/Makefile b/graphics/tiffgt/Makefile
new file mode 100644
index 000000000000..d6fa19c4675b
--- /dev/null
+++ b/graphics/tiffgt/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= tiffgt
+PORTVERSION= 4.0.3
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
+ http://download.osgeo.org/libtiff/
+DISTNAME= tiff-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= X11 Tools for working with TIFF images
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libjbig.so:${PORTSDIR}/graphics/jbigkit \
+ libtiff.so:${PORTSDIR}/${PKGCATEGORY}/tiff
+
+#TODO: Remove :oldver together with VERSION_INFO patching in pre-configure.
+USES= libtool:oldver
+USE_XORG= sm ice xmu xi x11
+USE_GL= glut glu gl
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-jpeg-include-dir=${LOCALBASE}/include \
+ --with-jpeg-lib-dir=${LOCALBASE}/lib \
+ --with-x --with-libgl
+PLIST_FILES= bin/tiffgt man/man1/tiffgt.1.gz
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's|^LIBTIFF_VERSION_INFO =.*$$|LIBTIFF_VERSION_INFO = 4:0:0|' \
+ ${WRKSRC}/libtiff/Makefile.in
+ ${REINPLACE_CMD} -e 's|^docfiles|no-docfiles|' \
+ -e 's|man html|man|' ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tools/.libs/tiffgt ${STAGEDIR}/${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/man/tiffgt.1 ${STAGEDIR}${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/graphics/tiffgt/distinfo b/graphics/tiffgt/distinfo
new file mode 100644
index 000000000000..983494f5b66e
--- /dev/null
+++ b/graphics/tiffgt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tiff-4.0.3.tar.gz) = ea1aebe282319537fb2d4d7805f478dd4e0e05c33d0928baba76a7c963684872
+SIZE (tiff-4.0.3.tar.gz) = 2051630
diff --git a/graphics/tiffgt/files/patch-Makefile.in b/graphics/tiffgt/files/patch-Makefile.in
new file mode 100644
index 000000000000..f055fcd7e404
--- /dev/null
+++ b/graphics/tiffgt/files/patch-Makefile.in
@@ -0,0 +1,31 @@
+--- Makefile.in.orig 2012-09-22 18:08:18.000000000 +0200
++++ Makefile.in 2012-10-13 19:35:28.000000000 +0200
+@@ -375,7 +375,7 @@
+
+ dist_doc_DATA = $(docfiles)
+ SUBDIRS = port libtiff tools build contrib test man html
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libtiff-4.pc
+ all: all-recursive
+
+@@ -427,19 +427,6 @@
+ -rm -f libtool config.lt
+ install-dist_docDATA: $(dist_doc_DATA)
+ @$(NORMAL_INSTALL)
+- @list='$(dist_doc_DATA)'; test -n "$(docdir)" || list=; \
+- if test -n "$$list"; then \
+- echo " $(MKDIR_P) '$(DESTDIR)$(docdir)'"; \
+- $(MKDIR_P) "$(DESTDIR)$(docdir)" || exit 1; \
+- fi; \
+- for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- echo "$$d$$p"; \
+- done | $(am__base_list) | \
+- while read files; do \
+- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
+- $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
+- done
+
+ uninstall-dist_docDATA:
+ @$(NORMAL_UNINSTALL)
diff --git a/graphics/tiffgt/pkg-descr b/graphics/tiffgt/pkg-descr
new file mode 100644
index 000000000000..75bfe7ee2617
--- /dev/null
+++ b/graphics/tiffgt/pkg-descr
@@ -0,0 +1,9 @@
+This software provides support for the Tag Image File Format (TIFF),
+a widely used format for storing image data.
+
+Included in this software distribution is a small collection of tools
+for doing simple manipulations of TIFF images on UNIX systems.
+
+LICENSE: Permission to use, copy, modify, distribute, and sell for any purpose
+
+WWW: http://www.remotesensing.org/libtiff/