aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tintfu
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
committerlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
commitb52944915a792d1df1b4539b6ffef32bb06c623c (patch)
tree2d2342fe8b657b24efa68b7b0eedf07f0880f0b9 /graphics/tintfu
parentcf6c4b2a7fb04e6bebe556711940aa746e81c384 (diff)
downloadfreebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.gz
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.zst
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Diffstat (limited to 'graphics/tintfu')
-rw-r--r--graphics/tintfu/Makefile2
-rw-r--r--graphics/tintfu/files/tintfu.sh.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/tintfu/Makefile b/graphics/tintfu/Makefile
index c31c0cf0c99b..a38a98ed207b 100644
--- a/graphics/tintfu/Makefile
+++ b/graphics/tintfu/Makefile
@@ -25,7 +25,7 @@ EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= .
NO_BUILD= yes
USE_JAVA= yes
-JAVA_VERSION= 1.3+
+JAVA_VERSION= 1.5+
PLIST_FILES= %%JAVAJARDIR%%/${DISTNAME}.jar \
bin/tintfu
diff --git a/graphics/tintfu/files/tintfu.sh.in b/graphics/tintfu/files/tintfu.sh.in
index 4a44d0645a0a..c766004fc83c 100644
--- a/graphics/tintfu/files/tintfu.sh.in
+++ b/graphics/tintfu/files/tintfu.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION="1.3+" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/%%DISTNAME%%.jar"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/%%DISTNAME%%.jar"