aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tkpng
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-10-08 19:17:49 +0800
committersat <sat@FreeBSD.org>2006-10-08 19:17:49 +0800
commitbf4e3aa375a5f1e4ec582e2b6ef435ad4d3bdad2 (patch)
tree4ebba7885c178ccd7e0bdd5ff1b544e317ada290 /graphics/tkpng
parent71b086d1b12b67b6b6341ffd87c2ba9cf478c261 (diff)
downloadfreebsd-ports-gnome-bf4e3aa375a5f1e4ec582e2b6ef435ad4d3bdad2.tar.gz
freebsd-ports-gnome-bf4e3aa375a5f1e4ec582e2b6ef435ad4d3bdad2.tar.zst
freebsd-ports-gnome-bf4e3aa375a5f1e4ec582e2b6ef435ad4d3bdad2.zip
Add port graphics/tkpng:
This port implements support for loading and using PNG images with Tcl/Tk. Although other extensions such as Img also add support for PNG images, I wanted something that was lightweight, did not depend on libpng, and which would be suitable for inclusion in the Tk core, as Tk does not currently support any image formats natively that take advantage of its internal support for alpha blending, and alpha antialiasing and drop shadows really go a long way toward beautifying Tk applications. At this time, the package supports reading images from files or binary data. Base64 decoding is supported as of version 0.6. Exporting images to PNG format is not supported yet. The package supports the full range of color types, channels and bit depths from 1 bit black & white to 16 bit per channel full color with alpha (64 bit RGBA) and interlacing. Ancillary "chunks" such as gamma, color profile, and text fields are ignored, although they are checked at a minimum for correct CRC. WWW: http://www.muonics.com/FreeStuff/TkPNG/ Author: Michael Kirkham <mikek@muonics.com>
Diffstat (limited to 'graphics/tkpng')
-rw-r--r--graphics/tkpng/Makefile38
-rw-r--r--graphics/tkpng/distinfo3
-rw-r--r--graphics/tkpng/pkg-descr20
-rw-r--r--graphics/tkpng/pkg-plist4
4 files changed, 65 insertions, 0 deletions
diff --git a/graphics/tkpng/Makefile b/graphics/tkpng/Makefile
new file mode 100644
index 000000000000..2c681d2f3bb6
--- /dev/null
+++ b/graphics/tkpng/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tkpng
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkpng
+PORTVERSION= 0.7
+CATEGORIES= graphics tk84
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= PNG support for Tcl/Tk
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --with-tclinclude=${LOCALBASE}/include/tcl${TK_VER}/generic \
+ --with-tkinclude=${LOCALBASE}/include/tk${TK_VER}/generic \
+ --exec-prefix=${PREFIX} --enable-shared
+CPPFLAGS= -I${LOCALBASE}/include/tk${TK_VER}/generic -I${X11BASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG} TKLIBVER=${TKLIBVER}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+WRKSRC= ${WRKDIR}/${TKPKG}
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so \
+ ${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so.0
+
+.include <bsd.port.mk>
diff --git a/graphics/tkpng/distinfo b/graphics/tkpng/distinfo
new file mode 100644
index 000000000000..2221a17ecc52
--- /dev/null
+++ b/graphics/tkpng/distinfo
@@ -0,0 +1,3 @@
+MD5 (tkpng0.7-src.tgz) = 81965db9ad4bfe7aa11554dc551dd088
+SHA256 (tkpng0.7-src.tgz) = b4778961268de5e33cf73830d92f6b7f4d1b65bf05f630af5790bcfef1eca36d
+SIZE (tkpng0.7-src.tgz) = 115821
diff --git a/graphics/tkpng/pkg-descr b/graphics/tkpng/pkg-descr
new file mode 100644
index 000000000000..0cca393eb2a8
--- /dev/null
+++ b/graphics/tkpng/pkg-descr
@@ -0,0 +1,20 @@
+This port implements support for loading and using PNG images with
+Tcl/Tk. Although other extensions such as Img also add support for PNG
+images, I wanted something that was lightweight, did not depend on libpng,
+and which would be suitable for inclusion in the Tk core, as Tk does not
+currently support any image formats natively that take advantage of its
+internal support for alpha blending, and alpha antialiasing and drop shadows
+really go a long way toward beautifying Tk applications.
+
+At this time, the package supports reading images from files or binary
+data. Base64 decoding is supported as of version 0.6. Exporting images
+to PNG format is not supported yet.
+
+The package supports the full range of color types, channels and bit
+depths from 1 bit black & white to 16 bit per channel full color
+with alpha (64 bit RGBA) and interlacing. Ancillary "chunks" such
+as gamma, color profile, and text fields are ignored, although they
+are checked at a minimum for correct CRC.
+
+WWW: http://www.muonics.com/FreeStuff/TkPNG/
+Author: Michael Kirkham <mikek@muonics.com>
diff --git a/graphics/tkpng/pkg-plist b/graphics/tkpng/pkg-plist
new file mode 100644
index 000000000000..7d2e230352e2
--- /dev/null
+++ b/graphics/tkpng/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%TKPKG%%/lib%%TKPKG%%.so
+lib/%%TKPKG%%/lib%%TKPKG%%.so.0
+lib/%%TKPKG%%/pkgIndex.tcl
+@dirrm lib/%%TKPKG%%