aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/togl/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-09-25 00:01:31 +0800
committertaoka <taoka@FreeBSD.org>1999-09-25 00:01:31 +0800
commit582e50e896fb788361a846f3b2287d44fc9cf117 (patch)
treecc35affef96993f4ec53cbaa4154b522cc139eca /graphics/togl/Makefile
parent3e8e4137c3f032dd287e42c0c3fc0ab20add0f96 (diff)
downloadfreebsd-ports-gnome-582e50e896fb788361a846f3b2287d44fc9cf117.tar.gz
freebsd-ports-gnome-582e50e896fb788361a846f3b2287d44fc9cf117.tar.zst
freebsd-ports-gnome-582e50e896fb788361a846f3b2287d44fc9cf117.zip
An OpenGL Widget for Tk
PR: 13296 Submitted by: Randall Hopper <aa8vb@ipass.net>
Diffstat (limited to 'graphics/togl/Makefile')
-rw-r--r--graphics/togl/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
new file mode 100644
index 000000000000..5238a0a229e4
--- /dev/null
+++ b/graphics/togl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Togl
+# Version required: 1.5
+# Date created: Wed Aug 18 18:49:17 EDT 1999
+# Whom: Randall Hopper <aa8vb@ipass.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Togl-1.5
+PKGNAME= togl-1.5
+CATEGORIES= graphics tk80
+MASTER_SITES= ftp://ftp.mesa3d.org/mesa/misc/ \
+ ftp://ftp.cs.umd.edu/pub/faculty/bederson/
+
+MAINTAINER= aa8vb@ipass.net
+
+LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80 \
+ tcl80.1:${PORTSDIR}/lang/tcl80 \
+ MesaGL.14:${PORTSDIR}/graphics/Mesa3
+
+ALL_TARGET= default
+
+TOGL_INSTDIR= ${PREFIX}/lib/tk8.0/${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${TOGL_INSTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/libtogl.so.1.3 ${TOGL_INSTDIR}/Togl.so
+ ${ECHO} 'package ifneeded Togl 1.5 [list load [file join $$dir Togl.so]]'\
+ > ${PREFIX}/lib/tk8.0/${DISTNAME}/pkgIndex.tcl
+
+.include <bsd.port.post.mk>