aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/truevision/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-13 22:52:42 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-13 22:52:42 +0800
commitf4c4253f0ff7a2df183c7e382ee998339381f7f5 (patch)
tree11df6f91f700f433e972955dd51da054bb4de3ae /graphics/truevision/Makefile
parentbc7b3071e094a100d015c4c1e120030489040b05 (diff)
downloadfreebsd-ports-gnome-f4c4253f0ff7a2df183c7e382ee998339381f7f5.tar.gz
freebsd-ports-gnome-f4c4253f0ff7a2df183c7e382ee998339381f7f5.tar.zst
freebsd-ports-gnome-f4c4253f0ff7a2df183c7e382ee998339381f7f5.zip
GNOME policy:
- Fix detection of libintl and install .po files into ${PREFIX}/share/locale, not into ${PREFIX}/share/gnome/locale.
Diffstat (limited to 'graphics/truevision/Makefile')
-rw-r--r--graphics/truevision/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
index 485464e93b17..e5302818bb64 100644
--- a/graphics/truevision/Makefile
+++ b/graphics/truevision/Makefile
@@ -8,6 +8,7 @@
PORTNAME= truevision
PORTVERSION= 0.3.10
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,14 +19,18 @@ LIB_DEPENDS= gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea
USE_X_PREFIX= yes
USE_MESA= yes
-USE_GTK= yes
USE_GNOME= yes
-GNU_CONFIGURE= yes
-CFLAGS+= ${PTHREAD_FLAGS}
-CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_FLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-post-patch:
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@${PERL} -pi -e "s,Bison ,Bison,g" ${WRKSRC}/configure
@${PERL} -pi -e "s,-lgthread,-lgthread12,g ; \
s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/src/Makefile.in