aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ttygif
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-15 23:30:24 +0800
committermarino <marino@FreeBSD.org>2014-08-15 23:30:24 +0800
commit8332219ff27db4bf4714216c2b18c85b640aa02a (patch)
treea32a61b3531db029efc653674cccd58faa609e3e /graphics/ttygif
parent39ec74d3ce05fe03a53d8a411d6f21418058ea6c (diff)
downloadfreebsd-ports-gnome-8332219ff27db4bf4714216c2b18c85b640aa02a.tar.gz
freebsd-ports-gnome-8332219ff27db4bf4714216c2b18c85b640aa02a.tar.zst
freebsd-ports-gnome-8332219ff27db4bf4714216c2b18c85b640aa02a.zip
Add new port graphics/ttygif
PR: 190328 Submitted by: Olivier (cochard.me) ttygif permit to convert ttyrec record into animated gif. It's a 3 steps process: 1. Generate a ttyrecord file with misc/ttyrec 2. convert the ttyrecord in multiple image file with ttygif 3. convert the multiple image with a unique animated gif file with concat
Diffstat (limited to 'graphics/ttygif')
-rw-r--r--graphics/ttygif/Makefile32
-rw-r--r--graphics/ttygif/distinfo2
-rw-r--r--graphics/ttygif/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/graphics/ttygif/Makefile b/graphics/ttygif/Makefile
new file mode 100644
index 000000000000..b1c8825d56b8
--- /dev/null
+++ b/graphics/ttygif/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= ttygif
+PORTVERSION= 1.0.8
+CATEGORIES= graphics
+
+MAINTAINER= olivier@cochard.me
+COMMENT= Converts a ttyrec file into animated gif
+
+LICENSE= MIT
+
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+
+GH_ACCOUNT= icholy
+GH_COMMIT= ea0b493
+
+USES= tar:bzip2 gmake
+
+USE_GITHUB= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ bin/concat
+
+post-patch:
+ @${REINPLACE_CMD} 's:\#\!/bin/bash:\#\!/bin/sh:' ${WRKSRC}/concat.sh
+ @${REINPLACE_CMD} 's:gcc:${CC}:' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/concat.sh ${STAGEDIR}${PREFIX}/bin/concat
+
+.include <bsd.port.mk>
diff --git a/graphics/ttygif/distinfo b/graphics/ttygif/distinfo
new file mode 100644
index 000000000000..02930343f274
--- /dev/null
+++ b/graphics/ttygif/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ttygif-1.0.8.tar.bz2) = 005d8c6a45daac8ae0e6b1e701bf043a819e2ea61734c95ba600d3a44eaec255
+SIZE (ttygif-1.0.8.tar.bz2) = 5098
diff --git a/graphics/ttygif/pkg-descr b/graphics/ttygif/pkg-descr
new file mode 100644
index 000000000000..54ecf5ba586e
--- /dev/null
+++ b/graphics/ttygif/pkg-descr
@@ -0,0 +1,3 @@
+Ttygif converts a ttyrec file into animated gif (need a X11 terminal).
+
+WWW: https://github.com/icholy/ttygif