aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tulip
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/tulip
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/tulip')
-rw-r--r--graphics/tulip/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 2f33e9f195b8..68949be2a695 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -25,7 +25,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MOC="${MOC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" GLDIR="${X11BASE}"
+CONFIGURE_ENV= MOC="${MOC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" GLDIR="${LOCALBASE}"
CONFIGURE_ARGS= --with-qt-includes=${QT_PREFIX}/include \
--with-qt-libraries=${QT_PREFIX}/lib \
--with-extra-libs=${LOCALBASE}/lib
@@ -39,7 +39,7 @@ USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include -I${PREFIX}/include \
-I${QT_PREFIX}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
-LDFLAGS= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib \
+LDFLAGS= -Wl,-export-dynamic -L${LOCALBASE}/lib \
-ljpeg -L${QT_PREFIX}/lib -lcompat ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>