aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/vips/Makefile
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-06-18 02:39:34 +0800
committerrene <rene@FreeBSD.org>2014-06-18 02:39:34 +0800
commit1963479b04bc198b6fbea7f0385d30056749aa91 (patch)
treeb071cb41ba1a596b59d6d211e0b729242233a271 /graphics/vips/Makefile
parent540a253aba8f98975d69ef54a5de1cf8741fe89b (diff)
downloadfreebsd-ports-gnome-1963479b04bc198b6fbea7f0385d30056749aa91.tar.gz
freebsd-ports-gnome-1963479b04bc198b6fbea7f0385d30056749aa91.tar.zst
freebsd-ports-gnome-1963479b04bc198b6fbea7f0385d30056749aa91.zip
Update www/GraphicsMagick to 1.3.19 and bump PORTREVISION for consumers.
Note that graphics/GraphicsMagick12 was removed on 2014-05-20 because it is no longer maintained upstream. Detailed/other changes: * graphics/GraphicsMagick : - Copy contents from graphics/GraphicsMagick13 - Remove PORTREVISION and PKGNAMESUFFIX - Keep original pkg-descr, do not copy whitespace-only changes. * graphics/pecl-gmagick : - Use modern LIB_DEPENDS * graphics/vips : - Stage support - Use modern LIB_DEPENDS - USES libtool, pathfix * multimedia/bombono : - Update BUILD_DEPENDS and RUN_DEPENDS * textproc/htmltolatex : - Use modern LIB_DEPENDS Phabric: D108 162 Approved by: portmgr (antoine, bapt)
Diffstat (limited to 'graphics/vips/Makefile')
-rw-r--r--graphics/vips/Makefile34
1 files changed, 15 insertions, 19 deletions
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index ec3bef1acd5c..02605b57ce10 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vips
PORTVERSION= 7.26.3
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
@@ -16,29 +16,27 @@ LIBOIL_DESC= Use liboil for CPU-optimized primitives
PYTHON_DESC= Create Python bindings
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- exif:${PORTSDIR}/graphics/libexif \
- tiff:${PORTSDIR}/graphics/tiff \
- GraphicsMagick:${PORTSDIR}/graphics/GraphicsMagick \
- IlmImf:${PORTSDIR}/graphics/OpenEXR \
- orc-0:${PORTSDIR}/devel/orc \
- png15:${PORTSDIR}/graphics/png \
- matio:${PORTSDIR}/math/matio \
- lcms:${PORTSDIR}/graphics/lcms
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libexif.so:${PORTSDIR}/graphics/libexif \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ liborc-0.4.so:${PORTSDIR}/devel/orc \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libmatio.so:${PORTSDIR}/math/matio \
+ liblcms.so:${PORTSDIR}/graphics/lcms
PYPRESENT!= which python > /dev/null && echo on || echo off
.if ${PYPRESENT} == on
OPTIONS_DEFAULT+= PYTHON
.endif
-USES= gettext gmake perl5 pkgconfig
+USES= gettext gmake libtool pathfix perl5 pkgconfig
USE_PERL5= build
-USE_GNOME= gnomehack glib20 pango libxml2
-USE_AUTOTOOLS= libtool
+USE_GNOME= glib20 pango libxml2
USE_LDCONFIG= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-NO_STAGE= yes
post-configure:
${REINPLACE_CMD} -Ee 's,^(G?MSGFMT = *)$$,\1${LOCALBASE}/bin/msgfmt,g' \
${WRKSRC}/po/Makefile
@@ -52,15 +50,13 @@ EXTRA_PATCHES= ${FILESDIR}/nodoc-patch
PLIST_SUB+= VERSION=${PORTVERSION:R}
CONFIGURE_ENV+= MAGICK_CFLAGS="-I${LOCALBASE}/include/GraphicsMagick"
-CONFIGURE_ARGS+=--without-x --mandir=${PREFIX}/man --with-magickpackage=GraphicsMagick
+CONFIGURE_ARGS+=--without-x --mandir=${STAGEDIR}${PREFIX}/man --with-magickpackage=GraphicsMagick
CONFIGURE_ARGS+=--without-v4l
.for p in tiff jpeg zip png
CONFIGURE_ARGS+=--with-$p-includes=${LOCALBASE}/include
CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
.endfor
-.include "Makefile.man"
-
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PY=""
@@ -76,7 +72,7 @@ BROKEN= Does not compile on sparc64-9
.endif
.if ${PORT_OPTIONS:MLIBOIL}
-LIB_DEPENDS+= oil:${PORTSDIR}/devel/liboil
+LIB_DEPENDS+= liboil-0.3.so:${PORTSDIR}/devel/liboil
.else
CONFIGURE_ARGS+= --without-liboil
.endif