aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/vips
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2004-02-08 04:32:38 +0800
committerlev <lev@FreeBSD.org>2004-02-08 04:32:38 +0800
commit89c039b7cef3dddf4afb0907268775beae72425b (patch)
tree20c4e6c9c59fa36763e72cb7e0e8ee0b4a47af73 /graphics/vips
parent463589d14888914b0d89cfcd04fc592f08698d4e (diff)
downloadfreebsd-ports-gnome-89c039b7cef3dddf4afb0907268775beae72425b.tar.gz
freebsd-ports-gnome-89c039b7cef3dddf4afb0907268775beae72425b.tar.zst
freebsd-ports-gnome-89c039b7cef3dddf4afb0907268775beae72425b.zip
Upgrade to latest version 7.8.14.
Diffstat (limited to 'graphics/vips')
-rw-r--r--graphics/vips/Makefile7
-rw-r--r--graphics/vips/distinfo3
-rw-r--r--graphics/vips/files/patch-configure45
-rw-r--r--graphics/vips/files/patch-libsrc::iofuncs::im_makerw.c14
-rw-r--r--graphics/vips/files/patch-libsrc::iofuncs::im_mapfile.c14
5 files changed, 16 insertions, 67 deletions
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index caa5e2dc7a4d..84460bea97fe 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vips
-PORTVERSION= 7.8.12
-PORTREVISION= 3
+PORTVERSION= 7.8.14
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/vips-7.8/
@@ -26,7 +25,9 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --without-magick --without-x
+CONFIGURE_ARGS= --without-magick --without-x \
+ --with-fftw-libraries=${LOCALBASE}/lib \
+ --with-fftw-includes=${LOCALBASE}/include
MAN1= batch_image_convert.1 batch_rubber_sheet.1 \
binfile.1 cooc.1 cooc_features.1 debugim.1 \
diff --git a/graphics/vips/distinfo b/graphics/vips/distinfo
index 7f8c915feaea..bfcabf9c8376 100644
--- a/graphics/vips/distinfo
+++ b/graphics/vips/distinfo
@@ -1 +1,2 @@
-MD5 (vips-7.8.12.tar.gz) = 003cb381b2f5217e6a56a8556a9f444e
+MD5 (vips-7.8.14.tar.gz) = 66fa8aa9f135858adf38ebaaac9b266f
+SIZE (vips-7.8.14.tar.gz) = 3357727
diff --git a/graphics/vips/files/patch-configure b/graphics/vips/files/patch-configure
index 022cdfdca2f0..9f132ddc9052 100644
--- a/graphics/vips/files/patch-configure
+++ b/graphics/vips/files/patch-configure
@@ -1,36 +1,11 @@
---- configure.orig Fri Dec 19 18:53:45 2003
-+++ configure Fri Dec 19 18:57:16 2003
-@@ -12181,7 +12181,7 @@
- fi
- rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+--- configure.orig Sat Feb 7 22:34:33 2004
++++ configure Sat Feb 7 22:35:10 2004
+@@ -24017,7 +24017,7 @@
+ # Check whether --with-fftw-libraries or --without-fftw-libraries was given.
+ if test "${with_fftw_libraries+set}" = set; then
+ withval="$with_fftw_libraries"
+- FFTW_LIBS="-L$withval -lfftw"
++ FFTW_LIBS="-L$withval -lfftw -lrfftw"
+ fi;
-- if test "$FFTW_LIBS" == "no"; then
-+ if test "$FFTW_LIBS" = "no"; then
- # Try the standard search path first
- LIBS="-lrfftw -lfftw -lm $fftw_save_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
-@@ -12225,7 +12225,7 @@
- /usr/*/lib \
- "${prefix}"/lib/* /usr/lib/* \
- /usr/local/lib/* /*/lib; do
-- if test -d "$dir" && test "`ls $dir/libdfftw.* 2> /dev/null`" != ""; then
-+ if test -d "$dir" && test "`ls $dir/libfftw.* 2> /dev/null`" != ""; then
- FFTW_LIBS="-L$dir -lrfftw -lfftw -lm"
- break
- fi
-@@ -12693,13 +12693,12 @@
-
- else
-
-- echo "$as_me:12696: checking for dlopen in -l" >&5
--echo $ECHO_N "checking for dlopen in -l... $ECHO_C" >&6
-+ echo "$as_me:12696: checking for dlopen" >&5
-+echo $ECHO_N "checking for dlopen... $ECHO_C" >&6
- if test "${ac_cv_lib__dlopen+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-l $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line 12704 "configure"
- #include "confdefs.h"
+ echo "$as_me:$LINENO: checking for FFTW" >&5
diff --git a/graphics/vips/files/patch-libsrc::iofuncs::im_makerw.c b/graphics/vips/files/patch-libsrc::iofuncs::im_makerw.c
deleted file mode 100644
index fcac44c6507b..000000000000
--- a/graphics/vips/files/patch-libsrc::iofuncs::im_makerw.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- libsrc/iofuncs/im_makerw.c.orig Fri Dec 19 19:13:38 2003
-+++ libsrc/iofuncs/im_makerw.c Fri Dec 19 19:13:49 2003
-@@ -51,10 +51,10 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <sys/types.h>
- #ifdef HAVE_SYS_MMAN_H
- #include <sys/mman.h>
- #endif
--#include <sys/types.h>
- #include <sys/stat.h>
-
- #include <vips/vips.h>
diff --git a/graphics/vips/files/patch-libsrc::iofuncs::im_mapfile.c b/graphics/vips/files/patch-libsrc::iofuncs::im_mapfile.c
deleted file mode 100644
index d3e83183d199..000000000000
--- a/graphics/vips/files/patch-libsrc::iofuncs::im_mapfile.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- libsrc/iofuncs/im_mapfile.c.orig Fri Dec 19 19:26:34 2003
-+++ libsrc/iofuncs/im_mapfile.c Fri Dec 19 19:26:51 2003
-@@ -68,10 +68,10 @@
- #include <errno.h>
- #include <assert.h>
-
-+#include <sys/types.h>
- #ifdef HAVE_SYS_MMAN_H
- #include <sys/mman.h>
- #endif /*HAVE_SYS_MMAN_H*/
--#include <sys/types.h>
- #ifdef HAVE_SYS_FILE_H
- #include <sys/file.h>
- #endif /*HAVE_SYS_FILE_H*/