aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/visprint/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-12 00:12:32 +0800
committerstas <stas@FreeBSD.org>2006-11-12 00:12:32 +0800
commitb6d6a0a37c2a554b40ba90aa92533c86985c6a84 (patch)
tree0181c1a00a242d05b438a3f40db965a96b74be73 /graphics/visprint/Makefile
parentce17867ad5e6b692681e871748ce98e8ceece3f6 (diff)
downloadfreebsd-ports-gnome-b6d6a0a37c2a554b40ba90aa92533c86985c6a84.tar.gz
freebsd-ports-gnome-b6d6a0a37c2a554b40ba90aa92533c86985c6a84.tar.zst
freebsd-ports-gnome-b6d6a0a37c2a554b40ba90aa92533c86985c6a84.zip
- Add port for graphics/visprint
Visprint makes fractal fingerprint png images based on the contents of any file. The image will be different for almost every file with even slightly different contents. Visprint uses the IFS fractal generation process, pioneered by Michael Barnsley. It is a way to create images which are self-similar to infinite depths. In other words, the picture is made up of smaller versions of itself. Author: Goiz "Samhain" <hackerbunny@tastyrabbit.net> WWW: http://www.tastyrabbit.net/visprint/
Diffstat (limited to 'graphics/visprint/Makefile')
-rw-r--r--graphics/visprint/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/visprint/Makefile b/graphics/visprint/Makefile
new file mode 100644
index 000000000000..53080ef57320
--- /dev/null
+++ b/graphics/visprint/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: visprint
+# Date created: 11 November 2006
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= visprint
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.tastyrabbit.net/visprint/download/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Creates fractal fingerprint images based on any data
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lpng
+
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/visprint
+
+MAN1= visprint.1
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -c visprint.c)
+ (cd ${WRKSRC} && ${CC} ${LDFLAGS} visprint.o -o visprint)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/visprint ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/visprint.1.gz ${PREFIX}/man/man1
+
+.include <bsd.port.mk>