aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xenomorph
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-04-03 14:30:56 +0800
committerijliao <ijliao@FreeBSD.org>2003-04-03 14:30:56 +0800
commit049b0d75b1aec178650f3a4774f68599b501d2ef (patch)
treeafe6506f8959c93b6a7283022cfa433aa01ba9a1 /graphics/xenomorph
parent2cbefdbfc11072dd2af1a1500542b1130046bfd5 (diff)
downloadfreebsd-ports-gnome-049b0d75b1aec178650f3a4774f68599b501d2ef.tar.gz
freebsd-ports-gnome-049b0d75b1aec178650f3a4774f68599b501d2ef.tar.zst
freebsd-ports-gnome-049b0d75b1aec178650f3a4774f68599b501d2ef.zip
add xenomorph 0.5.1
An image filter system based on volterra and morphologic filters
Diffstat (limited to 'graphics/xenomorph')
-rw-r--r--graphics/xenomorph/Makefile27
-rw-r--r--graphics/xenomorph/distinfo1
-rw-r--r--graphics/xenomorph/pkg-descr9
-rw-r--r--graphics/xenomorph/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/graphics/xenomorph/Makefile b/graphics/xenomorph/Makefile
new file mode 100644
index 000000000000..79bb8f007fb5
--- /dev/null
+++ b/graphics/xenomorph/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: xenomorph
+# Date created: Apr 3, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xenomorph
+PORTVERSION= 0.5.1
+CATEGORIES= graphics
+MASTER_SITES= http://xenomorph.sourceforge.net/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An image filter system based on volterra and morphologic filters
+
+USE_BZIP2= yes
+USE_QT_VER= 3
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR=${X11BASE}
+MAKE_ENV= QTDIR=${X11BASE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xenomorph ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/xenomorph/distinfo b/graphics/xenomorph/distinfo
new file mode 100644
index 000000000000..ec85fd21fee7
--- /dev/null
+++ b/graphics/xenomorph/distinfo
@@ -0,0 +1 @@
+MD5 (xenomorph051.tar.bz2) = 8694be7db5fc17d8cdab97cc97f2617f
diff --git a/graphics/xenomorph/pkg-descr b/graphics/xenomorph/pkg-descr
new file mode 100644
index 000000000000..85eba9e8bde8
--- /dev/null
+++ b/graphics/xenomorph/pkg-descr
@@ -0,0 +1,9 @@
+Xenomorph is OpenSource software running on Unix/X11 systems. It provides a
+unified concept of polynomial and morphologic image filters. It is built for
+precision, not for speed, that means it works in floating-point mode
+internally.
+
+It can read PNG, JPG and many other formats, and it writes PNG. A nice feature
+of this software is it's upgradeability by adding new filters.
+
+WWW: http://xenomorph.sourceforge.net/
diff --git a/graphics/xenomorph/pkg-plist b/graphics/xenomorph/pkg-plist
new file mode 100644
index 000000000000..c14a048cf3ca
--- /dev/null
+++ b/graphics/xenomorph/pkg-plist
@@ -0,0 +1 @@
+bin/xenomorph