aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xface.el/Makefile
diff options
context:
space:
mode:
authoryoichi <yoichi@FreeBSD.org>2002-02-17 18:58:19 +0800
committeryoichi <yoichi@FreeBSD.org>2002-02-17 18:58:19 +0800
commit05351834fc71a1f1944752b4154003a6e798444e (patch)
treef7d595d81f11b47d74547f4988621498eff40bee /graphics/xface.el/Makefile
parentb13d2d1403433ce922099a7aa0c2cda3fdfa8375 (diff)
downloadfreebsd-ports-gnome-05351834fc71a1f1944752b4154003a6e798444e.tar.gz
freebsd-ports-gnome-05351834fc71a1f1944752b4154003a6e798444e.tar.zst
freebsd-ports-gnome-05351834fc71a1f1944752b4154003a6e798444e.zip
Add x-face.el, X-Face utilities for Emacsen.
Diffstat (limited to 'graphics/xface.el/Makefile')
-rw-r--r--graphics/xface.el/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/graphics/xface.el/Makefile b/graphics/xface.el/Makefile
new file mode 100644
index 000000000000..560a380357df
--- /dev/null
+++ b/graphics/xface.el/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: x-face.el
+# Date created: 17 Feb 2002
+# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xface.el
+PORTVERSION= 1.3.6.15
+CATEGORIES= graphics elisp
+MASTER_SITES= ftp://ftp.jpl.org/pub/elisp/ \
+ ftp://ftp.opaopa.org/pub/mirror/elisp/jpl/elisp/
+DISTNAME= ${PORTNAME:S/.el//}-${PORTVERSION}
+DISTFILES= ${DISTNAME}.tar.gz \
+ ${PORTNAME:S/.el/-e21.el.gz/}
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
+
+MAINTAINER= yoichi@FreeBSD.org
+
+RUN_DEPENDS= compface:${PORTSDIR}/graphics/compface
+
+EMACS_PORT_NAME?= emacs21
+
+LISP_FILES= x-face
+.if (${EMACS_PORT_NAME} == emacs21)
+LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/x-face
+LISP_FILES+= x-face-e21
+PLIST_SUB+= E21_ONLY="" \
+ XEMACS_ONLY="@comment "
+.elif (${EMACS_PORT_NAME} == xemacs21 || ${EMACS_PORT_NAME} == xemacs21-mule)
+LISPDIR= ${EMACS_SITE_LISPDIR}/x-face
+LISP_FILES+= x-face-xmas
+PLIST_SUB+= E21_ONLY="@comment " \
+ XEMACS_ONLY=""
+.else
+LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}/x-face
+PLIST_SUB+= E21_ONLY="@comment " \
+ XEMACS_ONLY="@comment "
+.endif
+PLIST_SUB+= LISPDIR=${LISPDIR} \
+ DOCSDIR=share/doc/${PORTNAME}
+
+post-extract:
+.if (${EMACS_PORT_NAME} == emacs21)
+ ${CP} ${DISTDIR}/x-face-e21.el.gz ${WRKSRC}
+ ${GUNZIP_CMD} ${WRKSRC}/x-face-e21.el.gz
+.endif
+post-build:
+.if (${EMACS_PORT_NAME} == emacs21)
+ (cd ${WRKSRC}; \
+ ${EMACS_CMD} -batch -q -no-site-file \
+ -f batch-byte-compile x-face-e21.el)
+.endif
+do-install:
+ ${MKDIR} ${PREFIX}/${LISPDIR}
+.for i in ${LISP_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i}.el ${WRKSRC}/${i}.elc ${PREFIX}/${LISPDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in METHOD.ja README.ja README-Anim.ja TODO.ja
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>