aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xface.el
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-29 04:16:00 +0800
committerpawel <pawel@FreeBSD.org>2014-04-29 04:16:00 +0800
commit4d528b88b16d528dc4eef335ac2a9599fde84dcf (patch)
treef930ededea577e1441251dda2202d0d51b86b9dc /graphics/xface.el
parent78ce905c883a69a6718df8cb2c1465d5c26e62c6 (diff)
downloadfreebsd-ports-gnome-4d528b88b16d528dc4eef335ac2a9599fde84dcf.tar.gz
freebsd-ports-gnome-4d528b88b16d528dc4eef335ac2a9599fde84dcf.tar.zst
freebsd-ports-gnome-4d528b88b16d528dc4eef335ac2a9599fde84dcf.zip
- Add staging support
- Convert to new options framework
Diffstat (limited to 'graphics/xface.el')
-rw-r--r--graphics/xface.el/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/graphics/xface.el/Makefile b/graphics/xface.el/Makefile
index 40b5e9c192d0..f0360ac9255a 100644
--- a/graphics/xface.el/Makefile
+++ b/graphics/xface.el/Makefile
@@ -40,7 +40,8 @@ PLIST_SUB+= E21_ONLY="@comment " \
PLIST_SUB+= LISPDIR=${LISPDIR} \
DOCSDIR=share/doc/${PORTNAME}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-extract:
.if (${EMACS_PORT_NAME} == emacs21)
${CP} ${DISTDIR}/x-face-e21.el.gz ${WRKSRC}
@@ -53,15 +54,13 @@ post-build:
-f batch-byte-compile x-face-e21.el)
.endif
do-install:
- ${MKDIR} ${PREFIX}/${LISPDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${LISPDIR}
.for i in ${LISP_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${i}.el ${WRKSRC}/${i}.elc ${PREFIX}/${LISPDIR}
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in METHOD.ja README.ja README-Anim.ja TODO.ja
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i}.el ${WRKSRC}/${i}.elc \
+ ${STAGEDIR}${PREFIX}/${LISPDIR}
.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} METHOD.ja README.ja README-Anim.ja \
+ TODO.ja ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>