aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xnview/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-06-24 19:57:27 +0800
committerosa <osa@FreeBSD.org>2003-06-24 19:57:27 +0800
commitea385af3064e3e57bd55556a686c5ab5b47c4090 (patch)
tree5cfcffbb2535cca5b954dc3e7480d7ffe17492a5 /graphics/xnview/Makefile
parentd9e1ca25e7076fb16932b63bd17fd82a2d065fdf (diff)
downloadfreebsd-ports-gnome-ea385af3064e3e57bd55556a686c5ab5b47c4090.tar.gz
freebsd-ports-gnome-ea385af3064e3e57bd55556a686c5ab5b47c4090.tar.zst
freebsd-ports-gnome-ea385af3064e3e57bd55556a686c5ab5b47c4090.zip
Fix build on 5.x. [1]
Remove trailed spaces from Makefile (use tabs) [2] Reorganize pkg-plist [2] Make pkg-descr portlint compilant [2] Submitted by: [1] maintainer, [2] osa Approved by: maintainer, fjoe (mentor) (implicit)
Diffstat (limited to 'graphics/xnview/Makefile')
-rw-r--r--graphics/xnview/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/graphics/xnview/Makefile b/graphics/xnview/Makefile
index 0bb3512c8224..dc9cbd566d28 100644
--- a/graphics/xnview/Makefile
+++ b/graphics/xnview/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= xnview
-PORTVERSION= 1.50
+PORTVERSION= 1.50
CATEGORIES= graphics
-MASTER_SITES= http://perso.wanadoo.fr/pierre.g/download/viewer/ \
- ftp://www.zoo-logique.org/xnview/download/
-DISTNAME= XnView-x86-unknown-FreeBSD4.x-static
+MASTER_SITES= ftp://www.zoo-logique.org/xnview/download/
+DISTNAME= XnView-x86-unknown-FreeBSD4.x-static
EXTRACT_SUFX= .tgz
MAINTAINER= petr@petrovich.kiev.ua
COMMENT= An easy graphics viewer / converter
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
USE_X_PREFIX= yes
@@ -29,9 +30,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lib/libformat.so.3.87 ${PREFIX}/lib/libformat.so.3
${LN} -sf ${PREFIX}/lib/libformat.so.3 ${PREFIX}/lib/libformat.so
${INSTALL_DATA} ${WRKSRC}/app-defaults/XnView.ad ${PREFIX}/lib/X11/app-defaults/XnView
- ${MKDIR} ${PREFIX}/share/doc/xnview
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && \
${INSTALL_DATA} Formats.txt ReadMe.txt Usage.txt WhatsNew.txt \
- ${PREFIX}/share/doc/xnview
+ ${DOCSDIR}
+.endif
.include <bsd.port.mk>