aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xpdf
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2011-01-13 01:01:50 +0800
committeraraujo <araujo@FreeBSD.org>2011-01-13 01:01:50 +0800
commite961abd3c97eccdfe1c7bb6dbad8848fbfe4f6ec (patch)
tree7419f364ce139b544ea0fb0093adb79ca5e5ffed /graphics/xpdf
parent5dacbf6a58a1254cd348e3f61541874a25aa2d07 (diff)
downloadfreebsd-ports-gnome-e961abd3c97eccdfe1c7bb6dbad8848fbfe4f6ec.tar.gz
freebsd-ports-gnome-e961abd3c97eccdfe1c7bb6dbad8848fbfe4f6ec.tar.zst
freebsd-ports-gnome-e961abd3c97eccdfe1c7bb6dbad8848fbfe4f6ec.zip
- Fix an issue related when a file has bad TTF fonts that do a crash in XPDF.
- Bump PORTREVISION. Submitted by: stas (via mail) Feature safe: yes
Diffstat (limited to 'graphics/xpdf')
-rw-r--r--graphics/xpdf/Makefile2
-rw-r--r--graphics/xpdf/files/patch-fofi_FoFiTrueType.cc11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 5ff3077583e4..24baef4bc032 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpdf
PORTVERSION= 3.02
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN}
diff --git a/graphics/xpdf/files/patch-fofi_FoFiTrueType.cc b/graphics/xpdf/files/patch-fofi_FoFiTrueType.cc
new file mode 100644
index 000000000000..e8d2f32d178f
--- /dev/null
+++ b/graphics/xpdf/files/patch-fofi_FoFiTrueType.cc
@@ -0,0 +1,11 @@
+--- fofi/FoFiTrueType.cc.orig 2010-12-29 12:13:14.000000000 -0800
++++ fofi/FoFiTrueType.cc 2010-12-29 12:15:15.000000000 -0800
+@@ -906,7 +906,7 @@
+ // check for an incorrect cmap table length
+ badCmapLen = gFalse;
+ cmapLen = 0; // make gcc happy
+- if (!missingCmap) {
++ if (!missingCmap && cmaps != NULL && nCmaps != 0) {
+ cmapLen = cmaps[0].offset + cmaps[0].len;
+ for (i = 1; i < nCmaps; ++i) {
+ if (cmaps[i].offset + cmaps[i].len > cmapLen) {