aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/yagf
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2009-09-15 00:29:47 +0800
committerbsam <bsam@FreeBSD.org>2009-09-15 00:29:47 +0800
commit38b6939b9b6c2fc1426c015c4e33dc9e49c3b89a (patch)
treef37a310804d4d98d3f4e50bf86134391ec10d2b2 /graphics/yagf
parentb2c28713a3d75642bc8305e3ae41a07d78f6578a (diff)
downloadfreebsd-ports-gnome-38b6939b9b6c2fc1426c015c4e33dc9e49c3b89a.tar.gz
freebsd-ports-gnome-38b6939b9b6c2fc1426c015c4e33dc9e49c3b89a.tar.zst
freebsd-ports-gnome-38b6939b9b6c2fc1426c015c4e33dc9e49c3b89a.zip
YAGF is a graphical interface for the cuneiform text recognition
program on the Linux platform. With YAGF you can scan images via XSane, perform images preprocessing and recognize texts using cuneiform from a single command centre. YAGF also makes it easy to scan and recognize several images sequentially. WWW: http://symmetrica.net/cuneiform-linux/yagf-en.html
Diffstat (limited to 'graphics/yagf')
-rw-r--r--graphics/yagf/Makefile34
-rw-r--r--graphics/yagf/distinfo3
-rw-r--r--graphics/yagf/files/patch-CMakeLists.txt18
-rw-r--r--graphics/yagf/files/patch-src-FileChannel.cpp11
-rw-r--r--graphics/yagf/pkg-descr7
-rw-r--r--graphics/yagf/pkg-plist17
6 files changed, 90 insertions, 0 deletions
diff --git a/graphics/yagf/Makefile b/graphics/yagf/Makefile
new file mode 100644
index 000000000000..e88b52fa38e6
--- /dev/null
+++ b/graphics/yagf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: graphics/yagf
+# Date created: 2009-09-11
+# Whom: bsam
+#
+# $FreeBSD$
+#
+
+PORTNAME= yagf
+PORTVERSION= 0.8.1
+CATEGORIES= graphics
+MASTER_SITES= http://symmetrica.net/cuneiform-linux/
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Graphical interface for the cuneiform OCR program
+
+LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+
+ONLY_FOR_ARCHS= i386 amd64
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
+INSTALLS_ICONS= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui imageformats linguist moc qmake rcc uic
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION}<700000
+IGNORE= does not compile at 6.x
+.endif
+.include <bsd.port.post.mk>
diff --git a/graphics/yagf/distinfo b/graphics/yagf/distinfo
new file mode 100644
index 000000000000..31ef7a1041ef
--- /dev/null
+++ b/graphics/yagf/distinfo
@@ -0,0 +1,3 @@
+MD5 (yagf-0.8.1.tar.gz) = 72558252cba34003d26ea31fba24ca67
+SHA256 (yagf-0.8.1.tar.gz) = f520629cf36e346bfa032a12fd6a84b14ab7d48d5e86d1fd3340d94cbb7f4f03
+SIZE (yagf-0.8.1.tar.gz) = 189938
diff --git a/graphics/yagf/files/patch-CMakeLists.txt b/graphics/yagf/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..65d8f2893de1
--- /dev/null
+++ b/graphics/yagf/files/patch-CMakeLists.txt
@@ -0,0 +1,18 @@
+--- CMakeLists.txt.orig 2009-08-16 20:54:20.000000000 +0400
++++ CMakeLists.txt 2009-09-14 13:09:48.000000000 +0400
+@@ -25,12 +25,12 @@
+ #QT4_CREATE_TRANSLATION(yagf_ru.qm src/mainform.cpp ${MOC_SRCS} ${UI_HEADERS} src/yagf_ru.ts)
+ #set(CMAKE_INSTALL_PREFIX /usr/)
+ if (NOT DEFINED ${CMAKE_INSTALL_PREFIX})
+-set(CPACK_INSTALL_PREFIX /usr/)
+-set (CMAKE_INSTALL_PREFIX /usr/)
++set(CPACK_INSTALL_PREFIX ${PREFIX})
++set(CMAKE_INSTALL_PREFIX ${PREFIX})
+ endif()
+ install_targets(/bin/ yagf)
+ if (CMAKE_SIZEOF_VOID_P EQUAL 8)
+- set (LIB_PATH_SUFFIX 64)
++ set (LIB_PATH_SUFFIX "")
+ set_property (GLOBAL PROPERTY FIND_LIBRARY_USE_LIB64_PATHS TRUE)
+ endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ install_targets(/lib${LIB_PATH_SUFFIX}/yagf xspreload)
diff --git a/graphics/yagf/files/patch-src-FileChannel.cpp b/graphics/yagf/files/patch-src-FileChannel.cpp
new file mode 100644
index 000000000000..ace4b0a13f9c
--- /dev/null
+++ b/graphics/yagf/files/patch-src-FileChannel.cpp
@@ -0,0 +1,11 @@
+--- src/FileChannel.cpp.orig 2009-09-12 13:08:28.000000000 +0400
++++ src/FileChannel.cpp 2009-09-12 13:08:41.000000000 +0400
+@@ -248,7 +248,7 @@
+
+ QString FileChannel::errorString()
+ {
+- strcpy(lastErrorString, strerror_r(errno, lastErrorString, 0));
++ strcpy(lastErrorString, strerror(errno));
+ return QString(trUtf8(lastErrorString));
+ }
+
diff --git a/graphics/yagf/pkg-descr b/graphics/yagf/pkg-descr
new file mode 100644
index 000000000000..33b4998abf93
--- /dev/null
+++ b/graphics/yagf/pkg-descr
@@ -0,0 +1,7 @@
+YAGF is a graphical interface for the cuneiform text recognition
+program on the Linux platform. With YAGF you can scan images via
+XSane, perform images preprocessing and recognize texts using
+cuneiform from a single command centre. YAGF also makes it easy to
+scan and recognize several images sequentially.
+
+WWW: http://symmetrica.net/cuneiform-linux/yagf-en.html
diff --git a/graphics/yagf/pkg-plist b/graphics/yagf/pkg-plist
new file mode 100644
index 000000000000..2d359548d702
--- /dev/null
+++ b/graphics/yagf/pkg-plist
@@ -0,0 +1,17 @@
+bin/yagf
+lib/yagf/libxspreload.so
+share/applications/YAGF.desktop
+share/icons/hicolor/96x96/apps/yagf.png
+share/pixmaps/yagf.png
+share/yagf/translations/yagf_lt.qm
+share/yagf/translations/yagf_ru.qm
+@comment those are yagf directories
+@dirrm lib/yagf
+@dirrm share/yagf/translations
+@dirrm share/yagf
+@comment those are shared directories
+@dirrmtry share/applications
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons