aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/zathura
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-10-03 22:37:41 +0800
committerswills <swills@FreeBSD.org>2011-10-03 22:37:41 +0800
commit990071bbb5a33eacddbdb8c27c81f5018c2ae509 (patch)
tree4da6548ff5d53e9cefad76beace77bae77b7e600 /graphics/zathura
parent0b7682e1645afb3563bf0fadf2a4e931fd8efa2e (diff)
downloadfreebsd-ports-gnome-990071bbb5a33eacddbdb8c27c81f5018c2ae509.tar.gz
freebsd-ports-gnome-990071bbb5a33eacddbdb8c27c81f5018c2ae509.tar.zst
freebsd-ports-gnome-990071bbb5a33eacddbdb8c27c81f5018c2ae509.zip
- fix plist when rst2man is in PATH
- respect PREFIX for system-wide config file PR: ports/160668 Submitted by: h h <aakuusta@gmail.com> Approved by: Quentin Stievenart <acieroid@awesom.eu> (maintainer)
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 944f65671aa4..a706e443dacd 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -26,8 +26,13 @@ PLIST_FILES= bin/zathura \
share/applications/zathura.desktop
PLIST_DIRSTRY= share/applications
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
+MAN5+= zathurarc.5
+.endif
+
post-patch: .SILENT
- ${REINPLACE_CMD} -e 's|man1|man/man1|g' \
+ ${REINPLACE_CMD} -e 's|man[15]|man/&|g' \
-e '/CC/s/$${SFLAGS}/${STRIP} /' \
-e '/CFLAGS/!s/$${LDFLAGS}/$${CFLAGS} &/' \
-e 's/{DFLAGS/{DEBUG_FLAGS/g' \
@@ -39,10 +44,16 @@ post-patch: .SILENT
-e 's/cp[[:space:]]$$</cp $$>/' \
-e 's/\(include\)[[:space:]]\(.*\)/.\1 "\2"/' \
${WRKSRC}/Makefile
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} 's|which rst2man|${FALSE}|' ${WRKSRC}/Makefile
+.endif
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
-e 's/-lpthread/${PTHREAD_LIBS}/' \
-e 's/-lc//' \
-e 's/$$(shell[[:space:]]\(.*\))/`\1`/' \
${WRKSRC}/config.mk
+ ${REINPLACE_CMD} -e 's|/etc|${PREFIX}&|g' \
+ ${WRKSRC}/config.def.h \
+ ${WRKSRC}/zathurarc.5.rst
.include <bsd.port.mk>