aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-12 23:05:46 +0800
committermat <mat@FreeBSD.org>2016-04-12 23:05:46 +0800
commit01f4663cb4da5a4599e5fe47b89c0426bad521a5 (patch)
tree369ffc6c2e13f498ec382087056b3ee5c9adb723 /graphics
parentd36e1e3f11107933babe8190eb89b494c355cfae (diff)
downloadfreebsd-ports-gnome-01f4663cb4da5a4599e5fe47b89c0426bad521a5.tar.gz
freebsd-ports-gnome-01f4663cb4da5a4599e5fe47b89c0426bad521a5.tar.zst
freebsd-ports-gnome-01f4663cb4da5a4599e5fe47b89c0426bad521a5.zip
Upbreak.
- Regen patches. - Move part of pkg-descr explaining the options to pkg-help, where it belongs. PR: 208711 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Diffstat (limited to 'graphics')
-rw-r--r--graphics/giftool/Makefile9
-rw-r--r--graphics/giftool/distinfo4
-rw-r--r--graphics/giftool/files/extra-patch-aa44
-rw-r--r--graphics/giftool/files/extra-patch-ab30
-rw-r--r--graphics/giftool/pkg-descr12
-rw-r--r--graphics/giftool/pkg-help12
6 files changed, 46 insertions, 65 deletions
diff --git a/graphics/giftool/Makefile b/graphics/giftool/Makefile
index f0ea7e45d859..194b0767de73 100644
--- a/graphics/giftool/Makefile
+++ b/graphics/giftool/Makefile
@@ -4,20 +4,17 @@
PORTNAME= giftool
PORTVERSION= 1.0
CATEGORIES= graphics
-MASTER_SITES= http://www.the-labs.com/GIFTool/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= SUNSITE/apps/graphics/convert/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for GIF89a transparent option and interlace mode
-BROKEN= unfetchable
-
NO_CDROM= Shareware
NO_WRKSUBDIR= yes
ALL_TARGET= giftool
MAKE_ARGS= CFLAGS="${CFLAGS}"
+USES= tar:tgz
OPTIONS_DEFINE= RETVALUE MALLOCSIZE DOCS
OPTIONS_DEFAULT= RETVALUE MALLOCSIZE
@@ -32,6 +29,8 @@ MALLOCSIZE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ab
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/giftool ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/giftool/distinfo b/graphics/giftool/distinfo
index 32cb14caefd8..0f42a573a921 100644
--- a/graphics/giftool/distinfo
+++ b/graphics/giftool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (giftool.tar.Z) = 5bcd4f7a76729a1f823b53c2af804cc34ac4f0f261f42671af0e5843db4337ba
-SIZE (giftool.tar.Z) = 33697
+SHA256 (giftool-1.0.tgz) = fdf0e818839a3997ead856db7232e49fff4ba1eb3ec2d4a46c52826708e29b44
+SIZE (giftool-1.0.tgz) = 21512
diff --git a/graphics/giftool/files/extra-patch-aa b/graphics/giftool/files/extra-patch-aa
index 394687706f0b..e1db5e4f2e78 100644
--- a/graphics/giftool/files/extra-patch-aa
+++ b/graphics/giftool/files/extra-patch-aa
@@ -1,27 +1,17 @@
-*** main.c.orig Sat Mar 8 06:34:28 1997
---- main.c Sat Mar 8 06:37:33 1997
-***************
-*** 1275,1281 ****
- exit(1);
- }
-
-! main(int argc, char *argv[])
- {
- int c, i;
- int batchMode = 0;
---- 1275,1281 ----
- exit(1);
- }
-
-! int main(int argc, char *argv[])
- {
- int c, i;
- int batchMode = 0;
-***************
-*** 1410,1413 ****
---- 1410,1414 ----
- GIFFree(stream);
- }
- }
-+ return 0;
- }
+--- main.c.orig 1994-12-07 18:31:59 UTC
++++ main.c
+@@ -1275,7 +1275,7 @@ static void usage()
+ exit(1);
+ }
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ int c, i;
+ int batchMode = 0;
+@@ -1410,4 +1410,5 @@ main(int argc, char *argv[])
+ GIFFree(stream);
+ }
+ }
++ return 0;
+ }
diff --git a/graphics/giftool/files/extra-patch-ab b/graphics/giftool/files/extra-patch-ab
index e4742279e7fb..bcc450b7a0d7 100644
--- a/graphics/giftool/files/extra-patch-ab
+++ b/graphics/giftool/files/extra-patch-ab
@@ -1,19 +1,11 @@
-*** readGIF.c.orig Sat Mar 8 06:28:02 1997
---- readGIF.c Sat Mar 8 06:30:05 1997
-***************
-*** 253,259 ****
- cur->data.image.cmapSize = 0;
-
- }
-! cur->data.image.data = (unsigned char *)malloc(cur->width * cur->height);
- cur->data.image.interlaced = BitSet(buf[8], INTERLACE);
- readImage(fd, BitSet(buf[8], INTERLACE),
- cur->width, cur->height, cur->data.image.data);
---- 253,259 ----
- cur->data.image.cmapSize = 0;
-
- }
-! cur->data.image.data = (unsigned char *)malloc(cur->width * cur->height + 1);
- cur->data.image.interlaced = BitSet(buf[8], INTERLACE);
- readImage(fd, BitSet(buf[8], INTERLACE),
- cur->width, cur->height, cur->data.image.data);
+--- readGIF.c.orig 1994-12-09 19:17:03 UTC
++++ readGIF.c
+@@ -253,7 +253,7 @@ GIFStream *GIFReadFP(FILE *fd)
+ cur->data.image.cmapSize = 0;
+
+ }
+- cur->data.image.data = (unsigned char *)malloc(cur->width * cur->height);
++ cur->data.image.data = (unsigned char *)malloc(cur->width * cur->height + 1);
+ cur->data.image.interlaced = BitSet(buf[8], INTERLACE);
+ readImage(fd, BitSet(buf[8], INTERLACE),
+ cur->width, cur->height, cur->data.image.data);
diff --git a/graphics/giftool/pkg-descr b/graphics/giftool/pkg-descr
index dd67bf885b16..1471a62d0294 100644
--- a/graphics/giftool/pkg-descr
+++ b/graphics/giftool/pkg-descr
@@ -2,15 +2,3 @@ GIFTool is a tool for GIF89a transparent option and interlace mode. For
instance 'giftool -B -i *.gif' converts all images to interlaced GIF files.
GIFTool is shareware. Use the -info option to read the licensing information.
-
-Two options are recommended:
-WITH_RETVALUE=yes
- This option, suggested by Sergei Chechetkin
- <csl@whale.sunbay.crimea.ua>, causes GIFTool to provide a return value
- so may be used in pipes or with programs like make(1).
-WITH_MALLOCSIZE=yes
- This option, suggested by Hidetoshi Shimokawa
- <simokawa@sat.t.u-tokyo.ac.jp>, increases the size of a malloc, to avoid
- a segmentation fault when pre-reading some images.
-
-WWW: http://www.the-labs.com/GIFTool/
diff --git a/graphics/giftool/pkg-help b/graphics/giftool/pkg-help
new file mode 100644
index 000000000000..b5ddc1770a57
--- /dev/null
+++ b/graphics/giftool/pkg-help
@@ -0,0 +1,12 @@
+RETVALUE
+
+This option, suggested by Sergei Chechetkin
+<csl@whale.sunbay.crimea.ua>, causes GIFTool to provide a return
+value so may be used in pipes or with programs like make(1).
+
+MALLOCSIZE
+
+This option, suggested by Hidetoshi Shimokawa
+<simokawa@sat.t.u-tokyo.ac.jp>, increases the size of a malloc, to
+avoid a segmentation fault when pre-reading some images.
+