aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2005-05-05 09:20:50 +0800
committeranholt <anholt@FreeBSD.org>2005-05-05 09:20:50 +0800
commit026e598ec81a6b51f78af18267774956ba53436c (patch)
tree6d8136c47dd489b4bb0ff87ce9bbe24c76faecd9 /graphics
parenta9bb35caff693fa0bdb5602dc433508bed0543af (diff)
downloadfreebsd-ports-gnome-026e598ec81a6b51f78af18267774956ba53436c.tar.gz
freebsd-ports-gnome-026e598ec81a6b51f78af18267774956ba53436c.tar.zst
freebsd-ports-gnome-026e598ec81a6b51f78af18267774956ba53436c.zip
[1] Fix the build on alpha by removing -ffast-math from the build cflags.
[2] Remove an unnecessary configure script from when this was built from monolithic sources. [3] Register conflicts for dri-devel in dri. Submitted by: [1] krismail
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri-devel/files/patch-freebsd-dri2
-rw-r--r--graphics/dri/Makefile2
-rw-r--r--graphics/dri/files/patch-freebsd-dri2
-rw-r--r--graphics/dri/scripts/configure46
4 files changed, 3 insertions, 49 deletions
diff --git a/graphics/dri-devel/files/patch-freebsd-dri b/graphics/dri-devel/files/patch-freebsd-dri
index 664afaaaa4e4..079470eec1b1 100644
--- a/graphics/dri-devel/files/patch-freebsd-dri
+++ b/graphics/dri-devel/files/patch-freebsd-dri
@@ -16,7 +16,7 @@
DEFINES = -DDRI_NEW_INTERFACE_ONLY
-CFLAGS = $(DEFINES) -Wmissing-prototypes -g -std=c99 -Wundef -fPIC -ffast-math -I/usr/local/include $(X11_INCLUDES)
+CFLAGS = $(FBSDCFLAGS) $(DEFINES) -Wmissing-prototypes -g -std=c99 -Wundef \
-+ -fPIC -ffast-math -I/usr/local/include $(X11_INCLUDES)
++ -fPIC -I/usr/local/include $(X11_INCLUDES)
CXXFLAGS = $(DEFINES) -Wall -g -ansi -pedantic -fPIC
ASM_SOURCES =
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 52eda6467f3e..f5ce354ca287 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -20,7 +20,7 @@ COMMENT= OpenGL hardware acceleration drivers for the DRI
BUILD_DEPENDS= makedepend:${X_IMAKE_PORT}
-CONFLICTS= xfree86-dri-*
+CONFLICTS= xfree86-dri-* dri-6.2.2005*
WRKSRC= ${WRKDIR}/Mesa
USE_X_PREFIX= yes
diff --git a/graphics/dri/files/patch-freebsd-dri b/graphics/dri/files/patch-freebsd-dri
index 1b68eca25bfe..c63cdf85ecf6 100644
--- a/graphics/dri/files/patch-freebsd-dri
+++ b/graphics/dri/files/patch-freebsd-dri
@@ -15,7 +15,7 @@
-CFLAGS = -DDRI_NEW_INTERFACE_ONLY -Wmissing-prototypes -g -std=c99 -Wundef -fPIC -ffast-math -I/usr/local/include -I/usr/X11R6/include -I/usr/X11R6/include/X11/extensions
-CXXFLAGS = -DDRI_NEW_INTERFACE_ONLY -Wall -g -ansi -pedantic -fPIC
+CFLAGS = $(FBSDCFLAGS) -DDRI_NEW_INTERFACE_ONLY -Wmissing-prototypes -g \
-+ -std=c9x -Wundef -fPIC -ffast-math -I$(LOCALBASE)/include \
++ -std=c9x -Wundef -fPIC -I$(LOCALBASE)/include \
+ -I$(X11BASE)/include -I$(X11BASE)/include/X11/extensions
+CXXFLAGS = $(FBSDCXXFLAGS) -DDRI_NEW_INTERFACE_ONLY -Wall -g -ansi -pedantic \
+ -fPIC
diff --git a/graphics/dri/scripts/configure b/graphics/dri/scripts/configure
deleted file mode 100644
index 609c55af6fe5..000000000000
--- a/graphics/dri/scripts/configure
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-
-# This script does the following:
-# (1) cp xf86site.def, installed by imake-4 port,
-# to ${WRKDIR}/xc/config/cf.
-# this provides settings for the ports system.
-# (2) Create a host.def for this specific port, using
-# host.def as a base.
-
-ORIGDEF=$PREFIX/lib/X11/config/xf86site.def
-DESTDEF=$WRKDIR/xc/config/cf/xf86site.def
-ORIGHOSTDEF=$PREFIX/lib/X11/config/host.def
-LOCALDEF=$WRKDIR/.config
-HOSTDEF=$WRKDIR/xc/config/cf/host.def
-
-# Use original host.def as initial config file
-rm -f $LOCALDEF
-grep -v '#define.*ProjectRoot' $ORIGHOSTDEF >> $LOCALDEF
-echo "#define ProjectRoot $PREFIX" >> $LOCALDEF
-echo "#define X11ProjectRoot $PREFIX" >> $LOCALDEF
-
-# This is also defined in xf86site.def, but doesn't get
-# picked up for some reason.
-echo "#define NothingOutsideProjectRoot YES" >> $LOCALDEF
-
-echo "#define BuildXF86DRI YES" >> $LOCALDEF
-echo "#define BuildXF86DRM NO" >> $LOCALDEF
-echo "#define HasGlide3 YES" >> $LOCALDEF
-
-echo "#define BuildGLXLibrary YES" >> $LOCALDEF
-echo "#define UseInstalledPrograms YES" >> $LOCALDEF
-echo "#define UseInstalled YES" >> $LOCALDEF
-echo "#define StandardIncludes -I${PREFIX}/include" >> $LOCALDEF
-
-echo "#define FreeBSDCC ${CC}" >> $LOCALDEF
-echo "#define FreeBSDCXX ${CXX}" >> $LOCALDEF
-echo "#define FreeBSDCFLAGS ${CFLAGS}" >> $LOCALDEF
-
-# Copy ORIGDEF to DESTDEF
-rm -f $DESTDEF
-cp -f $ORIGDEF $DESTDEF
-
-# copy generated config to host.def
-cp -f $LOCALDEF $HOSTDEF
-
-exit 0