aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-13 02:26:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-13 02:26:10 +0800
commit15bd82b6b7d2a035f48f68235fa3d2c6ba016fd4 (patch)
treeeee74aa350cfc4974e11ce69de7ff2ab73f98a30 /graphics
parent90b6c73d5cd4d69c575c4350633e38bfb095a8c5 (diff)
downloadfreebsd-ports-gnome-15bd82b6b7d2a035f48f68235fa3d2c6ba016fd4.tar.gz
freebsd-ports-gnome-15bd82b6b7d2a035f48f68235fa3d2c6ba016fd4.tar.zst
freebsd-ports-gnome-15bd82b6b7d2a035f48f68235fa3d2c6ba016fd4.zip
- Add php-gdal 1.9.1
This port is the PHP binding for GDAL (Geospatial Data Abstraction Library). WWW: http://www.gdal.org/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/php-gdal/Makefile51
-rw-r--r--graphics/php-gdal/distinfo2
-rw-r--r--graphics/php-gdal/pkg-descr3
-rw-r--r--graphics/php-gdal/pkg-plist13
5 files changed, 70 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index aa4d8fa5a3f6..b925ac708c7f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -716,6 +716,7 @@
SUBDIR += photoclip
SUBDIR += photopc
SUBDIR += php-facedetect
+ SUBDIR += php-gdal
SUBDIR += php-libpuzzle
SUBDIR += php-magickwand
SUBDIR += php5-chartdirector
diff --git a/graphics/php-gdal/Makefile b/graphics/php-gdal/Makefile
new file mode 100644
index 000000000000..2eb05db51b26
--- /dev/null
+++ b/graphics/php-gdal/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: php-gdal
+# Date created: 2012-03-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdal
+PORTVERSION= 1.9.1
+CATEGORIES= graphics
+MASTER_SITES= http://download.osgeo.org/gdal/ \
+ ftp://ftp.remotesensing.org/pub/gdal/ \
+ LOCAL/sunpoet
+PKGNAMEPREFIX= php-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PHP binding for GDAL
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal
+
+ALL_TARGET= php_gdal.so php_gdalconst.so php_ogr.so php_osr.so
+CFLAGS+= -I${LOCALBASE}/include -fPIC
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
+LIBTOOLFILES= # empty
+MAKEFILE= GNUmakefile
+PHP_MOD_NAME= php_${PORTNAME}
+USE_AUTOTOOLS= libtool
+USE_GMAKE= yes
+USE_PHP= yes
+USE_PHP_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/swig/php
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CC=.*$$|CC=${CC}|; s|^CXX=.*$$|CXX=${CXX}|; s|^CFLAGS=.*$$|CFLAGS=${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
+
+do-configure:
+ @${DO_NADA}
+
+# include/cpl_config.h will exist after build phase
+pre-build:
+ ${SED} -e '/^GDAL_ROOT/d' ${DATADIR}/GDALmake.opt > ${WRKSRC}/../../GDALmake.opt
+ ${CP} ${LOCALBASE}/include/cpl_config.h ${WRKSRC}/../../port/
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}/ ${PREFIX}/include/php/ext/${PORTNAME}/
+ ${INSTALL_LIB} ${WRKSRC}/*.so ${PREFIX}/lib/php/${PHP_EXT_DIR}/
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/php/ext/${PORTNAME}/
+
+.include <bsd.port.mk>
diff --git a/graphics/php-gdal/distinfo b/graphics/php-gdal/distinfo
new file mode 100644
index 000000000000..362a722e3f60
--- /dev/null
+++ b/graphics/php-gdal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gdal-1.9.1.tar.gz) = 5b829e91c5d6c6c9af23fe6322e51bae9339e8805d52724cb0ad0b741aef7fa9
+SIZE (gdal-1.9.1.tar.gz) = 9487505
diff --git a/graphics/php-gdal/pkg-descr b/graphics/php-gdal/pkg-descr
new file mode 100644
index 000000000000..5ec66c58f2f6
--- /dev/null
+++ b/graphics/php-gdal/pkg-descr
@@ -0,0 +1,3 @@
+This port is the PHP binding for GDAL (Geospatial Data Abstraction Library).
+
+WWW: http://www.gdal.org/
diff --git a/graphics/php-gdal/pkg-plist b/graphics/php-gdal/pkg-plist
new file mode 100644
index 000000000000..78db7b00a615
--- /dev/null
+++ b/graphics/php-gdal/pkg-plist
@@ -0,0 +1,13 @@
+include/php/ext/gdal/php_gdal.h
+include/php/ext/gdal/php_gdalconst.h
+include/php/ext/gdal/php_ogr.h
+include/php/ext/gdal/php_osr.h
+lib/php/%%PHP_EXT_DIR%%/php_gdal.so
+lib/php/%%PHP_EXT_DIR%%/php_gdalconst.so
+lib/php/%%PHP_EXT_DIR%%/php_ogr.so
+lib/php/%%PHP_EXT_DIR%%/php_osr.so
+@dirrmtry lib/php/%%PHP_EXT_DIR%%
+@dirrmtry lib/php
+@dirrm include/php/ext/gdal
+@dirrmtry include/php/ext
+@dirrmtry include/php