aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2011-12-11 07:01:13 +0800
committeroliver <oliver@FreeBSD.org>2011-12-11 07:01:13 +0800
commit1cfd2f6a5944c6fea69fb12a3ee775e5145156a0 (patch)
tree198a3d6248c7aaec9c2d635ac2c223326a29a6cc /graphics
parent21beb28cc90c6d70f4a0262fb953116366baf2da (diff)
downloadfreebsd-ports-gnome-1cfd2f6a5944c6fea69fb12a3ee775e5145156a0.tar.gz
freebsd-ports-gnome-1cfd2f6a5944c6fea69fb12a3ee775e5145156a0.tar.zst
freebsd-ports-gnome-1cfd2f6a5944c6fea69fb12a3ee775e5145156a0.zip
use boost to build a threaded ogre (optional)
Feature safe: yes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ogre3d/Makefile17
-rw-r--r--graphics/ogre3d/pkg-plist12
2 files changed, 25 insertions, 4 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 06da2026a8c8..948ba381e1c9 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -19,6 +19,8 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
freetype.9:${PORTSDIR}/print/freetype2 \
freeimage.3:${PORTSDIR}/graphics/freeimage
+OPTIONS= BOOST "Use Boost to build threaded ogre" off
+
USE_LDCONFIG= YES
USE_BZIP2= YES
USE_CMAKE= YES
@@ -28,14 +30,25 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= Does not compile
+.if defined(WITH_BOOST)
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+RUND_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+PLIST_SUB+= BOOSTTRUE=""
+PLIST_SUB+= BOOSTFALSE="@comment "
+.else
+PLIST_SUB+= BOOSTTRUE="@comment "
+PLIST_SUB+= BOOSTFALSE=""
.endif
+
.if ${ARCH} == "powerpc"
BROKEN= Does not install on powerpc
.endif
post-patch:
+.if defined(WITHOUT_BOOST)
+ @${REINPLACE_CMD} -e 's|Boost|No_Boost|g' \
+ ${WRKSRC}/CMake/Dependencies.cmake
+.endif
@${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
@${REINPLACE_CMD} -e '\
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index e7ecaa351ca9..5e5a911e0063 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -345,6 +345,8 @@ include/OGRE/Plugins/ParticleFX/OgreRotationAffector.h
include/OGRE/Plugins/ParticleFX/OgreRotationAffectorFactory.h
include/OGRE/Plugins/ParticleFX/OgreScaleAffector.h
include/OGRE/Plugins/ParticleFX/OgreScaleAffectorFactory.h
+%%BOOSTTRUE%%include/OGRE/Property/OgreProperty.h
+%%BOOSTTRUE%%include/OGRE/Property/OgrePropertyPrerequisites.h
include/OGRE/RTShaderSystem/OgreRTShaderSystem.h
include/OGRE/RTShaderSystem/OgreShaderCGProgramProcessor.h
include/OGRE/RTShaderSystem/OgreShaderCGProgramWriter.h
@@ -441,8 +443,10 @@ include/OGRE/Terrain/OgreTerrainQuadTreeNode.h
include/OGRE/Threading/OgreDefaultWorkQueue.h
include/OGRE/Threading/OgreDefaultWorkQueueStandard.h
include/OGRE/Threading/OgreThreadDefines.h
-include/OGRE/Threading/OgreThreadDefinesNone.h
+%%BOOSTTRUE%%include/OGRE/Threading/OgreThreadDefinesBoost.h
+%%BOOSTFALSE%%include/OGRE/Threading/OgreThreadDefinesNone.h
include/OGRE/Threading/OgreThreadHeaders.h
+%%BOOSTTRUE%%include/OGRE/Threading/OgreThreadHeadersBoost.h
include/OGRE/asm_math.h
lib/OGRE/Plugin_BSPSceneManager.so
lib/OGRE/Plugin_OctreeSceneManager.so
@@ -462,12 +466,15 @@ lib/libOgreMain.so
lib/libOgreMain.so.1.7.3
lib/libOgrePaging.so
lib/libOgrePaging.so.1.7.3
+%%BOOSTTRUE%%lib/libOgreProperty.so
+%%BOOSTTRUE%%lib/libOgreProperty.so.1.7.3
lib/libOgreRTShaderSystem.so
lib/libOgreRTShaderSystem.so.1.7.3
lib/libOgreTerrain.so
lib/libOgreTerrain.so.1.7.3
libdata/pkgconfig/OGRE-PCZ.pc
libdata/pkgconfig/OGRE-Paging.pc
+%%BOOSTTRUE%%libdata/pkgconfig/OGRE-Property.pc
libdata/pkgconfig/OGRE-RTShaderSystem.pc
libdata/pkgconfig/OGRE-Terrain.pc
libdata/pkgconfig/OGRE.pc
@@ -475,13 +482,14 @@ libdata/pkgconfig/OGRE.pc
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm include/OGRE/GLX
+@dirrm include/OGRE/Paging
@dirrm include/OGRE/Plugins/OctreeSceneManager
@dirrm include/OGRE/Plugins/BSPSceneManager
@dirrm include/OGRE/Plugins/ParticleFX
@dirrm include/OGRE/Plugins/PCZSceneManager
@dirrm include/OGRE/Plugins/OctreeZone
@dirrm include/OGRE/Plugins
-@dirrm include/OGRE/Paging
+%%BOOSTTRUE%%@dirrm include/OGRE/Property
@dirrm include/OGRE/RTShaderSystem
@dirrm include/OGRE/RenderSystems/GL/GLX
@dirrm include/OGRE/RenderSystems/GL/GL