aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-05-07 00:29:43 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-05-07 00:29:43 +0800
commit24d74a55ea4b5b28412c4d64bfd7ef54958426ca (patch)
tree2e4eb9675cad5d3888d25fcc776c46d7ee297b6d /graphics
parent386eb33d8447c2b81ebf8ba08cda385b5263749a (diff)
downloadfreebsd-ports-gnome-24d74a55ea4b5b28412c4d64bfd7ef54958426ca.tar.gz
freebsd-ports-gnome-24d74a55ea4b5b28412c4d64bfd7ef54958426ca.tar.zst
freebsd-ports-gnome-24d74a55ea4b5b28412c4d64bfd7ef54958426ca.zip
Resynthesizer is a Gimp plug-in for texture synthesis. Given a
sample of a texture, it can create more of that texture. This has a surprising number of uses: * Creating more of a texture * Removing objects from images * Creating themed images WWW: http://www.logarithmic.net/pfh/resynthesizer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gimp-resynthesizer/Makefile44
-rw-r--r--graphics/gimp-resynthesizer/distinfo3
-rw-r--r--graphics/gimp-resynthesizer/pkg-descr9
-rw-r--r--graphics/gimp-resynthesizer/pkg-message7
5 files changed, 64 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c93f736ea66b..3d6a8c290e26 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -245,6 +245,7 @@
SUBDIR += gimp-lqr-plugin
SUBDIR += gimp-manual-html
SUBDIR += gimp-manual-pdf
+ SUBDIR += gimp-resynthesizer
SUBDIR += gimp-save-for-web
SUBDIR += gimpfx-foundry
SUBDIR += gimpshop
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
new file mode 100644
index 000000000000..681887973d1f
--- /dev/null
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: resynthesizer
+# Date created: 05 May 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= resynthesizer
+PORTVERSION= 0.16
+CATEGORIES= graphics
+MASTER_SITES= http://www.logarithmic.net/pfh-files/resynthesizer/ \
+ http://mirror.amdmi3.ru/distfiles/
+PKGNAMEPREFIX= gimp-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Gimp plug-in for texture synthesis
+
+LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app
+
+GIMPTOOL?= gimptool-2.0
+PLUGINS_DIR?= libexec/gimp/2.2/plug-ins
+SCRIPTS_DIR?= share/gimp/scripts
+
+MAKE_JOBS_SAFE= yes
+PLIST_FILES= ${PLUGINS_DIR}/resynth \
+ ${SCRIPTS_DIR}/smart-enlarge.scm \
+ ${SCRIPTS_DIR}/smart-remove.scm
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} \
+ `${GIMPTOOL} --cflags --libs` -o resynth resynth.cc
+
+do-install:
+ ${MKDIR} ${PREFIX}/${PLUGINS_DIR} ${PREFIX}/${SCRIPTS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/resynth ${PREFIX}/${PLUGINS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/smart-enlarge.scm \
+ ${WRKSRC}/smart-remove.scm ${PREFIX}/${SCRIPTS_DIR}
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-resynthesizer/distinfo b/graphics/gimp-resynthesizer/distinfo
new file mode 100644
index 000000000000..8810dd2988c9
--- /dev/null
+++ b/graphics/gimp-resynthesizer/distinfo
@@ -0,0 +1,3 @@
+MD5 (resynthesizer-0.16.tar.gz) = 097b3a21803fe02e47b8b8649af48144
+SHA256 (resynthesizer-0.16.tar.gz) = dd24ec89f3a36f867b733c6a5c1d193b6d603251bd6553ac54b573fd655020cd
+SIZE (resynthesizer-0.16.tar.gz) = 18241
diff --git a/graphics/gimp-resynthesizer/pkg-descr b/graphics/gimp-resynthesizer/pkg-descr
new file mode 100644
index 000000000000..35ec4ee5bdcc
--- /dev/null
+++ b/graphics/gimp-resynthesizer/pkg-descr
@@ -0,0 +1,9 @@
+Resynthesizer is a Gimp plug-in for texture synthesis. Given a
+sample of a texture, it can create more of that texture. This has
+a surprising number of uses:
+
+ * Creating more of a texture
+ * Removing objects from images
+ * Creating themed images
+
+WWW: http://www.logarithmic.net/pfh/resynthesizer
diff --git a/graphics/gimp-resynthesizer/pkg-message b/graphics/gimp-resynthesizer/pkg-message
new file mode 100644
index 000000000000..dfc9b08aa7f1
--- /dev/null
+++ b/graphics/gimp-resynthesizer/pkg-message
@@ -0,0 +1,7 @@
+After restarting the Gimp you should find the following items in
+the pop-up image menu:
+
+ * Filters/Map/Resynthesize
+ * Filters/Enhance/Smart enlarge
+ * Filters/Enhance/Smart sharpen
+ * Filters/Enhance/Smart remove selection