aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-11-06 14:29:12 +0800
committerdanfe <danfe@FreeBSD.org>2015-11-06 14:29:12 +0800
commit2d74c7a8d2ab932b321c73eb3317cfe0004282d9 (patch)
tree62575f8f3ffd7f9d55285b70f09c3898b5f3a323 /graphics
parent4070be524585a400a57f62c89b4025157064b85e (diff)
downloadfreebsd-ports-gnome-2d74c7a8d2ab932b321c73eb3317cfe0004282d9.tar.gz
freebsd-ports-gnome-2d74c7a8d2ab932b321c73eb3317cfe0004282d9.tar.zst
freebsd-ports-gnome-2d74c7a8d2ab932b321c73eb3317cfe0004282d9.zip
Add a port of Alembic, an open framework for storing and sharing graphic
scene data. WWW: http://alembic.io/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/alembic/Makefile27
-rw-r--r--graphics/alembic/distinfo2
-rw-r--r--graphics/alembic/files/patch-CMakeLists.txt67
-rw-r--r--graphics/alembic/files/patch-build_AlembicBoost.cmake18
-rw-r--r--graphics/alembic/files/patch-lib_Alembic_Util_Murmur3.cpp11
-rw-r--r--graphics/alembic/pkg-descr12
-rw-r--r--graphics/alembic/pkg-plist162
8 files changed, 300 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 220ec023e04d..cae712e62229 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -39,6 +39,7 @@
SUBDIR += aeskulap
SUBDIR += agave
SUBDIR += agg
+ SUBDIR += alembic
SUBDIR += alpng
SUBDIR += amide
SUBDIR += ampasACES-container
diff --git a/graphics/alembic/Makefile b/graphics/alembic/Makefile
new file mode 100644
index 000000000000..432654f31e98
--- /dev/null
+++ b/graphics/alembic/Makefile
@@ -0,0 +1,27 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= alembic
+PORTVERSION= 1.5.8
+CATEGORIES= graphics
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Open framework for storing and sharing graphic scene data
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libImath-2_2.so:${PORTSDIR}/graphics/ilmbase \
+ libhdf5.so:${PORTSDIR}/science/hdf5
+
+BROKEN_FreeBSD_9= does not build (insufficient C++11 support)
+
+USE_GITHUB= yes
+
+USES= cmake compiler:c++11-lang
+USE_CXXSTD= c++11
+USE_GL= glew glut
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON -DUSE_PYALEMBIC:BOOL=OFF
+
+.include <bsd.port.mk>
diff --git a/graphics/alembic/distinfo b/graphics/alembic/distinfo
new file mode 100644
index 000000000000..38ae3d68594d
--- /dev/null
+++ b/graphics/alembic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (alembic-alembic-1.5.8_GH0.tar.gz) = d5e94c5bee16bc7c2971338c5aada4f585794f01b2aa7e4bb4267d7d1002b533
+SIZE (alembic-alembic-1.5.8_GH0.tar.gz) = 1307347
diff --git a/graphics/alembic/files/patch-CMakeLists.txt b/graphics/alembic/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9d6730388416
--- /dev/null
+++ b/graphics/alembic/files/patch-CMakeLists.txt
@@ -0,0 +1,67 @@
+--- CMakeLists.txt.orig 2015-01-15 18:28:49 UTC
++++ CMakeLists.txt
+@@ -78,7 +78,7 @@ IF( "${CMAKE_SYSTEM_NAME}" MATCHES "Darw
+ ENDIF()
+
+ SET( LINUX FALSE )
+-IF( "${CMAKE_SYSTEM_NAME}" MATCHES "Linux" )
++IF( "${CMAKE_SYSTEM_NAME}" MATCHES "Linux|FreeBSD" )
+ SET( LINUX TRUE )
+ ENDIF()
+
+@@ -90,9 +90,6 @@ IF ( "${CMAKE_BUILD_TYPE}" MATCHES "Debu
+ ENDIF()
+ ELSEIF ( "${CMAKE_BUILD_TYPE}" MATCHES "Release" )
+ ADD_DEFINITIONS( -DNDEBUG=1 -UDEBUG )
+- IF ( NOT WINDOWS )
+- ADD_DEFINITIONS( -O3 )
+- ENDIF()
+ ENDIF()
+
+ IF ( NOT WINDOWS )
+@@ -130,10 +127,6 @@ endif ()
+ IF ( DEFINED ENV{ALEMBIC_INSTALL_PREFIX} )
+ SET( CMAKE_INSTALL_PREFIX
+ $ENV{ALEMBIC_INSTALL_PREFIX}/alembic-${VERSION} )
+-ELSE ()
+- SET( ORIGINAL_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX} )
+- SET( CMAKE_INSTALL_PREFIX
+- ${ORIGINAL_INSTALL_PREFIX}/alembic-${VERSION} )
+ ENDIF ()
+
+ # Tell me what my install location would be
+@@ -192,6 +185,7 @@ FIND_PACKAGE(ZLIB REQUIRED)
+ #-******************************************************************************
+ FIND_PACKAGE( OpenGL )
+ FIND_PACKAGE( GLUT )
++FIND_PACKAGE( GLEW )
+
+ IF ( ${WINDOWS} )
+ # Do a windows OpenGL thing, whatever that may be
+@@ -203,7 +197,7 @@ ELSEIF( ${DARWIN} )
+ # Do a darwin OpenGL thing.
+ SET( ALEMBIC_GL_LIBS ${GLUT_LIBRARY} "-framework OpenGL" )
+ ELSE()
+- SET( ALEMBIC_GL_LIBS GLEW ${GLUT_LIBRARY} ${OPENGL_LIBRARIES} )
++ SET( ALEMBIC_GL_LIBS ${GLEW_LIBRARY} ${GLUT_LIBRARY} ${OPENGL_LIBRARIES} )
+ ENDIF()
+
+ MESSAGE( STATUS "OpenGL Libraries: ${ALEMBIC_GL_LIBS}" )
+@@ -250,9 +244,6 @@ ELSE()
+ INCLUDE_DIRECTORIES( ${ALEMBIC_PYILMBASE_INCLUDE_DIRECTORY} )
+ ENDIF ()
+
+-# Include Python stuff
+-INCLUDE("./build/AlembicPython.cmake")
+-
+ # Include HDF5 stuff
+ INCLUDE("./build/AlembicHDF5.cmake")
+ if ( ALEMBIC_HDF5_FOUND )
+@@ -310,6 +301,7 @@ IF(DEFINED USE_PYALEMBIC AND NOT USE_PYA
+ MESSAGE(STATUS "Skipping Alembic Python bindings")
+ ELSE()
+ MESSAGE(STATUS "About to include Python cmake files")
++ INCLUDE("./build/AlembicPython.cmake")
+ ADD_SUBDIRECTORY( python )
+ ENDIF()
+
diff --git a/graphics/alembic/files/patch-build_AlembicBoost.cmake b/graphics/alembic/files/patch-build_AlembicBoost.cmake
new file mode 100644
index 000000000000..f36a58a98276
--- /dev/null
+++ b/graphics/alembic/files/patch-build_AlembicBoost.cmake
@@ -0,0 +1,18 @@
+--- build/AlembicBoost.cmake.orig 2015-01-15 18:28:49 UTC
++++ build/AlembicBoost.cmake
+@@ -107,13 +107,13 @@ ENDIF()
+ # Find the static and multi-threaded version only
+ #-******************************************************************************
+ #-******************************************************************************
+-SET( Boost_USE_STATIC_LIBS TRUE )
++SET( Boost_USE_STATIC_LIBS FALSE )
+ SET( Boost_USE_MULTITHREADED TRUE )
+ SET( Boost_NO_BOOST_CMAKE TRUE )
+
+ #- Alembic's python bridge boost-python 1.44 (for bug fixes)
+ SET( Boost_ADDITIONAL_VERSIONS "1.44" "1.42" "1.42.0" "1.43" "1.43.0" "1.44" "1.44.0" "1.45.0" )
+-FIND_PACKAGE( Boost COMPONENTS program_options python REQUIRED thread )
++FIND_PACKAGE( Boost COMPONENTS thread OPTIONAL_COMPONENTS python)
+
+
+ #-******************************************************************************
diff --git a/graphics/alembic/files/patch-lib_Alembic_Util_Murmur3.cpp b/graphics/alembic/files/patch-lib_Alembic_Util_Murmur3.cpp
new file mode 100644
index 000000000000..5a9549eb64b0
--- /dev/null
+++ b/graphics/alembic/files/patch-lib_Alembic_Util_Murmur3.cpp
@@ -0,0 +1,11 @@
+--- lib/Alembic/Util/Murmur3.cpp.orig 2015-01-15 18:28:49 UTC
++++ lib/Alembic/Util/Murmur3.cpp
+@@ -41,6 +41,8 @@
+
+ #ifdef __APPLE__
+ #include <machine/endian.h>
++#elif defined(__FreeBSD__)
++#include <sys/endian.h>
+ #elif !defined(_MSC_VER)
+ #include <endian.h>
+ #endif
diff --git a/graphics/alembic/pkg-descr b/graphics/alembic/pkg-descr
new file mode 100644
index 000000000000..f42ea70242a6
--- /dev/null
+++ b/graphics/alembic/pkg-descr
@@ -0,0 +1,12 @@
+Alembic is an open computer graphics interchange framework. It distills
+complex, animated scenes into a non-procedural, application-independent
+set of baked geometric results. This "distillation" of scenes into baked
+geometry is exactly analogous to the distillation of lighting and
+rendering scenes into rendered image data.
+
+Alembic is focused on efficiently storing the computed results of complex
+procedural geometric constructions. It is very specifically NOT concerned
+with storing the complex dependency graph of procedural tools used to
+create the computed results.
+
+WWW: http://alembic.io/
diff --git a/graphics/alembic/pkg-plist b/graphics/alembic/pkg-plist
new file mode 100644
index 000000000000..cd3015cfbed8
--- /dev/null
+++ b/graphics/alembic/pkg-plist
@@ -0,0 +1,162 @@
+bin/SimpleAbcViewer
+bin/abcconvert
+bin/abcecho
+bin/abcechobounds
+bin/abcstitcher
+include/AbcClients/WFObjConvert/AbcReader.h
+include/AbcClients/WFObjConvert/All.h
+include/AbcClients/WFObjConvert/Foundation.h
+include/AbcClients/WFObjConvert/Parser.h
+include/AbcClients/WFObjConvert/Reader.h
+include/AbcOpenGL/DrawContext.h
+include/AbcOpenGL/Drawable.h
+include/AbcOpenGL/Foundation.h
+include/AbcOpenGL/GLCamera.h
+include/AbcOpenGL/ICurvesDrw.h
+include/AbcOpenGL/INuPatchDrw.h
+include/AbcOpenGL/IObjectDrw.h
+include/AbcOpenGL/IPointsDrw.h
+include/AbcOpenGL/IPolyMeshDrw.h
+include/AbcOpenGL/ISubDDrw.h
+include/AbcOpenGL/IXformDrw.h
+include/AbcOpenGL/MeshDrwHelper.h
+include/AbcOpenGL/Scene.h
+include/AbcOpenGL/SceneWrapper.h
+include/Alembic/Abc/All.h
+include/Alembic/Abc/ArchiveInfo.h
+include/Alembic/Abc/Argument.h
+include/Alembic/Abc/Base.h
+include/Alembic/Abc/ErrorHandler.h
+include/Alembic/Abc/Foundation.h
+include/Alembic/Abc/IArchive.h
+include/Alembic/Abc/IArrayProperty.h
+include/Alembic/Abc/IBaseProperty.h
+include/Alembic/Abc/ICompoundProperty.h
+include/Alembic/Abc/IObject.h
+include/Alembic/Abc/ISampleSelector.h
+include/Alembic/Abc/IScalarProperty.h
+include/Alembic/Abc/ISchema.h
+include/Alembic/Abc/ISchemaObject.h
+include/Alembic/Abc/ITypedArrayProperty.h
+include/Alembic/Abc/ITypedScalarProperty.h
+include/Alembic/Abc/OArchive.h
+include/Alembic/Abc/OArrayProperty.h
+include/Alembic/Abc/OBaseProperty.h
+include/Alembic/Abc/OCompoundProperty.h
+include/Alembic/Abc/OObject.h
+include/Alembic/Abc/OScalarProperty.h
+include/Alembic/Abc/OSchema.h
+include/Alembic/Abc/OSchemaObject.h
+include/Alembic/Abc/OTypedArrayProperty.h
+include/Alembic/Abc/OTypedScalarProperty.h
+include/Alembic/Abc/Reference.h
+include/Alembic/Abc/SourceName.h
+include/Alembic/Abc/TypedArraySample.h
+include/Alembic/Abc/TypedPropertyTraits.h
+include/Alembic/AbcCollection/All.h
+include/Alembic/AbcCollection/ICollections.h
+include/Alembic/AbcCollection/OCollections.h
+include/Alembic/AbcCollection/SchemaInfoDeclarations.h
+include/Alembic/AbcCoreAbstract/All.h
+include/Alembic/AbcCoreAbstract/ArchiveReader.h
+include/Alembic/AbcCoreAbstract/ArchiveWriter.h
+include/Alembic/AbcCoreAbstract/ArrayPropertyReader.h
+include/Alembic/AbcCoreAbstract/ArrayPropertyWriter.h
+include/Alembic/AbcCoreAbstract/ArraySample.h
+include/Alembic/AbcCoreAbstract/ArraySampleKey.h
+include/Alembic/AbcCoreAbstract/BasePropertyReader.h
+include/Alembic/AbcCoreAbstract/BasePropertyWriter.h
+include/Alembic/AbcCoreAbstract/CompoundPropertyReader.h
+include/Alembic/AbcCoreAbstract/CompoundPropertyWriter.h
+include/Alembic/AbcCoreAbstract/DataType.h
+include/Alembic/AbcCoreAbstract/ForwardDeclarations.h
+include/Alembic/AbcCoreAbstract/Foundation.h
+include/Alembic/AbcCoreAbstract/MetaData.h
+include/Alembic/AbcCoreAbstract/ObjectHeader.h
+include/Alembic/AbcCoreAbstract/ObjectReader.h
+include/Alembic/AbcCoreAbstract/ObjectWriter.h
+include/Alembic/AbcCoreAbstract/PropertyHeader.h
+include/Alembic/AbcCoreAbstract/ReadArraySampleCache.h
+include/Alembic/AbcCoreAbstract/ScalarPropertyReader.h
+include/Alembic/AbcCoreAbstract/ScalarPropertyWriter.h
+include/Alembic/AbcCoreAbstract/ScalarSample.h
+include/Alembic/AbcCoreAbstract/TimeSampling.h
+include/Alembic/AbcCoreAbstract/TimeSamplingType.h
+include/Alembic/AbcCoreFactory/All.h
+include/Alembic/AbcCoreFactory/IFactory.h
+include/Alembic/AbcCoreHDF5/All.h
+include/Alembic/AbcCoreHDF5/ReadWrite.h
+include/Alembic/AbcCoreOgawa/All.h
+include/Alembic/AbcCoreOgawa/ReadWrite.h
+include/Alembic/AbcGeom/All.h
+include/Alembic/AbcGeom/ArchiveBounds.h
+include/Alembic/AbcGeom/Basis.h
+include/Alembic/AbcGeom/CameraSample.h
+include/Alembic/AbcGeom/CurveType.h
+include/Alembic/AbcGeom/FaceSetExclusivity.h
+include/Alembic/AbcGeom/FilmBackXformOp.h
+include/Alembic/AbcGeom/Foundation.h
+include/Alembic/AbcGeom/GeometryScope.h
+include/Alembic/AbcGeom/ICamera.h
+include/Alembic/AbcGeom/ICurves.h
+include/Alembic/AbcGeom/IFaceSet.h
+include/Alembic/AbcGeom/IGeomBase.h
+include/Alembic/AbcGeom/IGeomParam.h
+include/Alembic/AbcGeom/ILight.h
+include/Alembic/AbcGeom/INuPatch.h
+include/Alembic/AbcGeom/IPoints.h
+include/Alembic/AbcGeom/IPolyMesh.h
+include/Alembic/AbcGeom/ISubD.h
+include/Alembic/AbcGeom/IXform.h
+include/Alembic/AbcGeom/OCamera.h
+include/Alembic/AbcGeom/OCurves.h
+include/Alembic/AbcGeom/OFaceSet.h
+include/Alembic/AbcGeom/OGeomBase.h
+include/Alembic/AbcGeom/OGeomParam.h
+include/Alembic/AbcGeom/OLight.h
+include/Alembic/AbcGeom/ONuPatch.h
+include/Alembic/AbcGeom/OPoints.h
+include/Alembic/AbcGeom/OPolyMesh.h
+include/Alembic/AbcGeom/OSubD.h
+include/Alembic/AbcGeom/OXform.h
+include/Alembic/AbcGeom/SchemaInfoDeclarations.h
+include/Alembic/AbcGeom/Visibility.h
+include/Alembic/AbcGeom/XformOp.h
+include/Alembic/AbcGeom/XformSample.h
+include/Alembic/AbcMaterial/IMaterial.h
+include/Alembic/AbcMaterial/MaterialAssignment.h
+include/Alembic/AbcMaterial/MaterialFlatten.h
+include/Alembic/AbcMaterial/OMaterial.h
+include/Alembic/AbcMaterial/SchemaInfoDeclarations.h
+include/Alembic/Ogawa/Foundation.h
+include/Alembic/Ogawa/IArchive.h
+include/Alembic/Ogawa/IData.h
+include/Alembic/Ogawa/IGroup.h
+include/Alembic/Ogawa/IStreams.h
+include/Alembic/Ogawa/OArchive.h
+include/Alembic/Ogawa/OData.h
+include/Alembic/Ogawa/OGroup.h
+include/Alembic/Ogawa/OStream.h
+include/Alembic/Util/All.h
+include/Alembic/Util/Digest.h
+include/Alembic/Util/Dimensions.h
+include/Alembic/Util/Exception.h
+include/Alembic/Util/Foundation.h
+include/Alembic/Util/Murmur3.h
+include/Alembic/Util/Naming.h
+include/Alembic/Util/OperatorBool.h
+include/Alembic/Util/PlainOldDataType.h
+include/Alembic/Util/SpookyV2.h
+include/Alembic/Util/TokenMap.h
+lib/libAbcWFObjConvert.so
+lib/libAlembicAbc.so
+lib/libAlembicAbcCollection.so
+lib/libAlembicAbcCoreAbstract.so
+lib/libAlembicAbcCoreFactory.so
+lib/libAlembicAbcCoreHDF5.so
+lib/libAlembicAbcCoreOgawa.so
+lib/libAlembicAbcGeom.so
+lib/libAlembicAbcMaterial.so
+lib/libAlembicAbcOpenGL.so
+lib/libAlembicOgawa.so
+lib/libAlembicUtil.so