aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-10 06:48:23 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-10 06:48:23 +0800
commit2ee9175d2c4ea2ef0e2e12b0fe5f905878c0bf64 (patch)
tree80da2fe72b766a328ef0dd7a070d30c54a9d3423 /graphics
parenta3b92a6aeddfc28972840e6fff3a8cd843366c05 (diff)
downloadfreebsd-ports-gnome-2ee9175d2c4ea2ef0e2e12b0fe5f905878c0bf64.tar.gz
freebsd-ports-gnome-2ee9175d2c4ea2ef0e2e12b0fe5f905878c0bf64.tar.zst
freebsd-ports-gnome-2ee9175d2c4ea2ef0e2e12b0fe5f905878c0bf64.zip
- Use OPTIONS.
- Install data with the correct permissions.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/openclipart/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/openclipart/Makefile b/graphics/openclipart/Makefile
index 305ac4b96c9f..89a844f247db 100644
--- a/graphics/openclipart/Makefile
+++ b/graphics/openclipart/Makefile
@@ -16,9 +16,11 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Open Clip Art Library
USE_BZIP2= yes
-PLIST= ${WRKDIR}/pkg-plist
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${SVGPNG}
NO_BUILD= yes
+PLIST= ${WRKDIR}/pkg-plist
+
+OPTIONS= PNG "Install png files" on
.include <bsd.port.pre.mk>
@@ -28,13 +30,6 @@ SVGPNG= -full
SVGPNG= -svgonly
.endif
-pre-everything::
-.if !defined(WITHOUT_PNG)
- @${ECHO_MSG} "Disable the install of png files by defining"
- @${ECHO_MSG} "WITHOUT_PNG=yes"
- @${ECHO_MSG} ""
-.endif
-
pre-install:
${RM} -f ${PLIST}
${TOUCH} -f ${PLIST}
@@ -46,6 +41,8 @@ pre-install:
do-install:
cd ${WRKSRC} && ${FIND} . | \
- ${CPIO} -vpdm -L -R ${LIBOWN}:${LIBGRP} ${DATADIR}
+ ${CPIO} -vpdm -L -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ @${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ @${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
.include <bsd.port.post.mk>