aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-25 01:33:30 +0800
committertijl <tijl@FreeBSD.org>2014-04-25 01:33:30 +0800
commit383face66db5a21e4c5f4130f8e8d2b9d3f7b345 (patch)
treed676a4b05421db4d4f0707efb7939527cf323871 /graphics
parentef427bdbc7f4892e658632b68491f571d08a74ce (diff)
downloadfreebsd-ports-gnome-383face66db5a21e4c5f4130f8e8d2b9d3f7b345.tar.gz
freebsd-ports-gnome-383face66db5a21e4c5f4130f8e8d2b9d3f7b345.tar.zst
freebsd-ports-gnome-383face66db5a21e4c5f4130f8e8d2b9d3f7b345.zip
- Convert to USES=libtool.
- Use LDFLAGS instead of LIBS.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/corona/Makefile14
-rw-r--r--graphics/corona/pkg-plist1
2 files changed, 4 insertions, 11 deletions
diff --git a/graphics/corona/Makefile b/graphics/corona/Makefile
index 63528eeff64b..d079c4dd99d0 100644
--- a/graphics/corona/Makefile
+++ b/graphics/corona/Makefile
@@ -3,7 +3,7 @@
PORTNAME= corona
PORTVERSION= 1.0.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF
@@ -11,19 +11,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Graphics library that supports most image formats
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
- libjpeg.so.11:${PORTSDIR}/graphics/jpeg
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
-USE_AUTOTOOLS= libtool
-USE_GNOME= lthack
GNU_CONFIGURE= yes
+USES= libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="${LIBS} -L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-Wall||' \
- ${WRKSRC}/configure
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/graphics/corona/pkg-plist b/graphics/corona/pkg-plist
index 3bd7184106b0..40feabaa7216 100644
--- a/graphics/corona/pkg-plist
+++ b/graphics/corona/pkg-plist
@@ -3,5 +3,4 @@ bin/corona-config
include/corona.h
lib/libcorona-1.0.2.so
lib/libcorona.a
-lib/libcorona.la
lib/libcorona.so