aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-05-21 04:24:46 +0800
committermezz <mezz@FreeBSD.org>2012-05-21 04:24:46 +0800
commit445709914e36b4c1cc1dfb01134a538eacb6be9b (patch)
treea02337ed3d83936a29e8d4a36e462a5b2261a5a8 /graphics
parent7750a46c504fc80e1698da3a146667e3b2002b0b (diff)
downloadfreebsd-ports-gnome-445709914e36b4c1cc1dfb01134a538eacb6be9b.tar.gz
freebsd-ports-gnome-445709914e36b4c1cc1dfb01134a538eacb6be9b.tar.zst
freebsd-ports-gnome-445709914e36b4c1cc1dfb01134a538eacb6be9b.zip
Get its configure to recognize amd64 by s/x86_64/amd64/g to enable SSE/MMX.
PR: ports/167721 Submitted by: Jan Beich <jbeich@tormail.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gegl/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 49609653b265..d9e5911c2c3b 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -197,11 +197,15 @@ CONFIGURE_ARGS+= --disable-docs
post-patch:
.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e '10s|\\||; 11,13d' ${WRKSRC}/Makefile.am
-.endif
- ${REINPLACE_CMD} -e 's|-T||' ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in
- ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|/usr/bin/ruby|/usr/bin/env ruby|' ${WRKSRC}/tools/gobj2dot.rb
+ ${REINPLACE_CMD} -e '10s|\\||; 11,13d' \
+ ${WRKSRC}/Makefile.am
+.endif
+ ${REINPLACE_CMD} -e 's|-T||' \
+ ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in
+ ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g ; s|x86_64|amd64|g' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|/usr/bin/ruby|/usr/bin/env ruby|' \
+ ${WRKSRC}/tools/gobj2dot.rb
post-build:
.if !defined(NOPORTDOCS)