aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-03-30 23:08:58 +0800
committermat <mat@FreeBSD.org>2004-03-30 23:08:58 +0800
commit49bbd73e71032c3e192bbef0416bc4c1bf252908 (patch)
tree2db8a80dc337af539a5e932f6ba2b4acd85e4992 /graphics
parentb0adb3aa3c5eb724fa2ebc6dbb6dc864b0a31ecf (diff)
downloadfreebsd-ports-gnome-49bbd73e71032c3e192bbef0416bc4c1bf252908.tar.gz
freebsd-ports-gnome-49bbd73e71032c3e192bbef0416bc4c1bf252908.tar.zst
freebsd-ports-gnome-49bbd73e71032c3e192bbef0416bc4c1bf252908.zip
Update to 1.16 (1.12 was not available any more)
Approved by: maintainer timeout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Image-Info/Makefile17
-rw-r--r--graphics/p5-Image-Info/distinfo3
-rw-r--r--graphics/p5-Image-Info/files/5.005-Info.pm.tmpl11
-rw-r--r--graphics/p5-Image-Info/files/5.005-lib::Image::Info::PPM.pm12
4 files changed, 38 insertions, 5 deletions
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index 389898ded573..57a76941499f 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Image-Info
-PORTVERSION= 1.12
+PORTVERSION= 1.16
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Image
@@ -15,13 +15,22 @@ PKGNAMEPREFIX= p5-
MAINTAINER= shell@shellhung.org
COMMENT= Perl module for getting image information
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+BUILD_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+ ${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Image::Info.3 Image::Info::BMP.3 Image::Info::SVG.3 \
Image::Info::XBM.3 Image::Info::XPM.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES= ${PATCHDIR}/5.005-Info.pm.tmpl ${PATCHDIR}/5.005-lib::Image::Info::PPM.pm
+post-patch:
+ @${RM} -f ${WRKSRC}/lib/Image/Info/PPM.pm.orig
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Info/distinfo b/graphics/p5-Image-Info/distinfo
index 0e7a93210669..4cd5fd5e6568 100644
--- a/graphics/p5-Image-Info/distinfo
+++ b/graphics/p5-Image-Info/distinfo
@@ -1 +1,2 @@
-MD5 (Image-Info-1.12.tar.gz) = be1aa05997b119e986bd0a90f1a6c3c5
+MD5 (Image-Info-1.16.tar.gz) = 502b6299ef2d41f67bca4e1f7d9335ab
+SIZE (Image-Info-1.16.tar.gz) = 312250
diff --git a/graphics/p5-Image-Info/files/5.005-Info.pm.tmpl b/graphics/p5-Image-Info/files/5.005-Info.pm.tmpl
new file mode 100644
index 000000000000..fbb63e18d0c1
--- /dev/null
+++ b/graphics/p5-Image-Info/files/5.005-Info.pm.tmpl
@@ -0,0 +1,11 @@
+--- Info.pm.tmpl~ Wed Jan 7 13:39:11 2004
++++ Info.pm.tmpl Mon Mar 22 14:33:37 2004
+@@ -33,7 +33,7 @@
+ }
+ elsif (ref($source) eq "SCALAR") {
+ if ($] >= 5.008) {
+- open(my $s, "<", $source) or return _os_err("Can't open string");
++ open(my $s, "<". $source) or return _os_err("Can't open string");
+ $source = $s;
+ }
+ else {
diff --git a/graphics/p5-Image-Info/files/5.005-lib::Image::Info::PPM.pm b/graphics/p5-Image-Info/files/5.005-lib::Image::Info::PPM.pm
new file mode 100644
index 000000000000..ad5ef833b904
--- /dev/null
+++ b/graphics/p5-Image-Info/files/5.005-lib::Image::Info::PPM.pm
@@ -0,0 +1,12 @@
+--- lib/Image/Info/PPM.pm~ Mon Oct 6 18:38:53 2003
++++ lib/Image/Info/PPM.pm Mon Mar 22 14:29:29 2004
+@@ -39,7 +39,8 @@
+ $type = shift(@header);
+ $type =~ s/^P// || die;
+ $binary++ if $type > 3;
+- $type = "p" . qw/p b g/[$type % 3] . "m";
++ my @typetmp = qw/p b g/;
++ $type = "p" . $typetmp[$type % 3] . "m";
+ $num_wanted = 2 if $type eq "pbm";
+ }
+