aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-11-27 13:58:14 +0800
committerdinoex <dinoex@FreeBSD.org>2013-11-27 13:58:14 +0800
commit4b4645972f433b5ff2d9e3b28a1db0d28c95ac34 (patch)
tree81e4158aa2cbafb37ebc341aefa21e93fc948497 /graphics
parent159c163062b511a200ff53a9f35490aff5b2c4a9 (diff)
downloadfreebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.tar.gz
freebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.tar.zst
freebsd-ports-gnome-4b4645972f433b5ff2d9e3b28a1db0d28c95ac34.zip
- use STAGEDIR
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ruby-gd/Makefile26
-rw-r--r--graphics/rubygem-scruffy/Makefile5
2 files changed, 15 insertions, 16 deletions
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index b4dbbca6d35d..8b6e3dd65fc7 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -16,7 +16,7 @@ COMMENT= Ruby extension library to use Thomas Boutell's gd library
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-NO_STAGE= yes
+NEED_ROOT= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -33,7 +33,7 @@ CONFIGURE_ARGS+= --enable-gd2_0 \
--with-gd-include="${LOCALBASE}/include"
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
.if exists(${LOCALBASE}/bin/gd2topng)
@@ -66,20 +66,20 @@ post-patch:
${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/rubygem-scruffy/Makefile b/graphics/rubygem-scruffy/Makefile
index f8b16690053b..d47b64e3ed2c 100644
--- a/graphics/rubygem-scruffy/Makefile
+++ b/graphics/rubygem-scruffy/Makefile
@@ -16,10 +16,9 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-NO_STAGE= yes
post-install:
${REINPLACE_CMD} -e 's|#{options|0 0 #{options|' \
- ${PREFIX}/${GEM_LIB_DIR}/lib/scruffy/renderers/base.rb
- grep options ${PREFIX}/${GEM_LIB_DIR}/lib/scruffy/renderers/base.rb
+ ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/lib/scruffy/renderers/base.rb
+ grep options ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/lib/scruffy/renderers/base.rb
.include <bsd.port.mk>