aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-23 10:39:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-23 10:39:30 +0800
commit4ef0a880ff8ab5125344d495203f986e92fd66ae (patch)
treec9cfc7b301797cf79623146c5c5db77ea7c5dd73 /graphics
parent4109445c135a2408501cf9a98ebed025075a98bc (diff)
downloadfreebsd-ports-gnome-4ef0a880ff8ab5125344d495203f986e92fd66ae.tar.gz
freebsd-ports-gnome-4ef0a880ff8ab5125344d495203f986e92fd66ae.tar.zst
freebsd-ports-gnome-4ef0a880ff8ab5125344d495203f986e92fd66ae.zip
- Use new LIB_DEPENDS syntax
- Add needed LIBS (required after spatiallite/librasterlite USES=libtool conversion) Approved by: portmgr blanket
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libreatlas/Makefile35
1 files changed, 18 insertions, 17 deletions
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
index 7e74b0dc9eb7..33b31325a4da 100644
--- a/graphics/libreatlas/Makefile
+++ b/graphics/libreatlas/Makefile
@@ -12,24 +12,24 @@ COMMENT= Open Source Geography Education application
LICENSE= GPLv3
-LIB_DEPENDS= mspack:${PORTSDIR}/archivers/libmspack \
- spatialite:${PORTSDIR}/databases/spatialite \
- sqlite3:${PORTSDIR}/databases/sqlite3 \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- geos:${PORTSDIR}/graphics/geos \
- jbig:${PORTSDIR}/graphics/jbigkit \
- jpeg:${PORTSDIR}/graphics/jpeg \
- geotiff:${PORTSDIR}/graphics/libgeotiff \
- rasterlite:${PORTSDIR}/graphics/librasterlite \
- png15:${PORTSDIR}/graphics/png \
- proj:${PORTSDIR}/graphics/proj \
- tiff:${PORTSDIR}/graphics/tiff \
+LIB_DEPENDS= libmspack.so:${PORTSDIR}/archivers/libmspack \
+ libspatialite.so:${PORTSDIR}/databases/spatialite \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libgeos.so:${PORTSDIR}/graphics/geos \
+ libjbig.so:${PORTSDIR}/graphics/jbigkit \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libgeotiff.so:${PORTSDIR}/graphics/libgeotiff \
+ librasterlite.so:${PORTSDIR}/graphics/librasterlite \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libproj.so:${PORTSDIR}/graphics/proj \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
libfreetype.so:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- freexl:${PORTSDIR}/textproc/freexl \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libfreexl.so:${PORTSDIR}/textproc/freexl \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
GNU_CONFIGURE= yes
USES= pkgconfig gettext gmake iconv
@@ -41,6 +41,7 @@ WANT_UNICODE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -lgeos_c
PLIST_FILES= bin/LibreAtlas