aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-08-10 19:47:36 +0800
committermakc <makc@FreeBSD.org>2009-08-10 19:47:36 +0800
commit535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a (patch)
treeacc82b024802c87837dd90521b3991bd7c3b2ce5 /graphics
parent0f3e4afecbce328fa8a996731b691e68dbaef539 (diff)
downloadfreebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.tar.gz
freebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.tar.zst
freebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.zip
Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV All ports: - remove needless post-extract target - make patches relative to ${PATCH_WRKSRC} - clean up - bump PORTREVISION when required databases/akonadi: - replace dependency on boost-python-libs with boost-libs (finally, boost-pyhton does not conflict with boost \o/) deskutils/kdepim*: - replace boost-python-libs with boost-libs - reduce dependencies - respect PREFIX - fix build with qt3 installed misc/kdeedu4: - add dependency on astro/xplanet (for KStars) misc/kdeutils4: - add dependency on devel/qca (for okteta) - make dependency on kdebase non-optional multimedia/kdemultimedia4: - add optional support for PulseAudio x11/kdebase4: - remove needless dependency on kdebase4-runtime x11/kdebase4-runtime, x11/kdebase4-workspace - remove extra CMAKE_ARGS to fix build for qt3/kde3 users x11/kdelibs4 - remove needless dependencies - remove extra CMAKE_ARGS to fix build for qt3/kde3 users
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kdegraphics4/Makefile5
-rw-r--r--graphics/kdegraphics4/files/patch-libs__libkdcraw__CMakeLists.txt4
-rw-r--r--graphics/kdegraphics4/files/patch-libs__libkexiv2__CMakeLists.txt4
-rw-r--r--graphics/kdegraphics4/files/patch-libs__libkipi__CMakeLists.txt4
4 files changed, 7 insertions, 10 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 9d9bc563c1db..ff03344679de 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -44,11 +44,8 @@ QT_COMPONENTS= opengl gui svg iconengines pixeltool \
moc_build rcc_build uic_build qmake_build
MAKE_JOBS_SAFE= yes
-post-extract:
- ${MKDIR} ${WRKSRC}
-
post-patch:
- ${FIND} ${WRKSRC}/.. -type f -name CMakeLists.txt | ${XARGS} \
+ ${FIND} ${PATCH_WRKSRC} -type f -name CMakeLists.txt | ${XARGS} \
${REINPLACE_CMD} -e 's|pkgconfig|../libdata/pkgconfig|'
.include <bsd.port.mk>
diff --git a/graphics/kdegraphics4/files/patch-libs__libkdcraw__CMakeLists.txt b/graphics/kdegraphics4/files/patch-libs__libkdcraw__CMakeLists.txt
index 5d3df95751ba..46a5c62ffd1d 100644
--- a/graphics/kdegraphics4/files/patch-libs__libkdcraw__CMakeLists.txt
+++ b/graphics/kdegraphics4/files/patch-libs__libkdcraw__CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../libs/libkdcraw/CMakeLists.txt.orig 2009-05-06 12:13:22.000000000 +0200
-+++ ../libs/libkdcraw/CMakeLists.txt 2009-06-07 01:15:33.000000000 +0200
+--- ./libs/libkdcraw/CMakeLists.txt.orig 2009-05-06 12:13:22.000000000 +0200
++++ ./libs/libkdcraw/CMakeLists.txt 2009-06-07 01:15:33.000000000 +0200
@@ -114,9 +114,9 @@
# =======================================================
diff --git a/graphics/kdegraphics4/files/patch-libs__libkexiv2__CMakeLists.txt b/graphics/kdegraphics4/files/patch-libs__libkexiv2__CMakeLists.txt
index fd4dd54dd868..0372a8fae51a 100644
--- a/graphics/kdegraphics4/files/patch-libs__libkexiv2__CMakeLists.txt
+++ b/graphics/kdegraphics4/files/patch-libs__libkexiv2__CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../libs/libkexiv2/CMakeLists.txt.orig 2008-06-03 17:48:03.000000000 +0400
-+++ ../libs/libkexiv2/CMakeLists.txt 2008-08-18 20:07:28.000000000 +0400
+--- ./libs/libkexiv2/CMakeLists.txt.orig 2008-06-03 17:48:03.000000000 +0400
++++ ./libs/libkexiv2/CMakeLists.txt 2008-08-18 20:07:28.000000000 +0400
@@ -52,8 +52,8 @@
SUBDIRS(libkexiv2)
diff --git a/graphics/kdegraphics4/files/patch-libs__libkipi__CMakeLists.txt b/graphics/kdegraphics4/files/patch-libs__libkipi__CMakeLists.txt
index 59c5f8508491..6ea38105eb36 100644
--- a/graphics/kdegraphics4/files/patch-libs__libkipi__CMakeLists.txt
+++ b/graphics/kdegraphics4/files/patch-libs__libkipi__CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../libs/libkipi/CMakeLists.txt.orig 2008-06-03 17:48:04.000000000 +0400
-+++ ../libs/libkipi/CMakeLists.txt 2008-08-18 20:07:58.000000000 +0400
+--- ./libs/libkipi/CMakeLists.txt.orig 2008-06-03 17:48:04.000000000 +0400
++++ ./libs/libkipi/CMakeLists.txt 2008-08-18 20:07:58.000000000 +0400
@@ -51,8 +51,8 @@
SUBDIRS(libkipi)