aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-30 20:35:33 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-30 20:35:33 +0800
commit56a908ea1ee095f594a10a56b460c43b21d8a4d7 (patch)
tree6910d33f75352f75e8bf361a48ea7a296763e011 /graphics
parenta6161817c19b8f5924db215e5f04571b3899387b (diff)
downloadfreebsd-ports-gnome-56a908ea1ee095f594a10a56b460c43b21d8a4d7.tar.gz
freebsd-ports-gnome-56a908ea1ee095f594a10a56b460c43b21d8a4d7.tar.zst
freebsd-ports-gnome-56a908ea1ee095f594a10a56b460c43b21d8a4d7.zip
- fix build for png-1.4.1
- bump PORTREVISION
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evas-loader-png/Makefile2
-rw-r--r--graphics/evas-loader-png/files/patch-evas_image_load_png.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/evas-loader-png/Makefile b/graphics/evas-loader-png/Makefile
index dc864f60820f..6fcf2f1ef2b2 100644
--- a/graphics/evas-loader-png/Makefile
+++ b/graphics/evas-loader-png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= loader-png
PORTVERSION= 0.9.9.042
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
http://download.enlightenment.org/snapshots/2008-01-25/
diff --git a/graphics/evas-loader-png/files/patch-evas_image_load_png.c b/graphics/evas-loader-png/files/patch-evas_image_load_png.c
new file mode 100644
index 000000000000..7557aa27ea28
--- /dev/null
+++ b/graphics/evas-loader-png/files/patch-evas_image_load_png.c
@@ -0,0 +1,11 @@
+--- src/modules/loaders/png/evas_image_load_png.c.orig 2007-10-28 11:35:13.000000000 +0100
++++ src/modules/loaders/png/evas_image_load_png.c 2010-03-30 14:16:48.000000000 +0200
+@@ -44,7 +44,7 @@
+ fclose(f);
+ return 0;
+ }
+- if (!png_check_sig(buf, PNG_BYTES_TO_CHECK))
++ if (png_sig_cmp(buf, 0, PNG_BYTES_TO_CHECK))
+ {
+ fclose(f);
+ return 0;