aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-21 01:35:15 +0800
committermakc <makc@FreeBSD.org>2013-02-21 01:35:15 +0800
commit56ad0aaa6256bbd9f202b423740a5bb7bf80ee32 (patch)
tree3c57df5b9ff244e95f9822d521ab102f32b994c3 /graphics
parent5a3ca4b45e8b2359e50725c3d8e826c608b560b5 (diff)
downloadfreebsd-ports-gnome-56ad0aaa6256bbd9f202b423740a5bb7bf80ee32.tar.gz
freebsd-ports-gnome-56ad0aaa6256bbd9f202b423740a5bb7bf80ee32.tar.zst
freebsd-ports-gnome-56ad0aaa6256bbd9f202b423740a5bb7bf80ee32.zip
Convert to new options framework
PR: ports/175838 Submitted by: Veniamin Gvozdikov (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qiviewer/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/qiviewer/Makefile b/graphics/qiviewer/Makefile
index 5895fd5ed5fd..fc6ec8d34702 100644
--- a/graphics/qiviewer/Makefile
+++ b/graphics/qiviewer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qiviewer
-# Date created: 2011-04-02
-# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
-#
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
# $FreeBSD$
-#
PORTNAME= qiviewer
PORTVERSION= 0.5.0
@@ -32,12 +28,16 @@ PLIST_DIRS= share/qiviewer/locale \
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-OPTIONS= WEBP "Support for WebP image format (experimental)" off
+OPTIONS_DEFINE= WEBP
+WEBP_DESC= Support for WebP image format (experimental)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_WEBP)
+.if ${PORT_OPTIONS:MWEBP}
QMAKEFLAGS+= CONFIG+=enable-webp
+PLIST_SUB+= WEBP=""
+.else
+PLIST_SUB+= WEBP="@comment "
.endif
do-configure:
@@ -47,4 +47,4 @@ post-configure:
${REINPLACE_CMD} -e 's|lrelease|lrelease-qt4|g' \
${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>