aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2011-03-13 04:37:56 +0800
committernaddy <naddy@FreeBSD.org>2011-03-13 04:37:56 +0800
commit5cc5f89f4ee6703741f45abbea8bc68cf2ccae42 (patch)
tree412f70b97b6a0b5d685cd5a94080f899c23ef033 /graphics
parent7662ff54118373a98a9e427010e0511affa6ecf7 (diff)
downloadfreebsd-ports-gnome-5cc5f89f4ee6703741f45abbea8bc68cf2ccae42.tar.gz
freebsd-ports-gnome-5cc5f89f4ee6703741f45abbea8bc68cf2ccae42.tar.zst
freebsd-ports-gnome-5cc5f89f4ee6703741f45abbea8bc68cf2ccae42.zip
* Remove need for gmake (and it breaks with 3.82).
* Add missing includes and fix LP64 warnings.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/stamp/Makefile3
-rw-r--r--graphics/stamp/files/patch-Makefile.in21
-rw-r--r--graphics/stamp/files/patch-gstamp_gstamp.c10
-rw-r--r--graphics/stamp/files/patch-gstamp_gstamp_misc.c10
-rw-r--r--graphics/stamp/files/patch-gstamp_gstamp_signals.c10
-rw-r--r--graphics/stamp/files/patch-gstamp_gstamp_ui.c7
-rw-r--r--graphics/stamp/files/patch-lib_common.c9
-rw-r--r--graphics/stamp/files/patch-lib_transmogrify.c9
8 files changed, 77 insertions, 2 deletions
diff --git a/graphics/stamp/Makefile b/graphics/stamp/Makefile
index 2368576a32d8..b7a673bb68b6 100644
--- a/graphics/stamp/Makefile
+++ b/graphics/stamp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= stamp
PORTVERSION= 2.0.8
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF
@@ -20,7 +20,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS}" \
LIBS="-L${LOCALBASE}/lib"
-USE_GMAKE= unfortunatly
.if !defined(WITHOUT_X11)
USE_GNOME= gtk12
.endif
diff --git a/graphics/stamp/files/patch-Makefile.in b/graphics/stamp/files/patch-Makefile.in
new file mode 100644
index 000000000000..ccd944f6b2e5
--- /dev/null
+++ b/graphics/stamp/files/patch-Makefile.in
@@ -0,0 +1,21 @@
+--- Makefile.in.orig 2011-03-12 21:24:42.000000000 +0100
++++ Makefile.in 2011-03-12 21:25:00.000000000 +0100
+@@ -329,12 +329,12 @@ maintainer-clean-generic clean mostlycle
+ .PHONY: files
+
+ files:
+- @for subdir in $(DATADIRS); do \
+- files=`cd $$subdir; $(MAKE) files | grep -v "make\[[1-9]\]"`; \
+- for file in $$files; do \
+- echo $$subdir/$$file; \
+- done; \
+- done
++ @for subdir in $(DATADIRS); do \
++ files=`cd $$subdir; $(MAKE) files | grep -v "make\[[1-9]\]"`; \
++ for file in $$files; do \
++ echo $$subdir/$$file; \
++ done; \
++ done
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/graphics/stamp/files/patch-gstamp_gstamp.c b/graphics/stamp/files/patch-gstamp_gstamp.c
new file mode 100644
index 000000000000..30976d4b5613
--- /dev/null
+++ b/graphics/stamp/files/patch-gstamp_gstamp.c
@@ -0,0 +1,10 @@
+--- gstamp/gstamp.c.orig 2011-03-12 21:29:21.000000000 +0100
++++ gstamp/gstamp.c 2011-03-12 21:29:42.000000000 +0100
+@@ -7,6 +7,7 @@
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <getopt.h>
+ #include "gstamp.h"
diff --git a/graphics/stamp/files/patch-gstamp_gstamp_misc.c b/graphics/stamp/files/patch-gstamp_gstamp_misc.c
new file mode 100644
index 000000000000..20c8c0a91323
--- /dev/null
+++ b/graphics/stamp/files/patch-gstamp_gstamp_misc.c
@@ -0,0 +1,10 @@
+--- gstamp/gstamp_misc.c.orig 2011-03-12 21:33:49.000000000 +0100
++++ gstamp/gstamp_misc.c 2011-03-12 21:34:16.000000000 +0100
+@@ -2,6 +2,7 @@
+ Eric Werner - 19 FEB 1999
+ ebw@city-net.com
+ */
++#include <sys/shm.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/graphics/stamp/files/patch-gstamp_gstamp_signals.c b/graphics/stamp/files/patch-gstamp_gstamp_signals.c
new file mode 100644
index 000000000000..19926a639db3
--- /dev/null
+++ b/graphics/stamp/files/patch-gstamp_gstamp_signals.c
@@ -0,0 +1,10 @@
+--- gstamp/gstamp_signals.c.orig 2011-03-12 21:31:32.000000000 +0100
++++ gstamp/gstamp_signals.c 2011-03-12 21:31:44.000000000 +0100
+@@ -3,6 +3,7 @@
+ ebw@city-net.com
+ */
+ #include <gtk/gtk.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include "gstamp.h"
+ #include "../lib/rcfile.h"
diff --git a/graphics/stamp/files/patch-gstamp_gstamp_ui.c b/graphics/stamp/files/patch-gstamp_gstamp_ui.c
new file mode 100644
index 000000000000..7a4380560404
--- /dev/null
+++ b/graphics/stamp/files/patch-gstamp_gstamp_ui.c
@@ -0,0 +1,7 @@
+--- gstamp/gstamp_ui.c.orig 2011-03-12 21:31:56.000000000 +0100
++++ gstamp/gstamp_ui.c 2011-03-12 21:32:20.000000000 +0100
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include "gstamp.h"
+
diff --git a/graphics/stamp/files/patch-lib_common.c b/graphics/stamp/files/patch-lib_common.c
new file mode 100644
index 000000000000..276b677f222c
--- /dev/null
+++ b/graphics/stamp/files/patch-lib_common.c
@@ -0,0 +1,9 @@
+--- lib/common.c.orig 2011-03-12 21:28:20.000000000 +0100
++++ lib/common.c 2011-03-12 21:28:30.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <jpeglib.h>
+ #include <setjmp.h>
+ #include "common.h"
diff --git a/graphics/stamp/files/patch-lib_transmogrify.c b/graphics/stamp/files/patch-lib_transmogrify.c
new file mode 100644
index 000000000000..204d77f11ba1
--- /dev/null
+++ b/graphics/stamp/files/patch-lib_transmogrify.c
@@ -0,0 +1,9 @@
+--- lib/transmogrify.c.orig 2011-03-12 21:28:42.000000000 +0100
++++ lib/transmogrify.c 2011-03-12 21:28:55.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <jpeglib.h>
+ #include "../lib/common.h"
+