aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-13 09:51:42 +0800
committeredwin <edwin@FreeBSD.org>2004-10-13 09:51:42 +0800
commit5ea30113fdff08c224333e8cc10db496edffadb8 (patch)
tree249a62671fe50af58ca502b345dcfb09bcb9c74f /graphics
parent93b0b4507524d09e7b691408449216cf66379860 (diff)
downloadfreebsd-ports-gnome-5ea30113fdff08c224333e8cc10db496edffadb8.tar.gz
freebsd-ports-gnome-5ea30113fdff08c224333e8cc10db496edffadb8.tar.zst
freebsd-ports-gnome-5ea30113fdff08c224333e8cc10db496edffadb8.zip
[MAINTAINER] graphics/lphoto: [Add option to use jpeg-mmx]
- Add option to use jpeg-mmx PR: ports/69836 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/lphoto/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/graphics/lphoto/Makefile b/graphics/lphoto/Makefile
index 2cad826f7e06..d57c776a5ec8 100644
--- a/graphics/lphoto/Makefile
+++ b/graphics/lphoto/Makefile
@@ -19,12 +19,32 @@ LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS= gphoto2:${PORTSDIR}/graphics/gphoto2 \
pyuic:${PORTSDIR}/x11-toolkits/py-qt
+USE_REINPLACE= yes
USE_KDELIBS_VER=3
USE_PYTHON= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+# Hack to use OPTIONS since OPTIONS is listed below bsd.port.pre.mk
+OPTIONS=
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+OPTIONS+= JPEGMMX "Use JPEG with MMX optimization" off
+.endif
+
+.if defined(WITH_JPEGMMX)
+RUN_DEPENDS+= jpegtran-mmx:${PORTSDIR}/graphics/jpeg-mmx
+.endif
+
+post-patch:
+.if defined(WITH_JPEGMMX)
+ @${REINPLACE_CMD} -e 's|jpegtran|jpegtran-mmx|' \
+ ${WRKSRC}/Lphoto/photolibrary.py
+.endif
+
do-install:
@cd ${WRKSRC} && ${PYTHON_CMD} install.py -d ${PREFIX}/${PYTHON_SITELIBDIR:S/${PYTHONBASE}//} -b ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>