aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-10-06 15:08:42 +0800
committersobomax <sobomax@FreeBSD.org>2001-10-06 15:08:42 +0800
commit5edbbe8a60ea379cc5e34ed21e02663db0dbfcfa (patch)
tree9c45d6b2bc6701e5022ff6b084f49b92707de904 /graphics
parent513710a41d503e48bdf41d7b766dc2d0bd15be9c (diff)
downloadfreebsd-ports-gnome-5edbbe8a60ea379cc5e34ed21e02663db0dbfcfa.tar.gz
freebsd-ports-gnome-5edbbe8a60ea379cc5e34ed21e02663db0dbfcfa.tar.zst
freebsd-ports-gnome-5edbbe8a60ea379cc5e34ed21e02663db0dbfcfa.zip
Add drm-kmod 0.9.2, a FreeBSD kernel modules for 3d acceleration
with the DRI. PR: 31081 Submitted by: Eric Anholt <eanholt@gladstone.uoregon.edu>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/drm-kmod/Makefile56
-rw-r--r--graphics/drm-kmod/distinfo1
-rw-r--r--graphics/drm-kmod/pkg-comment1
-rw-r--r--graphics/drm-kmod/pkg-descr6
-rw-r--r--graphics/drm-kmod/pkg-message21
-rw-r--r--graphics/drm-kmod/pkg-plist7
7 files changed, 93 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d58603661c7b..47e4180f5b4d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -30,6 +30,7 @@
SUBDIR += diacanvas
SUBDIR += divx4linux
SUBDIR += dore
+ SUBDIR += drm-kmod
SUBDIR += dumpmpeg
SUBDIR += ecg2png
SUBDIR += electriceyes
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
new file mode 100644
index 000000000000..c846d2900355
--- /dev/null
+++ b/graphics/drm-kmod/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: drm-kmod
+# Date created: 6 October 2001
+# Whom: Eric Anholt <eanholt@gladstone.uoregon.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drm-kmod
+PORTVERSION= 0.9.2
+CATEGORIES= graphics x11
+MASTER_SITES= http://gladstone.uoregon.edu/~eanholt/dri/
+
+MAINTAINER= eanholt@gladstone.uoregon.edu
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PKGMESSAGE= ${WRKSRC}/.MESSAGE
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400006
+BROKEN= "FreeBSD before 4.1 is not supported"
+.elif ${OSVERSION} < 500000
+.if defined(WITH_SMP)
+CFLAGS+= -DSMP -DAPIC_IO
+.endif
+.endif
+
+pre-extract:
+.if ${OSVERSION} < 500000
+.if !defined(WITH_SMP)
+ @${ECHO_MSG} "If you are using modules on an SMP system, define WITH_SMP to get SMP locking"
+ @${ECHO_MSG}
+.endif
+.endif
+
+pre-patch:
+ ${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/drm.sh
+
+pre-install:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > \
+ ${PKGMESSAGE}
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/drm
+ ${INSTALL_PROGRAM} ${WRKSRC}/tdfx/tdfx.ko ${PREFIX}/lib/drm/
+ ${INSTALL_PROGRAM} ${WRKSRC}/mga/mga.ko ${PREFIX}/lib/drm/
+ ${INSTALL_PROGRAM} ${WRKSRC}/r128/r128.ko ${PREFIX}/lib/drm/
+ ${INSTALL_PROGRAM} ${WRKSRC}/radeon/radeon.ko ${PREFIX}/lib/drm/
+ ${INSTALL_PROGRAM} ${WRKSRC}/gamma/gamma.ko ${PREFIX}/lib/drm/
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/drm.sh ${PREFIX}/etc/rc.d/drm.sh.sample
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/graphics/drm-kmod/distinfo b/graphics/drm-kmod/distinfo
new file mode 100644
index 000000000000..6a2c45d86e21
--- /dev/null
+++ b/graphics/drm-kmod/distinfo
@@ -0,0 +1 @@
+MD5 (drm-kmod-0.9.2.tar.gz) = b4397e2f0c6138992f2a43076ec70da9
diff --git a/graphics/drm-kmod/pkg-comment b/graphics/drm-kmod/pkg-comment
new file mode 100644
index 000000000000..a1463e51f7b3
--- /dev/null
+++ b/graphics/drm-kmod/pkg-comment
@@ -0,0 +1 @@
+A FreeBSD kernel modules for 3d acceleration with the DRI
diff --git a/graphics/drm-kmod/pkg-descr b/graphics/drm-kmod/pkg-descr
new file mode 100644
index 000000000000..b916deb66e73
--- /dev/null
+++ b/graphics/drm-kmod/pkg-descr
@@ -0,0 +1,6 @@
+FreeBSD DRM kernel modules for the Direct Rendering
+Infrastructure. With XFree86 4.0 they provide 3d
+acceleration under X for 3dfx Voodoo3/5/Banshee,
+Matrox G200 and G400, and ATI Rage128 and Radeon cards.
+
+WWW: http://gladstone.uoregon.edu/~eanholt/dri/
diff --git a/graphics/drm-kmod/pkg-message b/graphics/drm-kmod/pkg-message
new file mode 100644
index 000000000000..8b5543b40631
--- /dev/null
+++ b/graphics/drm-kmod/pkg-message
@@ -0,0 +1,21 @@
+-------------------------------------------------------------------------------
+To use the drivers, make a copy of %%PREFIX%%/etc/rc.d/drm.sh.sample under
+%%PREFIX%%/etc/rc.d/drm.sh.
+
+To load the drivers run (as root):
+
+# %%PREFIX%%/etc/rc.d/drm.sh start
+
+To unload it:
+
+# %%PREFIX%%/etc/rc.d/drm.sh stop
+
+It'll also load the drivers automatically when the system is started.
+Alternatively, you could add %%PREFIX%%/lib/drm to your kern.module_path sysctl
+and let XFree86 load the drivers for you.
+
+Once the modules are loaded, check http://gladstone.uoregon.edu/~eanholt/dri/
+for more information on how to set up the DRI.
+
+Please report problems to Eric Anholt <eanholt@gladstone.uoregon.edu>.
+-------------------------------------------------------------------------------
diff --git a/graphics/drm-kmod/pkg-plist b/graphics/drm-kmod/pkg-plist
new file mode 100644
index 000000000000..7026569f02e1
--- /dev/null
+++ b/graphics/drm-kmod/pkg-plist
@@ -0,0 +1,7 @@
+etc/rc.d/drm.sh.sample
+lib/drm/gamma.ko
+lib/drm/mga.ko
+lib/drm/r128.ko
+lib/drm/radeon.ko
+lib/drm/tdfx.ko
+@dirrm lib/drm