aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-07-11 01:10:14 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-07-11 01:10:14 +0800
commit699f6ba6f774c85d5047d2c9f7d437270b53989a (patch)
treea17f570c36618e512ff7c1a508d90ef28eeffafe /graphics
parentc97ddf5d3ebbf130c6d3321fdd913c32d0a2c4fb (diff)
downloadfreebsd-ports-gnome-699f6ba6f774c85d5047d2c9f7d437270b53989a.tar.gz
freebsd-ports-gnome-699f6ba6f774c85d5047d2c9f7d437270b53989a.tar.zst
freebsd-ports-gnome-699f6ba6f774c85d5047d2c9f7d437270b53989a.zip
- Use devel/swig30 instead of devel/swig20
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php-gdal/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/php-gdal/Makefile b/graphics/php-gdal/Makefile
index ed8e3601b5cb..a9906dfdcce2 100644
--- a/graphics/php-gdal/Makefile
+++ b/graphics/php-gdal/Makefile
@@ -14,7 +14,7 @@ COMMENT= PHP binding for GDAL
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig2.0:${PORTSDIR}/devel/swig20
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
ALL_TARGET= php_gdal.so php_gdalconst.so php_ogr.so php_osr.so
@@ -24,10 +24,11 @@ PHP_MOD_NAME= php_${PORTNAME}
USE_PHP= yes
USE_PHP_BUILD= yes
USES= gmake
+
WRKSRC= ${WRKDIR}/${DISTNAME}/swig/php
post-patch:
- @${REINPLACE_CMD} -e '/^SWIG = swig/ s|$$|2.0|' ${WRKSRC}/../SWIGmake.base
+ @${REINPLACE_CMD} -e '/^SWIG = swig/ s|$$|3.0|' ${WRKSRC}/../SWIGmake.base
@${REINPLACE_CMD} -e 's|^CC=.*$$|CC=${CC}|; s|^CXX=.*$$|CXX=${CXX}|; s|^CFLAGS=.*$$|CFLAGS=${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
# include/cpl_config.h will exist after build phase