aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-09-26 21:59:08 +0800
committergahr <gahr@FreeBSD.org>2008-09-26 21:59:08 +0800
commit7a1057ff3afb2d54e6247ffb40accd873b64dfe6 (patch)
treef6e1188eccc0eb5631a4d81c6114924895f416b7 /graphics
parentbf9d736357df0318413d35f66c3a635e50ace743 (diff)
downloadfreebsd-ports-gnome-7a1057ff3afb2d54e6247ffb40accd873b64dfe6.tar.gz
freebsd-ports-gnome-7a1057ff3afb2d54e6247ffb40accd873b64dfe6.tar.zst
freebsd-ports-gnome-7a1057ff3afb2d54e6247ffb40accd873b64dfe6.zip
- Fix ImageMagick libraries
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autotrace/Makefile2
-rw-r--r--graphics/autotrace/files/patch-configure11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index b62c70eda119..f4fd7a98acf6 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
MAN1= autotrace.1
diff --git a/graphics/autotrace/files/patch-configure b/graphics/autotrace/files/patch-configure
new file mode 100644
index 000000000000..0b2ac58b06b3
--- /dev/null
+++ b/graphics/autotrace/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-09-26 15:52:26.000000000 +0200
++++ configure 2008-09-26 15:52:09.000000000 +0200
+@@ -7973,7 +7973,7 @@
+ MAGICK_CFLAGS=${CPPFLAGS}
+ CPPFLAGS=${CPPFLAGS_BACKUP}
+ if test "x${magick_header_found}" = xyes ; then
+- MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs`"
++ MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs` `MagickWand-config --ldflags` `MagickWand-config --libs`"
+ echo "$as_me:$LINENO: checking ImageMagick - version >= 5.2.1" >&5
+ echo $ECHO_N "checking ImageMagick - version >= 5.2.1... $ECHO_C" >&6
+ MAGICK_VERSION=`Magick-config --version`