aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
committerbsam <bsam@FreeBSD.org>2013-09-05 04:01:05 +0800
commit7b5950ceb07fbf7baff9cf5f999cb870df39056d (patch)
tree293dcbc9c7e5b5460095f0f0b868e1ead9528ded /graphics
parentce8f3833463574b1140cd020d12c0b68cfcb0d83 (diff)
downloadfreebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.gz
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.tar.zst
freebsd-ports-gnome-7b5950ceb07fbf7baff9cf5f999cb870df39056d.zip
Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.
It's value is "--with-libiconv-prefix=/usr/local" for systems before 100043 with ports libiconv and to use at systems post 100043 with base iconv it's value is "" (NULL). Co-authors: bapt, madpilot and bsam (me)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/gdal/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 09b1603821b9..5922649ea721 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -44,7 +44,7 @@ GNU_CONFIGURE_ARGS+= --with-fontconfig=no
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
-GNU_CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+GNU_CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
.else
GNU_CONFIGURE_ARGS+= --without-libiconv
GNU_CONFIGURE_ARGS+= --with-libiconv-prefix=no
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index cd507a83300c..426f8776717e 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -90,7 +90,7 @@ CONFIGURE_ARGS+=--with-hdf5=no
.endif
.if ${PORT_OPTIONS:MICONV}
-CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+=${ICONV_CONFIGURE_ARG}
USES+= iconv
.else
CONFIGURE_ARGS+=--with-libiconv-prefix=no