aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2011-04-11 04:10:19 +0800
committermakc <makc@FreeBSD.org>2011-04-11 04:10:19 +0800
commit82c9048d6e634f72446fc470a89b6ebc44d452f5 (patch)
tree90f9c9471904c6144381f3a4e5dc97452b22c51d /graphics
parent98f55067706d27b68f244f598e059cae4063f69d (diff)
downloadfreebsd-ports-gnome-82c9048d6e634f72446fc470a89b6ebc44d452f5.tar.gz
freebsd-ports-gnome-82c9048d6e634f72446fc470a89b6ebc44d452f5.tar.zst
freebsd-ports-gnome-82c9048d6e634f72446fc470a89b6ebc44d452f5.zip
Update to 2.4.1
PR: based on ports/156055 Submitted by: Gvozdikov Veniamin (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zint/Makefile9
-rw-r--r--graphics/zint/distinfo5
-rw-r--r--graphics/zint/files/patch-backend_CMakeLists.txt13
-rw-r--r--graphics/zint/files/patch-backend_code1.c7
-rw-r--r--graphics/zint/files/patch-backend_maxicode.c7
-rw-r--r--graphics/zint/pkg-plist10
6 files changed, 20 insertions, 31 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
index 643d2197dc83..531a700c11ee 100644
--- a/graphics/zint/Makefile
+++ b/graphics/zint/Makefile
@@ -6,23 +6,20 @@
#
PORTNAME= zint
-PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTVERSION= 2.4.1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
-DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= g.veniamin@googlemail.com
COMMENT= Zint Barcode Generator
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LICENSE= GPLv3
+
USE_CMAKE= yes
-CMAKE_USE_PTHREAD= yes
USE_LDCONFIG= yes
USE_QT_VER= 4
QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build designer
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
.include <bsd.port.mk>
diff --git a/graphics/zint/distinfo b/graphics/zint/distinfo
index b51c6e68b3f0..89e4deb2f656 100644
--- a/graphics/zint/distinfo
+++ b/graphics/zint/distinfo
@@ -1,3 +1,2 @@
-MD5 (zint-2.3.1.src.tar.gz) = d8e12cc60505e3e89b99fc16ff6b38b8
-SHA256 (zint-2.3.1.src.tar.gz) = 2d997a9fb825370adedd2c0ad8491d79460635f707b9878d0e39f07b2a164388
-SIZE (zint-2.3.1.src.tar.gz) = 490520
+SHA256 (zint-2.4.1.tar.gz) = b609b79c80482e06ecaf30edf63489613e029d3d2df7fbd013bb1b294db2c401
+SIZE (zint-2.4.1.tar.gz) = 443412
diff --git a/graphics/zint/files/patch-backend_CMakeLists.txt b/graphics/zint/files/patch-backend_CMakeLists.txt
index e8d354cddcb8..c2c8447cf5e6 100644
--- a/graphics/zint/files/patch-backend_CMakeLists.txt
+++ b/graphics/zint/files/patch-backend_CMakeLists.txt
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- backend/CMakeLists.txt.orig
-+++ backend/CMakeLists.txt
+--- backend/CMakeLists.txt.orig 2011-03-30 15:13:56.000000000 +0800
++++ backend/CMakeLists.txt 2011-03-30 15:14:34.000000000 +0800
@@ -2,7 +2,8 @@
project(zint)
@@ -11,14 +8,14 @@ $FreeBSD$
+find_package(PNG REQUIRED)
+include_directories(${PNG_INCLUDE_DIR})
- set(zint_COMMON_SRCS common.c library.c ps.c large.c reedsol.c gs1.c svg.c png.c)
+ set(zint_COMMON_SRCS common.c library.c render.c ps.c large.c reedsol.c gs1.c svg.c png.c)
set(zint_ONEDIM_SRCS code.c code128.c 2of5.c upcean.c telepen.c medical.c plessey.c rss.c)
-@@ -21,7 +22,7 @@
+@@ -21,7 +22,7 @@ add_library(zint SHARED ${zint_SRCS})
set_target_properties(zint PROPERTIES SOVERSION "${ZINT_VERSION_MAJOR}.${ZINT_VERSION_MINOR}"
VERSION ${ZINT_VERSION})
-target_link_libraries(zint ${PNG_LIBRARIES} )
+target_link_libraries(zint ${PNG_LIBRARY} )
+ target_link_libraries(zint -lm)
install(TARGETS zint ${INSTALL_TARGETS_DEFAULT_ARGS} )
- install(FILES zint.h DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel)
diff --git a/graphics/zint/files/patch-backend_code1.c b/graphics/zint/files/patch-backend_code1.c
index f6a225480d6d..1be3e5599dac 100644
--- a/graphics/zint/files/patch-backend_code1.c
+++ b/graphics/zint/files/patch-backend_code1.c
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- backend/code1.c.orig
-+++ backend/code1.c
+--- backend/code1.c.orig 2011-03-30 15:18:25.000000000 +0800
++++ backend/code1.c 2011-03-30 15:18:35.000000000 +0800
@@ -28,7 +28,6 @@
#ifdef __APPLE__
#include <sys/malloc.h>
diff --git a/graphics/zint/files/patch-backend_maxicode.c b/graphics/zint/files/patch-backend_maxicode.c
index f6b242d32e50..2a587d33450b 100644
--- a/graphics/zint/files/patch-backend_maxicode.c
+++ b/graphics/zint/files/patch-backend_maxicode.c
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- backend/maxicode.c.orig
-+++ backend/maxicode.c
+--- backend/maxicode.c.orig 2011-03-30 15:17:49.000000000 +0800
++++ backend/maxicode.c 2011-03-30 15:18:15.000000000 +0800
@@ -29,7 +29,6 @@
#ifdef __APPLE__
#include <sys/malloc.h>
diff --git a/graphics/zint/pkg-plist b/graphics/zint/pkg-plist
index baff23a4888d..2734a427892d 100644
--- a/graphics/zint/pkg-plist
+++ b/graphics/zint/pkg-plist
@@ -3,9 +3,11 @@ bin/zint-qt
include/qzint.h
include/zint.h
lib/libQZint.so
-lib/libQZint.so.2.3
-lib/libQZint.so.2.3.1
+lib/libQZint.so.2.4
+lib/libQZint.so.2.4.1
lib/libzint.so
-lib/libzint.so.2.3
-lib/libzint.so.2.3.1
+lib/libzint.so.2.4
+lib/libzint.so.2.4.1
share/cmake/Modules/FindZint.cmake
+@dirrmtry share/cmake/Modules
+@dirrmtry share/cmake