aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-25 18:20:08 +0800
committerpav <pav@FreeBSD.org>2004-03-25 18:20:08 +0800
commit871f242b0938d1f2f59f4c7f2f1a49408596c6a7 (patch)
treec2eb25c940fdbd601523dcae9049788e2722412a /graphics
parent7efb23c0e217a7d43fc950f069e21e8dfd7d5eab (diff)
downloadfreebsd-ports-gnome-871f242b0938d1f2f59f4c7f2f1a49408596c6a7.tar.gz
freebsd-ports-gnome-871f242b0938d1f2f59f4c7f2f1a49408596c6a7.tar.zst
freebsd-ports-gnome-871f242b0938d1f2f59f4c7f2f1a49408596c6a7.zip
- Update to 0.3
PR: ports/64657 Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mingplot/Makefile2
-rw-r--r--graphics/mingplot/distinfo3
-rw-r--r--graphics/mingplot/files/patch-mingchart.rb69
3 files changed, 3 insertions, 71 deletions
diff --git a/graphics/mingplot/Makefile b/graphics/mingplot/Makefile
index ea4837ab8f78..a2b1f35ec28b 100644
--- a/graphics/mingplot/Makefile
+++ b/graphics/mingplot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mingplot
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/mingplot/
diff --git a/graphics/mingplot/distinfo b/graphics/mingplot/distinfo
index 6b8f4543661c..afcc8f9cf7fe 100644
--- a/graphics/mingplot/distinfo
+++ b/graphics/mingplot/distinfo
@@ -1 +1,2 @@
-MD5 (mingplot-0.2.tar.gz) = 7f54e5224f14f5e490617f540fafebe8
+MD5 (mingplot-0.3.tar.gz) = f2c53c6b90e79a5d543e8711fd744698
+SIZE (mingplot-0.3.tar.gz) = 47090
diff --git a/graphics/mingplot/files/patch-mingchart.rb b/graphics/mingplot/files/patch-mingchart.rb
deleted file mode 100644
index d06ca349995a..000000000000
--- a/graphics/mingplot/files/patch-mingchart.rb
+++ /dev/null
@@ -1,69 +0,0 @@
---- mingchart.rb.orig Fri Aug 15 10:06:17 2003
-+++ mingchart.rb Fri Aug 15 10:06:20 2003
-@@ -188,7 +188,7 @@
-
- def add_axises
- shape = SWFShape.new
-- shape.set_line(@axis_line_width, *@axis_line_color)
-+ shape.set_line(@axis_line_width, *@axis_line_color.to_a)
- shape.move_pen(@canvas_x_margin, @canvas_y_margin)
- shape.draw_line(0, @y_length)
- shape.draw_line(@x_length, 0)
-@@ -325,7 +325,7 @@
- item.move_to(xx + x_margin, yy + y_margin)
-
- line = SWFShape.new
-- line.set_line(@scale_line_width, *@scale_line_color)
-+ line.set_line(@scale_line_width, *@scale_line_color.to_a)
- line.move_pen_to(xx, yy)
- if at == :bottom
- line.draw_line(0, -@s...)
-@@ -354,7 +354,7 @@
- xx = convert_x(x)
- yy = @canvas_height - @canvas_y_margin
- line = SWFShape.new
-- line.set_line(@grid_line_width, *@grid_line_color)
-+ line.set_line(@grid_line_width, *@grid_line_color.to_a)
- line.move_pen_to(xx, yy)
- line.draw_line(0, -@y...)
- @movie.add(line)
-@@ -370,7 +370,7 @@
- xx = @canvas_x_margin
- yy = convert_y(y, side)
- line = SWFShape.new
-- line.set_line(@grid_line_width, *@grid_line_color)
-+ line.set_line(@grid_line_width, *@grid_line_color.to_a)
- line.move_pen_to(xx, yy)
- line.draw_line(@x_length, 0)
- @movie.add(line)
-@@ -424,7 +424,7 @@
-
- def draw_line (data, color, side, fill_p = false)
- line = SWFShape.new
-- line.set_line(@line_width, *color)
-+ line.set_line(@line_width, *color.to_a)
- first_time = true
-
- if fill_p
-@@ -549,8 +549,9 @@
- texts.push([text, width, height, lineno])
- }
-
-- total_height = texts.map {|x| x[2] }.inject(0) {|x, y|
-- x + y * @line_title_line_height_ratio
-+ total_height = 0
-+ texts.map {|x| x[2] }.each {|v|
-+ total_height += v * @line_title_line_height_ratio
- }
- max_width = texts.map {|x| x[1] }.max
-
-@@ -571,7 +572,7 @@
- base_y + height + height * i * @line_title_line_height_ratio)
-
- line = SWFShape.new
-- line.set_line(@line_width, *@line_colors[lineno])
-+ line.set_line(@line_width, *@line_colors[lineno].to_a)
- line.draw_line(@line_title_line_length, 0)
- item = @movie.add(line)
- item.move_to(base_x + @line_title_line_margin,
-