aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2010-03-26 07:11:22 +0800
committermarius <marius@FreeBSD.org>2010-03-26 07:11:22 +0800
commit9e559bc118e7dcf47eb96b66d3e98df925e0236a (patch)
treee7bb4d52fa3ae170ed63deb0ab488206864807f6 /graphics
parent0dad3a58ebf39db1b071326e5aacba020e0f999b (diff)
downloadfreebsd-ports-gnome-9e559bc118e7dcf47eb96b66d3e98df925e0236a.tar.gz
freebsd-ports-gnome-9e559bc118e7dcf47eb96b66d3e98df925e0236a.tar.zst
freebsd-ports-gnome-9e559bc118e7dcf47eb96b66d3e98df925e0236a.zip
Unbreak the Mesa3D 7.4.4 build for powerpc and sparc64 after the 7.6.1
integration. Approved by: rnoland
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dri/Makefile8
-rw-r--r--graphics/libGL/Makefile4
-rw-r--r--graphics/libGLU/Makefile4
-rw-r--r--graphics/libGLw/Makefile4
-rw-r--r--graphics/libglut/Makefile4
5 files changed, 12 insertions, 12 deletions
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index ca03f9e66935..5be5e9fb08f0 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -21,8 +21,8 @@ MAKE_JOBS_UNSAFE= yes
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
-.ifdef WITH_NOUVEAU
-EXTRA_PATCHES= mesalib74-configure
+.ifndef WITHOUT_NOUVEAU
+EXTRA_PATCHES+= ${FILESDIR}/mesalib74-configure
.endif
do-install:
@@ -32,8 +32,8 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not install on ia64 on sparc64
+.if ${ARCH} == "ia64"
+BROKEN= Does not install on ia64
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 6e7e99f84234..009d2c7a538a 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS+= drm:${PORTSDIR}/graphics/libdrm \
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto:both
-.ifdef WITH_NOUVEAU
-EXTRA_PATCHES= mesalib74-configure
+.ifndef WITHOUT_NOUVEAU
+EXTRA_PATCHES+= ${FILESDIR}/mesalib74-configure
.endif
do-install:
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index accdeb74936a..40dc3770c58c 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -14,8 +14,8 @@ COMMENT= OpenGL utility library
USE_GL= gl
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto
-.ifdef WITH_NOUVEAU
-EXTRA_PATCHES= mesalib74-configure
+.ifndef WITHOUT_NOUVEAU
+EXTRA_PATCHES+= ${FILESDIR}/mesalib74-configure
.endif
do-install:
diff --git a/graphics/libGLw/Makefile b/graphics/libGLw/Makefile
index 0801794354f4..84a2a30d0715 100644
--- a/graphics/libGLw/Makefile
+++ b/graphics/libGLw/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS+= Xm.3:${PORTSDIR}/x11-toolkits/open-motif
USE_GL= gl
USE_XORG= glproto xt x11 xext xxf86vm xdamage xfixes dri2proto
-.ifdef WITH_NOUVEAU
-EXTRA_PATCHES= mesalib74-configure
+.ifndef WITHOUT_NOUVEAU
+EXTRA_PATCHES+= ${FILESDIR}/mesalib74-configure
.endif
do-install:
diff --git a/graphics/libglut/Makefile b/graphics/libglut/Makefile
index 1e682c71a8be..033d82c9aa72 100644
--- a/graphics/libglut/Makefile
+++ b/graphics/libglut/Makefile
@@ -15,8 +15,8 @@ COMMENT= OpenGL utility toolkit
USE_GL= glu
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes xi xmu dri2proto
-.ifdef WITH_NOUVEAU
-EXTRA_PATCHES= mesalib74-configure
+.ifndef WITHOUT_NOUVEAU
+EXTRA_PATCHES+= ${FILESDIR}/mesalib74-configure
.endif
do-install: