aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-02 05:42:02 +0800
committerpav <pav@FreeBSD.org>2004-04-02 05:42:02 +0800
commitab66f431f8fd3be649efbaf2710470571ce33b72 (patch)
tree91649f1db0445e90d51fa3bf1d790e9ddd607b0a /graphics
parent61178120fb5d9b1213f8eb34619739ce242a4a54 (diff)
downloadfreebsd-ports-gnome-ab66f431f8fd3be649efbaf2710470571ce33b72.tar.gz
freebsd-ports-gnome-ab66f431f8fd3be649efbaf2710470571ce33b72.tar.zst
freebsd-ports-gnome-ab66f431f8fd3be649efbaf2710470571ce33b72.zip
- Respect ${CC} and ${CFLAGS}
PR: ports/65047 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glew/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/glew/Makefile b/graphics/glew/Makefile
index cb1222028fa3..1514bbbf9bc5 100644
--- a/graphics/glew/Makefile
+++ b/graphics/glew/Makefile
@@ -19,7 +19,13 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GL= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV= CC="${CC}"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' \
+ ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/glewinfo ${PREFIX}/bin