aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2007-12-22 23:16:31 +0800
committernork <nork@FreeBSD.org>2007-12-22 23:16:31 +0800
commitbbe32e311f9d5771e4bf6f76da7fa10125014190 (patch)
tree1e45d6921d1cbd5633f507828350d85bbd23b3cf /graphics
parent3c23c4f1c4ff76b1fcfc5873e604b761baf805a4 (diff)
downloadfreebsd-ports-gnome-bbe32e311f9d5771e4bf6f76da7fa10125014190.tar.gz
freebsd-ports-gnome-bbe32e311f9d5771e4bf6f76da7fa10125014190.tar.zst
freebsd-ports-gnome-bbe32e311f9d5771e4bf6f76da7fa10125014190.zip
Enable V4L (Video for Linux) compatible to use USB Camera.
Approved by: maintainer timeout (1 week)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opencv/Makefile6
-rw-r--r--graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp10
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 0da00ec76c2c..eaede051b127 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -8,7 +8,7 @@
PORTNAME= opencv
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= opencvlibrary
@@ -16,6 +16,8 @@ MASTER_SITE_SUBDIR= opencvlibrary
MAINTAINER= msabramo@yahoo.com
COMMENT= Open Source Computer Vision Library from Intel
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+
CFLAGS+= -I${LOCALBASE}/include/OpenEXR
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/OpenEXR
LDFLAGS+= -L${LOCALBASE}/lib
@@ -24,7 +26,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --without-v4l --without-quicktime --without-carbon \
+CONFIGURE_ARGS= --with-v4l --without-quicktime --without-carbon \
--without-1394libs \
--without-swig # I don't know anything about swig ...
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp b/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp
new file mode 100644
index 000000000000..21e6f22d1a3c
--- /dev/null
+++ b/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp
@@ -0,0 +1,10 @@
+--- otherlibs/highgui/cvcap_v4l.cpp.orig 2006-09-27 10:40:03.000000000 +0900
++++ otherlibs/highgui/cvcap_v4l.cpp 2007-12-15 14:44:37.000000000 +0900
+@@ -209,7 +209,6 @@
+
+ #include <string.h>
+ #include <stdlib.h>
+-#include <asm/types.h> /* for videodev2.h */
+ #include <assert.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>