aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-01-17 08:33:46 +0800
committernemysis <nemysis@FreeBSD.org>2014-01-17 08:33:46 +0800
commitd0784c7953974ae82ef0e9b9f4ba18f303332395 (patch)
treed0d4cb1a6a208d582e0c0907307df3135fafa228 /graphics
parentc283083eb3d36e16b6e6d5774e270809f81236ca (diff)
downloadfreebsd-ports-gnome-d0784c7953974ae82ef0e9b9f4ba18f303332395.tar.gz
freebsd-ports-gnome-d0784c7953974ae82ef0e9b9f4ba18f303332395.tar.zst
freebsd-ports-gnome-d0784c7953974ae82ef0e9b9f4ba18f303332395.zip
- Use the new format for LIB_DEPENDS
- Disable all warnings with -w - Support STAGEDIR - Add DOCS and EXAMPLES Options - Recreate patches with make makepatch
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pngwriter/Makefile28
-rw-r--r--graphics/pngwriter/files/patch-src__pngwriter.cc (renamed from graphics/pngwriter/files/patch-pngwriter.cc)4
2 files changed, 12 insertions, 20 deletions
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index 018f8f315b5d..19b8aa1c3cbd 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= C++ library for creating PNG images
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USES= pkgconfig
WRKSRC= ${WRKDIR}/${DISTNAME}
-CXXFLAGS+= `pkg-config --cflags freetype2 libpng15` -I${LOCALBASE}/include
+CXXFLAGS+= `pkg-config --cflags freetype2 libpng15` -I${LOCALBASE}/include -w
PLIST_FILES= include/pngwriter.h \
lib/libpngwriter.a \
@@ -29,8 +29,7 @@ PLIST_DIRS= %%DATADIR%%/fonts \
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
post-extract:
@${FIND} ${WRKSRC} -name "\.*" -delete
@@ -41,18 +40,11 @@ do-build:
&& ${AR} rv libpngwriter.a pngwriter.o
do-install:
- ${INSTALL_DATA} ${WRKSRC}/src/pngwriter.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/src/libpngwriter.a ${PREFIX}/lib
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} fonts ${DATADIR})
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/src/pngwriter.h ${STAGEDIR}${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/src/libpngwriter.a ${STAGEDIR}${PREFIX}/lib/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} fonts ${STAGEDIR}${DATADIR})
+
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/graphics/pngwriter/files/patch-pngwriter.cc b/graphics/pngwriter/files/patch-src__pngwriter.cc
index 135ab18302c3..48af638b78f6 100644
--- a/graphics/pngwriter/files/patch-pngwriter.cc
+++ b/graphics/pngwriter/files/patch-src__pngwriter.cc
@@ -1,5 +1,5 @@
---- src/pngwriter.cc.orig 2009-02-10 22:45:16.000000000 +0100
-+++ src/pngwriter.cc 2012-05-07 20:50:38.000000000 +0200
+--- ./src/pngwriter.cc.orig 2009-02-10 22:45:16.000000000 +0100
++++ ./src/pngwriter.cc 2014-01-17 01:17:46.000000000 +0100
@@ -988,19 +988,19 @@
time(&gmt);
png_convert_from_time_t(&mod_time, gmt);