aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-06-30 22:26:29 +0800
committertota <tota@FreeBSD.org>2011-06-30 22:26:29 +0800
commitd6418967c0b49e913c891a50c55f44bf9ed07a20 (patch)
tree6ae2057a6b9ebd3ed8d51faf52a02a13abbbc0f0 /graphics
parent55479dada12cf1fd509a4d15276dfc5ed806d8cb (diff)
downloadfreebsd-ports-gnome-d6418967c0b49e913c891a50c55f44bf9ed07a20.tar.gz
freebsd-ports-gnome-d6418967c0b49e913c891a50c55f44bf9ed07a20.tar.zst
freebsd-ports-gnome-d6418967c0b49e913c891a50c55f44bf9ed07a20.zip
- Remove OPTIONS because giflib and libpng dependencies have been mandatory
since 0.44 - Bump PORTREVISION
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php5-swfed/Makefile24
-rw-r--r--graphics/php5-swfed/files/patch-config-lib.m420
2 files changed, 4 insertions, 40 deletions
diff --git a/graphics/php5-swfed/Makefile b/graphics/php5-swfed/Makefile
index d073031d0eeb..4f68d1e70e22 100644
--- a/graphics/php5-swfed/Makefile
+++ b/graphics/php5-swfed/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swfed
PORTVERSION= 0.44
+PORTREVISION= 1
CATEGORIES= graphics www
MASTER_SITES= SFJP
MASTER_SITE_SUBDIR= ${PORTNAME}/52477
@@ -16,6 +17,8 @@ MAINTAINER= yoya@awm.jp
COMMENT= A PHP extension to edit SWF file
BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
+LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
+ png.6:${PORTSDIR}/graphics/png
DEFAULT_PHP_VER= 5
IGNORE_WITH_PHP= 4
@@ -30,25 +33,6 @@ PORTEXAMPLES= *
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-OPTIONS= GIF "With gif image support" on \
- PNG "With png image support" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_GIF)
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
-CONFIGURE_ARGS+= --with-gif-dir=yes
-.else
-CONFIGURE_ARGS+= --with-gif-dir=no
-.endif
-
-.if defined(WITH_PNG)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
-CONFIGURE_ARGS+= --with-png-dir=yes
-.else
-CONFIGURE_ARGS+= --with-png-dir=no
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -67,4 +51,4 @@ x-generate-plist:
${FIND} ${WWWDIR} -type d -depth | ${SORT} -r | ${SED} -e 's,${WWWDIR},@dirrm %%WWWDIR%%,g' >> pkg-plist.new
${ECHO} '@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/php5-swfed/files/patch-config-lib.m4 b/graphics/php5-swfed/files/patch-config-lib.m4
deleted file mode 100644
index 6cae29d3b217..000000000000
--- a/graphics/php5-swfed/files/patch-config-lib.m4
+++ /dev/null
@@ -1,20 +0,0 @@
---- config-lib.m4.orig 2010-04-20 10:09:36.000000000 +0900
-+++ config-lib.m4 2010-06-13 13:01:53.000000000 +0900
-@@ -70,7 +70,7 @@
- else
- AC_MSG_ERROR([Can't find LIBPNG headers under "$PHP_PNG_DIR"])
- fi
-- else
-+ elif test "$PHP_PNG_DIR" = "yes"; then
- for i in /usr/local /usr; do
- if test -f "$i/include/libpng/png.h"; then
- AC_DEFINE(HAVE_PNG,1,[ ])
-@@ -115,7 +115,7 @@
- else
- AC_MSG_ERROR([Can't find GIFLIB headers under "$PHP_GIF_DIR"])
- fi
-- else
-+ elif test "$PHP_GIF_DIR" = "yes"; then
- for i in /usr/local /usr; do
- if test -f "$i/include/giflib/gif_lib.h"; then
- AC_DEFINE(HAVE_GIF,1,[ ])