aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2006-09-11 22:24:53 +0800
committeroliver <oliver@FreeBSD.org>2006-09-11 22:24:53 +0800
commiteac5f43e9b211391aff0eb9e06482a40bb0047ef (patch)
tree539054c1c12193fa7d3ff0c0bfdee27e7bdef1ed /graphics
parent2bea4667f72ec2d87905db3a55eec137f2e873e6 (diff)
downloadfreebsd-ports-gnome-eac5f43e9b211391aff0eb9e06482a40bb0047ef.tar.gz
freebsd-ports-gnome-eac5f43e9b211391aff0eb9e06482a40bb0047ef.tar.zst
freebsd-ports-gnome-eac5f43e9b211391aff0eb9e06482a40bb0047ef.zip
update to 1.2.2.p1
PR: ports/101052 (partly)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ogre312/Makefile22
-rw-r--r--graphics/ogre312/distinfo6
-rw-r--r--graphics/ogre312/pkg-plist25
-rw-r--r--graphics/ogre3d/Makefile22
-rw-r--r--graphics/ogre3d/distinfo6
-rw-r--r--graphics/ogre3d/pkg-plist25
-rw-r--r--graphics/ogre3d12/Makefile22
-rw-r--r--graphics/ogre3d12/distinfo6
-rw-r--r--graphics/ogre3d12/pkg-plist25
9 files changed, 108 insertions, 51 deletions
diff --git a/graphics/ogre312/Makefile b/graphics/ogre312/Makefile
index c3c6380288e4..dae696891d06 100644
--- a/graphics/ogre312/Makefile
+++ b/graphics/ogre312/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= ogre3d
-PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTVERSION= 1.2.2.p1
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
-DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g}
+DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g:S/-p/p/}
MAINTAINER= oliver@FreeBSD.org
COMMENT= A scene-oriented, flexible 3D engine written in C++
@@ -20,23 +19,24 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
CEGUIBase.0:${PORTSDIR}/graphics/cegui
WRKSRC= ${WRKDIR}/ogrenew
-CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static
+CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
+ --with-cppunit-prefix=/nonexistent
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
-INSTALLS_SHLIB= YES
-USE_GCC= 3.4
+USE_LDCONFIG= YES
+USE_GCC= 3.4+
USE_BZIP2= YES
USE_X_PREFIX= YES
USE_GNOME= gnomehack
-USE_SDL= sdl
USE_GMAKE= YES
+USE_SDL= sdl
post-patch:
@${REINPLACE_CMD} -e '\
- s|sdl-config|${SDL_CONFIG}|g ;\
+ s|sdl-config|${SDL_CONFIG}|g; \
s|-lpthread|${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
- s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
- s|GLSUPPORT_CFLAGS=\$$SDL_CFLAGS|GLSUPPORT_CFLAGS="-I${X11BASE}/include \$$SDL_CFLAGS"|' \
+ s|-lGL -lGLU|-L${X11BASE}/lib &|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
${WRKSRC}/Samples/Gui/src/Gui.cpp \
@@ -54,6 +54,8 @@ post-patch:
${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
+ ${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
@${REINPLACE_CMD} -e '\
s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
${WRKSRC}/OgreMain/include/OgrePlatform.h
diff --git a/graphics/ogre312/distinfo b/graphics/ogre312/distinfo
index 1ed6b8df01ca..c3928e94b7fb 100644
--- a/graphics/ogre312/distinfo
+++ b/graphics/ogre312/distinfo
@@ -1,3 +1,3 @@
-MD5 (ogre-linux_osx-v1-0-7.tar.bz2) = 9120af9f10efddeb8c79bb9f46d9706c
-SHA256 (ogre-linux_osx-v1-0-7.tar.bz2) = e4dbd75feb877173f3cc9c83f10e4f5326affebc5833c4c0f49c349bfbda84af
-SIZE (ogre-linux_osx-v1-0-7.tar.bz2) = 18786151
+MD5 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 34004bdde39427e9a3213286f8cc057a
+SHA256 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 1c0c4f2a382301db1b7e89fc95e2a099a5a5891678923eabd0d72f26fc610547
+SIZE (ogre-linux_osx-v1-2-2p1.tar.bz2) = 22890671
diff --git a/graphics/ogre312/pkg-plist b/graphics/ogre312/pkg-plist
index 4ba70f2710a3..3528dfffff8d 100644
--- a/graphics/ogre312/pkg-plist
+++ b/graphics/ogre312/pkg-plist
@@ -2,15 +2,18 @@ bin/OgreMaterialUpgrade
bin/OgreMeshUpgrade
bin/OgreXMLConverter
include/OGRE/Ogre.h
+include/OGRE/OgreAnimable.h
include/OGRE/OgreAnimation.h
include/OGRE/OgreAnimationState.h
include/OGRE/OgreAnimationTrack.h
+include/OGRE/OgreAny.h
include/OGRE/OgreArchive.h
include/OGRE/OgreArchiveFactory.h
include/OGRE/OgreArchiveManager.h
include/OGRE/OgreAutoParamDataSource.h
include/OGRE/OgreAxisAlignedBox.h
include/OGRE/OgreBillboard.h
+include/OGRE/OgreBillboardChain.h
include/OGRE/OgreBillboardParticleRenderer.h
include/OGRE/OgreBillboardSet.h
include/OGRE/OgreBitwise.h
@@ -24,6 +27,16 @@ include/OGRE/OgreCamera.h
include/OGRE/OgreCodec.h
include/OGRE/OgreColourValue.h
include/OGRE/OgreCommon.h
+include/OGRE/OgreCompiler2Pass.h
+include/OGRE/OgreCompositionPass.h
+include/OGRE/OgreCompositionTargetPass.h
+include/OGRE/OgreCompositionTechnique.h
+include/OGRE/OgreCompositor.h
+include/OGRE/OgreCompositorChain.h
+include/OGRE/OgreCompositorInstance.h
+include/OGRE/OgreCompositorManager.h
+include/OGRE/OgreCompositorScriptCompiler.h
+include/OGRE/OgreCompositorSerializer.h
include/OGRE/OgreConfig.h
include/OGRE/OgreConfigDialog.h
include/OGRE/OgreConfigFile.h
@@ -76,6 +89,7 @@ include/OGRE/OgreKeyTarget.h
include/OGRE/OgreLight.h
include/OGRE/OgreLog.h
include/OGRE/OgreLogManager.h
+include/OGRE/OgreManualObject.h
include/OGRE/OgreMaterial.h
include/OGRE/OgreMaterialManager.h
include/OGRE/OgreMaterialSerializer.h
@@ -121,24 +135,26 @@ include/OGRE/OgrePlane.h
include/OGRE/OgrePlaneBoundedVolume.h
include/OGRE/OgrePlatform.h
include/OGRE/OgrePlatformManager.h
+include/OGRE/OgrePose.h
include/OGRE/OgrePositionTarget.h
include/OGRE/OgrePredefinedControllers.h
include/OGRE/OgrePrerequisites.h
include/OGRE/OgreProfiler.h
include/OGRE/OgreProgressiveMesh.h
include/OGRE/OgreQuaternion.h
+include/OGRE/OgreRadixSort.h
include/OGRE/OgreRay.h
include/OGRE/OgreRectangle.h
include/OGRE/OgreRectangle2D.h
include/OGRE/OgreRenderOperation.h
include/OGRE/OgreRenderQueue.h
+include/OGRE/OgreRenderQueueInvocation.h
include/OGRE/OgreRenderQueueListener.h
include/OGRE/OgreRenderQueueSortingGrouping.h
include/OGRE/OgreRenderSystem.h
include/OGRE/OgreRenderSystemCapabilities.h
include/OGRE/OgreRenderTarget.h
include/OGRE/OgreRenderTargetListener.h
-include/OGRE/OgreRenderTargetTexture.h
include/OGRE/OgreRenderTexture.h
include/OGRE/OgreRenderWindow.h
include/OGRE/OgreRenderable.h
@@ -146,6 +162,7 @@ include/OGRE/OgreResource.h
include/OGRE/OgreResourceBackgroundQueue.h
include/OGRE/OgreResourceGroupManager.h
include/OGRE/OgreResourceManager.h
+include/OGRE/OgreRibbonTrail.h
include/OGRE/OgreRoot.h
include/OGRE/OgreRotationalSpline.h
include/OGRE/OgreSceneManager.h
@@ -215,16 +232,16 @@ lib/libCEGUIOgreRenderer.so.0
lib/libOgreMain.a
lib/libOgreMain.la
lib/libOgreMain.so
-lib/libOgreMain.so.10
+lib/libOgreMain.so.11
lib/libOgrePlatform.a
lib/libOgrePlatform.la
lib/libOgrePlatform.so
libdata/pkgconfig/CEGUI-OGRE.pc
libdata/pkgconfig/OGRE.pc
share/OGRE/ogre-config.glade
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm include/OGRE
@dirrm lib/OGRE
@dirrm share/OGRE
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index c3c6380288e4..dae696891d06 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= ogre3d
-PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTVERSION= 1.2.2.p1
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
-DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g}
+DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g:S/-p/p/}
MAINTAINER= oliver@FreeBSD.org
COMMENT= A scene-oriented, flexible 3D engine written in C++
@@ -20,23 +19,24 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
CEGUIBase.0:${PORTSDIR}/graphics/cegui
WRKSRC= ${WRKDIR}/ogrenew
-CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static
+CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
+ --with-cppunit-prefix=/nonexistent
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
-INSTALLS_SHLIB= YES
-USE_GCC= 3.4
+USE_LDCONFIG= YES
+USE_GCC= 3.4+
USE_BZIP2= YES
USE_X_PREFIX= YES
USE_GNOME= gnomehack
-USE_SDL= sdl
USE_GMAKE= YES
+USE_SDL= sdl
post-patch:
@${REINPLACE_CMD} -e '\
- s|sdl-config|${SDL_CONFIG}|g ;\
+ s|sdl-config|${SDL_CONFIG}|g; \
s|-lpthread|${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
- s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
- s|GLSUPPORT_CFLAGS=\$$SDL_CFLAGS|GLSUPPORT_CFLAGS="-I${X11BASE}/include \$$SDL_CFLAGS"|' \
+ s|-lGL -lGLU|-L${X11BASE}/lib &|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
${WRKSRC}/Samples/Gui/src/Gui.cpp \
@@ -54,6 +54,8 @@ post-patch:
${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
+ ${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
@${REINPLACE_CMD} -e '\
s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
${WRKSRC}/OgreMain/include/OgrePlatform.h
diff --git a/graphics/ogre3d/distinfo b/graphics/ogre3d/distinfo
index 1ed6b8df01ca..c3928e94b7fb 100644
--- a/graphics/ogre3d/distinfo
+++ b/graphics/ogre3d/distinfo
@@ -1,3 +1,3 @@
-MD5 (ogre-linux_osx-v1-0-7.tar.bz2) = 9120af9f10efddeb8c79bb9f46d9706c
-SHA256 (ogre-linux_osx-v1-0-7.tar.bz2) = e4dbd75feb877173f3cc9c83f10e4f5326affebc5833c4c0f49c349bfbda84af
-SIZE (ogre-linux_osx-v1-0-7.tar.bz2) = 18786151
+MD5 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 34004bdde39427e9a3213286f8cc057a
+SHA256 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 1c0c4f2a382301db1b7e89fc95e2a099a5a5891678923eabd0d72f26fc610547
+SIZE (ogre-linux_osx-v1-2-2p1.tar.bz2) = 22890671
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index 4ba70f2710a3..3528dfffff8d 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -2,15 +2,18 @@ bin/OgreMaterialUpgrade
bin/OgreMeshUpgrade
bin/OgreXMLConverter
include/OGRE/Ogre.h
+include/OGRE/OgreAnimable.h
include/OGRE/OgreAnimation.h
include/OGRE/OgreAnimationState.h
include/OGRE/OgreAnimationTrack.h
+include/OGRE/OgreAny.h
include/OGRE/OgreArchive.h
include/OGRE/OgreArchiveFactory.h
include/OGRE/OgreArchiveManager.h
include/OGRE/OgreAutoParamDataSource.h
include/OGRE/OgreAxisAlignedBox.h
include/OGRE/OgreBillboard.h
+include/OGRE/OgreBillboardChain.h
include/OGRE/OgreBillboardParticleRenderer.h
include/OGRE/OgreBillboardSet.h
include/OGRE/OgreBitwise.h
@@ -24,6 +27,16 @@ include/OGRE/OgreCamera.h
include/OGRE/OgreCodec.h
include/OGRE/OgreColourValue.h
include/OGRE/OgreCommon.h
+include/OGRE/OgreCompiler2Pass.h
+include/OGRE/OgreCompositionPass.h
+include/OGRE/OgreCompositionTargetPass.h
+include/OGRE/OgreCompositionTechnique.h
+include/OGRE/OgreCompositor.h
+include/OGRE/OgreCompositorChain.h
+include/OGRE/OgreCompositorInstance.h
+include/OGRE/OgreCompositorManager.h
+include/OGRE/OgreCompositorScriptCompiler.h
+include/OGRE/OgreCompositorSerializer.h
include/OGRE/OgreConfig.h
include/OGRE/OgreConfigDialog.h
include/OGRE/OgreConfigFile.h
@@ -76,6 +89,7 @@ include/OGRE/OgreKeyTarget.h
include/OGRE/OgreLight.h
include/OGRE/OgreLog.h
include/OGRE/OgreLogManager.h
+include/OGRE/OgreManualObject.h
include/OGRE/OgreMaterial.h
include/OGRE/OgreMaterialManager.h
include/OGRE/OgreMaterialSerializer.h
@@ -121,24 +135,26 @@ include/OGRE/OgrePlane.h
include/OGRE/OgrePlaneBoundedVolume.h
include/OGRE/OgrePlatform.h
include/OGRE/OgrePlatformManager.h
+include/OGRE/OgrePose.h
include/OGRE/OgrePositionTarget.h
include/OGRE/OgrePredefinedControllers.h
include/OGRE/OgrePrerequisites.h
include/OGRE/OgreProfiler.h
include/OGRE/OgreProgressiveMesh.h
include/OGRE/OgreQuaternion.h
+include/OGRE/OgreRadixSort.h
include/OGRE/OgreRay.h
include/OGRE/OgreRectangle.h
include/OGRE/OgreRectangle2D.h
include/OGRE/OgreRenderOperation.h
include/OGRE/OgreRenderQueue.h
+include/OGRE/OgreRenderQueueInvocation.h
include/OGRE/OgreRenderQueueListener.h
include/OGRE/OgreRenderQueueSortingGrouping.h
include/OGRE/OgreRenderSystem.h
include/OGRE/OgreRenderSystemCapabilities.h
include/OGRE/OgreRenderTarget.h
include/OGRE/OgreRenderTargetListener.h
-include/OGRE/OgreRenderTargetTexture.h
include/OGRE/OgreRenderTexture.h
include/OGRE/OgreRenderWindow.h
include/OGRE/OgreRenderable.h
@@ -146,6 +162,7 @@ include/OGRE/OgreResource.h
include/OGRE/OgreResourceBackgroundQueue.h
include/OGRE/OgreResourceGroupManager.h
include/OGRE/OgreResourceManager.h
+include/OGRE/OgreRibbonTrail.h
include/OGRE/OgreRoot.h
include/OGRE/OgreRotationalSpline.h
include/OGRE/OgreSceneManager.h
@@ -215,16 +232,16 @@ lib/libCEGUIOgreRenderer.so.0
lib/libOgreMain.a
lib/libOgreMain.la
lib/libOgreMain.so
-lib/libOgreMain.so.10
+lib/libOgreMain.so.11
lib/libOgrePlatform.a
lib/libOgrePlatform.la
lib/libOgrePlatform.so
libdata/pkgconfig/CEGUI-OGRE.pc
libdata/pkgconfig/OGRE.pc
share/OGRE/ogre-config.glade
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm include/OGRE
@dirrm lib/OGRE
@dirrm share/OGRE
diff --git a/graphics/ogre3d12/Makefile b/graphics/ogre3d12/Makefile
index c3c6380288e4..dae696891d06 100644
--- a/graphics/ogre3d12/Makefile
+++ b/graphics/ogre3d12/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= ogre3d
-PORTVERSION= 1.0.7
-PORTREVISION= 1
+PORTVERSION= 1.2.2.p1
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=ogre
-DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g}
+DISTNAME= ogre-linux_osx-v${PORTVERSION:S/./-/g:S/-p/p/}
MAINTAINER= oliver@FreeBSD.org
COMMENT= A scene-oriented, flexible 3D engine written in C++
@@ -20,23 +19,24 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
CEGUIBase.0:${PORTSDIR}/graphics/cegui
WRKSRC= ${WRKDIR}/ogrenew
-CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static
+CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static --with-platform=SDL \
+ --with-cppunit-prefix=/nonexistent
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG"
GNU_CONFIGURE= YES
-INSTALLS_SHLIB= YES
-USE_GCC= 3.4
+USE_LDCONFIG= YES
+USE_GCC= 3.4+
USE_BZIP2= YES
USE_X_PREFIX= YES
USE_GNOME= gnomehack
-USE_SDL= sdl
USE_GMAKE= YES
+USE_SDL= sdl
post-patch:
@${REINPLACE_CMD} -e '\
- s|sdl-config|${SDL_CONFIG}|g ;\
+ s|sdl-config|${SDL_CONFIG}|g; \
s|-lpthread|${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
- s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
- s|GLSUPPORT_CFLAGS=\$$SDL_CFLAGS|GLSUPPORT_CFLAGS="-I${X11BASE}/include \$$SDL_CFLAGS"|' \
+ s|-lGL -lGLU|-L${X11BASE}/lib &|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
${WRKSRC}/Samples/Gui/src/Gui.cpp \
@@ -54,6 +54,8 @@ post-patch:
${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|(CEGUI::uint)|(size_t)|' \
+ ${WRKSRC}/Samples/OceanDemo/src/OceanDemo.cpp
@${REINPLACE_CMD} -e '\
s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
${WRKSRC}/OgreMain/include/OgrePlatform.h
diff --git a/graphics/ogre3d12/distinfo b/graphics/ogre3d12/distinfo
index 1ed6b8df01ca..c3928e94b7fb 100644
--- a/graphics/ogre3d12/distinfo
+++ b/graphics/ogre3d12/distinfo
@@ -1,3 +1,3 @@
-MD5 (ogre-linux_osx-v1-0-7.tar.bz2) = 9120af9f10efddeb8c79bb9f46d9706c
-SHA256 (ogre-linux_osx-v1-0-7.tar.bz2) = e4dbd75feb877173f3cc9c83f10e4f5326affebc5833c4c0f49c349bfbda84af
-SIZE (ogre-linux_osx-v1-0-7.tar.bz2) = 18786151
+MD5 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 34004bdde39427e9a3213286f8cc057a
+SHA256 (ogre-linux_osx-v1-2-2p1.tar.bz2) = 1c0c4f2a382301db1b7e89fc95e2a099a5a5891678923eabd0d72f26fc610547
+SIZE (ogre-linux_osx-v1-2-2p1.tar.bz2) = 22890671
diff --git a/graphics/ogre3d12/pkg-plist b/graphics/ogre3d12/pkg-plist
index 4ba70f2710a3..3528dfffff8d 100644
--- a/graphics/ogre3d12/pkg-plist
+++ b/graphics/ogre3d12/pkg-plist
@@ -2,15 +2,18 @@ bin/OgreMaterialUpgrade
bin/OgreMeshUpgrade
bin/OgreXMLConverter
include/OGRE/Ogre.h
+include/OGRE/OgreAnimable.h
include/OGRE/OgreAnimation.h
include/OGRE/OgreAnimationState.h
include/OGRE/OgreAnimationTrack.h
+include/OGRE/OgreAny.h
include/OGRE/OgreArchive.h
include/OGRE/OgreArchiveFactory.h
include/OGRE/OgreArchiveManager.h
include/OGRE/OgreAutoParamDataSource.h
include/OGRE/OgreAxisAlignedBox.h
include/OGRE/OgreBillboard.h
+include/OGRE/OgreBillboardChain.h
include/OGRE/OgreBillboardParticleRenderer.h
include/OGRE/OgreBillboardSet.h
include/OGRE/OgreBitwise.h
@@ -24,6 +27,16 @@ include/OGRE/OgreCamera.h
include/OGRE/OgreCodec.h
include/OGRE/OgreColourValue.h
include/OGRE/OgreCommon.h
+include/OGRE/OgreCompiler2Pass.h
+include/OGRE/OgreCompositionPass.h
+include/OGRE/OgreCompositionTargetPass.h
+include/OGRE/OgreCompositionTechnique.h
+include/OGRE/OgreCompositor.h
+include/OGRE/OgreCompositorChain.h
+include/OGRE/OgreCompositorInstance.h
+include/OGRE/OgreCompositorManager.h
+include/OGRE/OgreCompositorScriptCompiler.h
+include/OGRE/OgreCompositorSerializer.h
include/OGRE/OgreConfig.h
include/OGRE/OgreConfigDialog.h
include/OGRE/OgreConfigFile.h
@@ -76,6 +89,7 @@ include/OGRE/OgreKeyTarget.h
include/OGRE/OgreLight.h
include/OGRE/OgreLog.h
include/OGRE/OgreLogManager.h
+include/OGRE/OgreManualObject.h
include/OGRE/OgreMaterial.h
include/OGRE/OgreMaterialManager.h
include/OGRE/OgreMaterialSerializer.h
@@ -121,24 +135,26 @@ include/OGRE/OgrePlane.h
include/OGRE/OgrePlaneBoundedVolume.h
include/OGRE/OgrePlatform.h
include/OGRE/OgrePlatformManager.h
+include/OGRE/OgrePose.h
include/OGRE/OgrePositionTarget.h
include/OGRE/OgrePredefinedControllers.h
include/OGRE/OgrePrerequisites.h
include/OGRE/OgreProfiler.h
include/OGRE/OgreProgressiveMesh.h
include/OGRE/OgreQuaternion.h
+include/OGRE/OgreRadixSort.h
include/OGRE/OgreRay.h
include/OGRE/OgreRectangle.h
include/OGRE/OgreRectangle2D.h
include/OGRE/OgreRenderOperation.h
include/OGRE/OgreRenderQueue.h
+include/OGRE/OgreRenderQueueInvocation.h
include/OGRE/OgreRenderQueueListener.h
include/OGRE/OgreRenderQueueSortingGrouping.h
include/OGRE/OgreRenderSystem.h
include/OGRE/OgreRenderSystemCapabilities.h
include/OGRE/OgreRenderTarget.h
include/OGRE/OgreRenderTargetListener.h
-include/OGRE/OgreRenderTargetTexture.h
include/OGRE/OgreRenderTexture.h
include/OGRE/OgreRenderWindow.h
include/OGRE/OgreRenderable.h
@@ -146,6 +162,7 @@ include/OGRE/OgreResource.h
include/OGRE/OgreResourceBackgroundQueue.h
include/OGRE/OgreResourceGroupManager.h
include/OGRE/OgreResourceManager.h
+include/OGRE/OgreRibbonTrail.h
include/OGRE/OgreRoot.h
include/OGRE/OgreRotationalSpline.h
include/OGRE/OgreSceneManager.h
@@ -215,16 +232,16 @@ lib/libCEGUIOgreRenderer.so.0
lib/libOgreMain.a
lib/libOgreMain.la
lib/libOgreMain.so
-lib/libOgreMain.so.10
+lib/libOgreMain.so.11
lib/libOgrePlatform.a
lib/libOgrePlatform.la
lib/libOgrePlatform.so
libdata/pkgconfig/CEGUI-OGRE.pc
libdata/pkgconfig/OGRE.pc
share/OGRE/ogre-config.glade
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm include/OGRE
@dirrm lib/OGRE
@dirrm share/OGRE