aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-03-14 00:13:31 +0800
committermiwi <miwi@FreeBSD.org>2008-03-14 00:13:31 +0800
commited0ed549c93f3f5c92c6d28edc5bd5721504dfe0 (patch)
tree6891fe62fa1f6b70f8261b38cb3f1e2c08b60a6e /graphics
parent2f1518cdd3b30b44552dfbb95364d4542cddd1dd (diff)
downloadfreebsd-ports-gnome-ed0ed549c93f3f5c92c6d28edc5bd5721504dfe0.tar.gz
freebsd-ports-gnome-ed0ed549c93f3f5c92c6d28edc5bd5721504dfe0.tar.zst
freebsd-ports-gnome-ed0ed549c93f3f5c92c6d28edc5bd5721504dfe0.zip
- Add ONLY_FOR_ARCHS
Notes: The software uses SSE, so it won't compile on sparc64; add proper ONLY_FOR_ARCHS and ONLY_FOR_ARCHS_REASON PR: 121551 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sharpconstruct/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/sharpconstruct/Makefile b/graphics/sharpconstruct/Makefile
index aa1dcc6c7a65..808583ccfbad 100644
--- a/graphics/sharpconstruct/Makefile
+++ b/graphics/sharpconstruct/Makefile
@@ -24,14 +24,12 @@ USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAN1= sharpconstruct.1
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= uses SSE
-.include <bsd.port.pre.mk>
+MAN1= sharpconstruct.1
post-patch:
-.if ${ARCH} != "i386" && ${ARCH} != "amd64"
- @${REINPLACE_CMD} -e 's|-msse||' ${WRKSRC}/src/Makefile*
-.endif
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/include/Align.hh
@${REINPLACE_CMD} -e 's|"/sharpconstruct|"|' ${WRKSRC}/src/MainWindow.cc
@${REINPLACE_CMD} -e 's|/usr/share/sharpconstruct|${DATADIR}|' ${WRKSRC}/src/MainWindow.cc
@@ -40,4 +38,4 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e '/^DEFS / s|$$| -DDATADIR=\\"${DATADIR}\\"|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>