aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-06 03:15:41 +0800
committermarino <marino@FreeBSD.org>2014-07-06 03:15:41 +0800
commitf2934f81eededb8e3485eca925041c0c353442a8 (patch)
treedda573c015329ad03b6dd29c596e752f5b6e968f /graphics
parentf057cd4b2d903cbbded3a734de1cfe8320a2e8f5 (diff)
downloadfreebsd-ports-gnome-f2934f81eededb8e3485eca925041c0c353442a8.tar.gz
freebsd-ports-gnome-f2934f81eededb8e3485eca925041c0c353442a8.tar.zst
freebsd-ports-gnome-f2934f81eededb8e3485eca925041c0c353442a8.zip
graphics/timeless: stage and explicit linking with -lm (dports)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/timeless/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/timeless/Makefile b/graphics/timeless/Makefile
index 99ef4874a435..ff9324d53341 100644
--- a/graphics/timeless/Makefile
+++ b/graphics/timeless/Makefile
@@ -12,9 +12,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= FreeBSD/SDL port of Tran's Timeless Demo with Sound
USE_SDL= sdl mixer
+LDFLAGS+= -lm
-PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/time.s3m
+PLIST_FILES= bin/timeless %%DATADIR%%/time.s3m
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/timeless ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/time.s3m ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>