aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-03-08 05:15:14 +0800
committerdinoex <dinoex@FreeBSD.org>2011-03-08 05:15:14 +0800
commitfadf7c5c69994d11092c84e86cc931584ca0b898 (patch)
tree50e1d3eaaa355e38a333597242ccd3e6045242dc /graphics
parent10b851305dd74509e70044f7c804d83eb29b40a2 (diff)
downloadfreebsd-ports-gnome-fadf7c5c69994d11092c84e86cc931584ca0b898.tar.gz
freebsd-ports-gnome-fadf7c5c69994d11092c84e86cc931584ca0b898.tar.zst
freebsd-ports-gnome-fadf7c5c69994d11092c84e86cc931584ca0b898.zip
- fix ruby pluging with ruby19
PR: 155114 Submitted by: Scot Hetzel
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphviz/Makefile1
-rw-r--r--graphics/graphviz/files/patch-configure24
2 files changed, 21 insertions, 4 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 58337e6e3338..ac509d3ab036 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -331,6 +331,7 @@ PLIST_SUB+= WITH_PYTHON="@comment "
.if defined(WITH_RUBY)
CONFIGURE_ARGS+= --enable-ruby
+CONFIGURE_ENV+= RUBY="${RUBY}"
PLIST_SUB+= WITH_RUBY=""
USE_RUBY= yes
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
diff --git a/graphics/graphviz/files/patch-configure b/graphics/graphviz/files/patch-configure
index 7b1d02b10fdf..fbe154990031 100644
--- a/graphics/graphviz/files/patch-configure
+++ b/graphics/graphviz/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-10-08 01:54:55.000000000 +0200
-+++ configure 2009-02-27 11:12:03.000000000 +0100
-@@ -6481,6 +6481,9 @@
+--- configure.orig 2010-01-26 16:01:10.000000000 +0000
++++ configure 2011-02-28 06:36:25.156165774 +0000
+@@ -6917,6 +6917,9 @@
*-apple-darwin* )
CFLAGS="${CFLAGS} -fno-common -Wall"
;;
@@ -10,7 +10,7 @@
*-freebsd* )
CFLAGS="${CFLAGS} -Wstrict-prototypes -Wpointer-arith -Wall -ffast-math"
;;
-@@ -26247,7 +26250,9 @@
+@@ -24803,7 +24806,9 @@
LUA_INCLUDES=""
LUA_LIBS=""
@@ -21,3 +21,19 @@
if test -n "$lua_inc"; then
CFLAGS="$CFLAGS -I$lua_inc"
+@@ -27574,7 +27579,14 @@
+ if test "x$RUBY" = "x"; then
+ use_ruby="No (ruby not available)"
+ else
+- RUBY_INCLUDES="-I`$RUBY $srcdir/config/config_ruby.rb INCLUDES`"
++ RUBY_VER="`$RUBY -rrbconfig -e \"puts Config::CONFIG['ruby_version']\"`"
++ if test "x$RUBY_VER" = "x1.8"; then
++ RUBY_INCLUDES="-I`$RUBY $srcdir/config/config_ruby.rb INCLUDES`"
++ else
++ RUBY_INC="`$RUBY -rrbconfig -e \"puts Config::CONFIG['rubyhdrdir']\"`"
++ RUBY_ARCH="`$RUBY -rrbconfig -e \"puts Config::CONFIG['arch']\"`"
++ RUBY_INCLUDES="-I$RUBY_INC -I$RUBY_INC/$RUBY_ARCH"
++ fi
+ # hack for powerpc-darwin8 (10.4)
+ RUBY_INCLUDES=`echo $RUBY_INCLUDES | sed 's/powerpc/universal/'`
+ RUBY_LIBS="-L`$RUBY $srcdir/config/config_ruby.rb lib` `$RUBY -rrbconfig -e \"puts Config::CONFIG['LIBRUBYARG_SHARED']\"`"