aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-03-04 04:38:30 +0800
committerasami <asami@FreeBSD.org>2000-03-04 04:38:30 +0800
commitfb14a21d76f4a29efdab086fe7276e55cbba3d35 (patch)
tree38c5fd2ab495eb6edaea7d3ef346f5da1f4e1f6f /graphics
parent612dc69322519984958de39cbf5971134975aaa3 (diff)
downloadfreebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.tar.gz
freebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.tar.zst
freebsd-ports-gnome-fb14a21d76f4a29efdab086fe7276e55cbba3d35.zip
Add -L${LOCALBASE}/lib in front of -ltiff and stuff in imlib-config;
without it, ports (like astro/xplanet) that only require X-related stuff will fail (since they will only put -L${X11BASE}/lib in the linker command line).
Diffstat (limited to 'graphics')
-rw-r--r--graphics/imlib/Makefile3
-rw-r--r--graphics/imlib/files/patch-ab11
-rw-r--r--graphics/imlib2-tmp/Makefile3
-rw-r--r--graphics/imlib2/Makefile3
4 files changed, 20 insertions, 0 deletions
diff --git a/graphics/imlib/Makefile b/graphics/imlib/Makefile
index c1c07d8c0d03..43cf654facf2 100644
--- a/graphics/imlib/Makefile
+++ b/graphics/imlib/Makefile
@@ -30,4 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
--disable-gtktest
+pre-configure:
+ ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+
.include <bsd.port.mk>
diff --git a/graphics/imlib/files/patch-ab b/graphics/imlib/files/patch-ab
new file mode 100644
index 000000000000..ed31cf167d97
--- /dev/null
+++ b/graphics/imlib/files/patch-ab
@@ -0,0 +1,11 @@
+--- ./imlib-config.in.org Thu Aug 26 08:09:25 1999
++++ ./imlib-config.in Fri Mar 3 11:08:41 2000
+@@ -3,7 +3,7 @@
+ # Shamelessly ripped form gtk's gtk-config.in
+ #
+
+-gx_libs="@SUPPORT_LIBS@"
++gx_libs="-L%%LOCALBASE%%/lib @SUPPORT_LIBS@"
+ gdk_gx_libs=" @GDK_SUPPORT_LIBS@"
+ gdk_libs="@LIBS@"
+
diff --git a/graphics/imlib2-tmp/Makefile b/graphics/imlib2-tmp/Makefile
index c1c07d8c0d03..43cf654facf2 100644
--- a/graphics/imlib2-tmp/Makefile
+++ b/graphics/imlib2-tmp/Makefile
@@ -30,4 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
--disable-gtktest
+pre-configure:
+ ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+
.include <bsd.port.mk>
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index c1c07d8c0d03..43cf654facf2 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -30,4 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/imlib \
--disable-gtktest
+pre-configure:
+ ${PERL} -pi -e "s^%%LOCALBASE%%^${LOCALBASE}^" ${WRKSRC}/imlib-config.in
+
.include <bsd.port.mk>